summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-09-29 08:48:16 +0000
committerMike Frysinger <vapier@gentoo.org>2005-09-29 08:48:16 +0000
commit3b9bfb4d6d6be8216c80488cad2f286a178429e9 (patch)
tree85714398af4cccd7215b4529e85a6c68fbbaedfc /sys-devel
parentold (diff)
downloadgentoo-2-3b9bfb4d6d6be8216c80488cad2f286a178429e9.tar.gz
gentoo-2-3b9bfb4d6d6be8216c80488cad2f286a178429e9.tar.bz2
gentoo-2-3b9bfb4d6d6be8216c80488cad2f286a178429e9.zip
Add patch to fix rules with subdirs #107435 by John Ratliff.
(Portage version: 2.0.52-r1 http://www.bash.org/?136501 )
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/automake/ChangeLog8
-rw-r--r--sys-devel/automake/automake-1.9.6-r1.ebuild48
-rw-r--r--sys-devel/automake/files/automake-1.9.6-include-dir-prefix.patch31
-rw-r--r--sys-devel/automake/files/digest-automake-1.9.6-r11
4 files changed, 87 insertions, 1 deletions
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 07e928605106..8d21aa53bf5c 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/automake
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.75 2005/07/11 04:48:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.76 2005/09/29 08:48:16 vapier Exp $
+
+*automake-1.9.6-r1 (29 Sep 2005)
+
+ 29 Sep 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/automake-1.9.6-include-dir-prefix.patch, +automake-1.9.6-r1.ebuild:
+ Add patch to fix rules with subdirs #107435 by John Ratliff.
*automake-1.9.6 (11 Jul 2005)
diff --git a/sys-devel/automake/automake-1.9.6-r1.ebuild b/sys-devel/automake/automake-1.9.6-r1.ebuild
new file mode 100644
index 000000000000..89956a3d4b9a
--- /dev/null
+++ b/sys-devel/automake/automake-1.9.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.9.6-r1.ebuild,v 1.1 2005/09/29 08:48:16 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://sources.redhat.com/automake/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="${PV:0:3}"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ~ppc-macos s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ sys-devel/automake-wrapper
+ >=sys-devel/autoconf-2.59-r6
+ >=sys-apps/texinfo-4.7
+ sys-devel/gnuconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^@setfilename/s|automake|automake${SLOT}|" \
+ -e "s|automake: (automake)|automake v${SLOT}: (automake${SLOT})|" \
+ -e "s|aclocal: (automake)|aclocal v${SLOT}: (automake${SLOT})|" \
+ doc/automake.texi || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-1.9.6-infopage-namechange.patch
+ epatch "${FILESDIR}"/${P}-include-dir-prefix.patch #107435
+ export WANT_AUTOCONF=2.5
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ rm -f "${D}"/usr/bin/{aclocal,automake}
+
+ dodoc NEWS README THANKS TODO AUTHORS ChangeLog
+ doinfo doc/*.info*
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ local x=
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}
diff --git a/sys-devel/automake/files/automake-1.9.6-include-dir-prefix.patch b/sys-devel/automake/files/automake-1.9.6-include-dir-prefix.patch
new file mode 100644
index 000000000000..a1d62a78e119
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.9.6-include-dir-prefix.patch
@@ -0,0 +1,31 @@
+http://bugs.gentoo.org/107435
+http://lists.gnu.org/archive/html/automake/2005-09/msg00088.html
+
+2005-09-27 Stepan Kasal <address@hidden>
+
+ * automake.in (handle_single_transform): Direct suffix rule preserves
+ the directory prefix, so the generated object name should contain
+ it, too.
+
+--- automake.in 2005-09-17 15:05:39.000000000 +0200
++++ automake.in 2005-09-27 17:10:47.000000000 +0200
+@@ -1755,6 +1755,10 @@
+ # This is probably the result of a direct suffix rule.
+ # In this case we just accept the rewrite.
+ $object = "$base$extension";
++ if ($directory ne '')
++ {
++ $object = $directory . '/' . $object;
++ }
+ $linker = '';
+ }
+ else
+@@ -1824,7 +1828,7 @@
+
+ # For Java, the way we're handling it right now, a
+ # `..' component doesn't make sense.
+- if ($lang->name eq 'java' && $object =~ /(\/|^)\.\.\//)
++ if ($lang && $lang->name eq 'java' && $object =~ /(\/|^)\.\.\//)
+ {
+ err_am "`$full' should not contain a `..' component";
+ }
diff --git a/sys-devel/automake/files/digest-automake-1.9.6-r1 b/sys-devel/automake/files/digest-automake-1.9.6-r1
new file mode 100644
index 000000000000..3fe57a5cad3e
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.9.6-r1
@@ -0,0 +1 @@
+MD5 c11b8100bb311492d8220378fd8bf9e0 automake-1.9.6.tar.bz2 765505