summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2004-12-31 03:21:36 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2004-12-31 03:21:36 +0000
commit36e126f14b3535f2d9a43aeeebfedcc40f7eac1c (patch)
tree4bac6047b53249087b9e0216752e2a0191fae31f /sys-devel
parentdont kill $prog unless $search is valid (diff)
downloadgentoo-2-36e126f14b3535f2d9a43aeeebfedcc40f7eac1c.tar.gz
gentoo-2-36e126f14b3535f2d9a43aeeebfedcc40f7eac1c.tar.bz2
gentoo-2-36e126f14b3535f2d9a43aeeebfedcc40f7eac1c.zip
Fixing bad function prototype which causes compilation to fail on some configurations.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch11
-rw-r--r--sys-devel/gcc/gcc-3.3.5-r1.ebuild6
3 files changed, 23 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 620821f4bbc6..6dc210b65fc9 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.363 2004/12/24 10:56:03 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.364 2004/12/31 03:21:36 eradicator Exp $
+
+ 30 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org>
+ +files/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch,
+ gcc-3.3.5-r1.ebuild:
+ Fixing bad function prototype which causes compilation to fail on some
+ configurations.
24 Dec 2004; Jeremy Huddleston <eradicator@gentoo.org>
gcc-3.4.3-r1.ebuild:
diff --git a/sys-devel/gcc/files/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch b/sys-devel/gcc/files/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch
new file mode 100644
index 000000000000..f489deca5c3a
--- /dev/null
+++ b/sys-devel/gcc/files/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch
@@ -0,0 +1,11 @@
+--- gcc-3.3.5/gcc/f/com.h.orig 2004-12-30 18:43:49.520799009 -0800
++++ gcc-3.3.5/gcc/f/com.h 2004-12-30 18:44:17.719152427 -0800
+@@ -233,7 +233,7 @@ void ffecom_finish_decl (tree decl, tree
+ void ffecom_finish_progunit (void);
+ tree ffecom_get_invented_identifier (const char *pattern, ...)
+ ATTRIBUTE_PRINTF_1;
+-ffeinfoKindtype ffecom_gfrt_basictype (ffecomGfrt ix);
++ffeinfoBasictype ffecom_gfrt_basictype (ffecomGfrt ix);
+ ffeinfoKindtype ffecom_gfrt_kindtype (ffecomGfrt ix);
+ void ffecom_init_0 (void);
+ void ffecom_init_2 (void);
diff --git a/sys-devel/gcc/gcc-3.3.5-r1.ebuild b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
index a001c5481264..b702a8e7e3c7 100644
--- a/sys-devel/gcc/gcc-3.3.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.1 2004/12/05 04:19:34 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.2 2004/12/31 03:21:36 eradicator Exp $
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
@@ -126,6 +126,10 @@ src_unpack() {
# misc patches that havent made it into a patch tarball yet
epatch ${FILESDIR}/gcc-spec-env.patch
+ # fix an incorrect prototype of ffecom_gfrt_basictype() which causes
+ # 3.3.5 to not compile on some configurations.
+ epatch ${FILESDIR}/3.3.5/gcc-3.3.5-ffecom_gfrt_basictype-prototype.patch
+
if [ "${ARCH}" = "ppc" -o "${ARCH}" = "ppc64" ] ; then
epatch ${FILESDIR}/3.3.3/gcc333_pre20040408-stack-size.patch
fi