summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-29 03:04:52 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-29 03:04:52 +0000
commit2ad4e1746de8da99f9755416c1291b098eb279a7 (patch)
treec498516e1c608b535a89693d9947da8f1bdd63f4 /sys-devel
parentstable on ppc64 (diff)
downloadgentoo-2-2ad4e1746de8da99f9755416c1291b098eb279a7.tar.gz
gentoo-2-2ad4e1746de8da99f9755416c1291b098eb279a7.tar.bz2
gentoo-2-2ad4e1746de8da99f9755416c1291b098eb279a7.zip
add support for modular X when gcj/gtk
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.3.6.ebuild7
-rw-r--r--sys-devel/gcc/gcc-3.4.4-r1.ebuild7
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r1.ebuild7
-rw-r--r--sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild7
4 files changed, 20 insertions, 8 deletions
diff --git a/sys-devel/gcc/gcc-3.3.6.ebuild b/sys-devel/gcc/gcc-3.3.6.ebuild
index 7f70ea834011..2ea1605457f9 100644
--- a/sys-devel/gcc/gcc-3.3.6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.15 2005/10/07 02:01:56 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.16 2005/11/29 03:04:52 vapier Exp $
MAN_VER=""
PATCH_VER="1.3"
@@ -50,7 +50,10 @@ RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
sparc? ( hardened? ( >=sys-libs/glibc-2.3.3.20040420 ) )
!build? (
gcj? (
- gtk? ( >=x11-libs/gtk+-2.2 )
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ )
>=media-libs/libart_lgpl-2.1
)
>=sys-libs/ncurses-5.2-r2
diff --git a/sys-devel/gcc/gcc-3.4.4-r1.ebuild b/sys-devel/gcc/gcc-3.4.4-r1.ebuild
index f2ca98728d28..31f40519ff89 100644
--- a/sys-devel/gcc/gcc-3.4.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4-r1.ebuild,v 1.7 2005/11/22 05:15:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4-r1.ebuild,v 1.8 2005/11/29 03:04:52 vapier Exp $
MAN_VER=""
PATCH_VER="1.7"
@@ -56,7 +56,10 @@ RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
!build? (
gcj? (
- gtk? ( >=x11-libs/gtk+-2.2 )
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ )
>=media-libs/libart_lgpl-2.1
)
>=sys-libs/ncurses-5.2-r2
diff --git a/sys-devel/gcc/gcc-4.0.2-r1.ebuild b/sys-devel/gcc/gcc-4.0.2-r1.ebuild
index 801ac8c21220..201e83a9dbd1 100644
--- a/sys-devel/gcc/gcc-4.0.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r1.ebuild,v 1.11 2005/11/21 01:12:11 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r1.ebuild,v 1.12 2005/11/29 03:04:52 vapier Exp $
PATCH_VER="1.2"
PATCH_GCC_VER="4.0.2"
@@ -39,7 +39,10 @@ RDEPEND="!sys-devel/hardened-gcc
)
!build? (
gcj? (
- gtk? ( >=x11-libs/gtk+-2.2 )
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ )
>=media-libs/libart_lgpl-2.1
)
>=sys-libs/ncurses-5.2-r2
diff --git a/sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild b/sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild
index 18ce9001a978..362e57966ff3 100644
--- a/sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild,v 1.1 2005/11/26 04:05:10 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_beta20051125.ebuild,v 1.2 2005/11/29 03:04:52 vapier Exp $
ETYPE="gcc-compiler"
@@ -22,7 +22,10 @@ RDEPEND="!sys-devel/hardened-gcc
)
!build? (
gcj? (
- gtk? ( >=x11-libs/gtk+-2.2 )
+ gtk? (
+ || ( ( x11-libs/libXt x11-libs/libX11 x11-libs/libXtst x11-proto/xproto x11-proto/xextproto ) virtual/x11 )
+ >=x11-libs/gtk+-2.2
+ )
>=media-libs/libart_lgpl-2.1
)
>=sys-libs/ncurses-5.2-r2