summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-11-08 18:11:32 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-11-08 18:11:32 +0000
commit286b2c91e8e9e1db4bed151b6eb854af0b732f9a (patch)
treedeaa7d1cf280403f7ec18eb5afa37f10e46837d1 /sys-devel
parentStable for HPPA (bug #490434). (diff)
downloadgentoo-2-286b2c91e8e9e1db4bed151b6eb854af0b732f9a.tar.gz
gentoo-2-286b2c91e8e9e1db4bed151b6eb854af0b732f9a.tar.bz2
gentoo-2-286b2c91e8e9e1db4bed151b6eb854af0b732f9a.zip
live update
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/byfl/ChangeLog5
-rw-r--r--sys-devel/byfl/byfl-9999.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/sys-devel/byfl/ChangeLog b/sys-devel/byfl/ChangeLog
index 742c9cfbd5c6..4c9355ae737d 100644
--- a/sys-devel/byfl/ChangeLog
+++ b/sys-devel/byfl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/byfl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/ChangeLog,v 1.1 2013/11/05 20:38:23 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/ChangeLog,v 1.2 2013/11/08 18:11:32 ottxor Exp $
+
+ 08 Nov 2013; Christoph Junghans <ottxor@gentoo.org> byfl-9999.ebuild:
+ live update
*byfl-9999 (05 Nov 2013)
diff --git a/sys-devel/byfl/byfl-9999.ebuild b/sys-devel/byfl/byfl-9999.ebuild
index 7a9689613f11..cce163984a34 100644
--- a/sys-devel/byfl/byfl-9999.ebuild
+++ b/sys-devel/byfl/byfl-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-9999.ebuild,v 1.1 2013/11/05 20:38:23 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/byfl/byfl-9999.ebuild,v 1.2 2013/11/08 18:11:32 ottxor Exp $
EAPI=5
-inherit autotools-utils multilib
+inherit autotools-utils flag-o-matic multilib
if [ "${PV}" = "9999" ]; then
EGIT_REPO_URI="git://github.com/losalamos/${PN^b}.git http://github.com/losalamos/${PN}.git"
@@ -31,6 +31,7 @@ src_prepare() {
ln -s autoconf/configure.ac || die
eaclocal -I autoconf/m4
eautoconf
+ replace-flags -O? -O0 #upstream is working on this
}
src_configure() {
@@ -41,9 +42,9 @@ src_configure() {
}
src_compile() {
- autotools-utils_src_compile VERBOSE=1
+ autotools-utils_src_compile VERBOSE=1 LOPT="$(type -p opt)"
}
src_install() {
- autotools-utils_src_install -j1 VERBOSE=1 CXXFLAGS='-O0' LOPT="$(type -p opt)"
+ autotools-utils_src_install VERBOSE=1 LOPT="$(type -p opt)"
}