summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicholas Jones <carpaski@gentoo.org>2002-09-19 17:40:31 +0000
committerNicholas Jones <carpaski@gentoo.org>2002-09-19 17:40:31 +0000
commit202ec66049252a4f6d6cd827fb7119802cd87fd0 (patch)
tree75dbc187b16af51a993454cfccc8900c82a93e9d /sys-devel
parenthopefully final permission fixes. (diff)
downloadgentoo-2-202ec66049252a4f6d6cd827fb7119802cd87fd0.tar.gz
gentoo-2-202ec66049252a4f6d6cd827fb7119802cd87fd0.tar.bz2
gentoo-2-202ec66049252a4f6d6cd827fb7119802cd87fd0.zip
compatibility ebuild for upgrade profiles. Maintains gcc libs.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-compat/ChangeLog9
-rw-r--r--sys-devel/gcc-compat/gcc-compat-1.4.ebuild30
2 files changed, 39 insertions, 0 deletions
diff --git a/sys-devel/gcc-compat/ChangeLog b/sys-devel/gcc-compat/ChangeLog
new file mode 100644
index 000000000000..efbd9e6017e4
--- /dev/null
+++ b/sys-devel/gcc-compat/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for sys-devel/gcc-compat
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-compat/ChangeLog,v 1.1 2002/09/19 17:40:31 carpaski Exp $
+
+*sys-lib/gcc-compat-1.4 (19 Sep 2002)
+
+ 19 Sep 2002; Nicholas Jones <carpaski@gentoo.org> :
+ Created the ebuild. $PV == PROFILE TO ATTAIN
+
diff --git a/sys-devel/gcc-compat/gcc-compat-1.4.ebuild b/sys-devel/gcc-compat/gcc-compat-1.4.ebuild
new file mode 100644
index 000000000000..a3f26c677420
--- /dev/null
+++ b/sys-devel/gcc-compat/gcc-compat-1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-compat/gcc-compat-1.4.ebuild,v 1.1 2002/09/19 17:40:31 carpaski Exp $
+
+DESCRIPTION="This is a compatability layer for use when upgrading to profile $PV"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI=""
+LICENSE="gpl-2"
+
+# Only ONE version of this should exist on a system
+# This is ABSOLUTELY Machine non-specific
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND=""
+RDEPEND=""
+
+# DON'T STRIP THE LIBS!
+RESTRICT="nostrip"
+
+src_compile() {
+ echo -ne ""
+}
+
+src_install () {
+ cd /
+ tar cvf ${WORKDIR}/gcc-libs.tar $(find /usr/lib/gcc-lib/ -type f -name '*.so*')
+ cd ${D}
+ tar -mxvf ${WORKDIR}/gcc-libs.tar
+}