summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-10-21 08:14:07 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-10-21 08:14:07 +0000
commit1d263c22f79a7a604071be38fb7d71bf94fa92b1 (patch)
treeb3e77b23c4300a52c2b881fd93341fa009b626de /sys-devel
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-1d263c22f79a7a604071be38fb7d71bf94fa92b1.tar.gz
gentoo-2-1d263c22f79a7a604071be38fb7d71bf94fa92b1.tar.bz2
gentoo-2-1d263c22f79a7a604071be38fb7d71bf94fa92b1.zip
Also set GCC C headers path with USE=system-cxx-headers, reported by Guillaume Chatelet <chatelet.guillaume@gmail.com>, bug #341891, tested with boost compilation. Clean some versions
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog10
-rw-r--r--sys-devel/clang/clang-2.7-r2.ebuild173
-rw-r--r--sys-devel/clang/clang-2.8-r2.ebuild (renamed from sys-devel/clang/clang-2.8.ebuild)21
3 files changed, 23 insertions, 181 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index b4c569357e60..0422ef98ec7e 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.28 2010/10/12 09:24:54 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.29 2010/10/21 08:14:07 voyageur Exp $
+
+*clang-2.8-r2 (21 Oct 2010)
+
+ 21 Oct 2010; Bernard Cafarelli <voyageur@gentoo.org> -clang-2.7-r2.ebuild,
+ -clang-2.8.ebuild, +clang-2.8-r2.ebuild:
+ Also set GCC C headers path with USE=system-cxx-headers, reported by
+ Guillaume Chatelet <chatelet.guillaume@gmail.com>, bug #341891, tested
+ with boost compilation. Clean some versions
*clang-2.8-r1 (12 Oct 2010)
diff --git a/sys-devel/clang/clang-2.7-r2.ebuild b/sys-devel/clang/clang-2.7-r2.ebuild
deleted file mode 100644
index 93fd702dd73e..000000000000
--- a/sys-devel/clang/clang-2.7-r2.ebuild
+++ /dev/null
@@ -1,173 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.7-r2.ebuild,v 1.5 2010/09/08 17:34:54 grobian Exp $
-
-EAPI=3
-
-RESTRICT_PYTHON_ABIS="3.*"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit eutils multilib python
-
-DESCRIPTION="C language family frontend for LLVM"
-HOMEPAGE="http://clang.llvm.org/"
-# Fetching LLVM as well: see http://llvm.org/bugs/show_bug.cgi?id=4840
-SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.tgz
- http://llvm.org/releases/${PV}/${P}.tgz"
-
-LICENSE="UoI-NCSA"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos"
-IUSE="debug +static-analyzer system-cxx-headers test"
-
-# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
-DEPEND="static-analyzer? ( dev-lang/perl )
- test? ( dev-util/dejagnu )"
-RDEPEND="~sys-devel/llvm-${PV}"
-
-S="${WORKDIR}/llvm-2.7"
-
-src_prepare() {
- mv "${WORKDIR}"/clang-2.7 "${S}"/tools/clang || die "clang source directory not found"
-
- # Same as llvm doc patches
- epatch "${FILESDIR}"/${PN}-2.7-fixdoc.patch
-
- # Fix toolchain lookup for Darwin/Prefix.
- epatch "${FILESDIR}"/${PN}-2.7-darwin-prefix.patch
- sed -e "s|@GENTOO_PORTAGE_CHOST@|${CHOST%%-darwin*}-darwin|g" \
- -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}|g" \
- -i tools/clang/lib/Driver/ToolChains.cpp \
- || die "fixing toolchain lookup"
-
- # multilib-strict
- sed -e "/PROJ_headers/s#lib/clang#$(get_libdir)/clang#" \
- -i tools/clang/lib/Headers/Makefile \
- || die "clang Makefile failed"
- # fix the static analyzer for in-tree install
- sed -e 's/import ScanView/from clang \0/' \
- -i tools/clang/tools/scan-view/scan-view \
- || die "scan-view sed failed"
- sed -e "/scanview.css\|sorttable.js/s#\$RealBin#/usr/share/${PN}#" \
- -i tools/clang/tools/scan-build/scan-build \
- || die "scan-build sed failed"
- # Specify python version
- python_convert_shebangs 2 tools/clang/tools/scan-view/scan-view
-
- # From llvm src_prepare
- einfo "Fixing install dirs"
- sed -e 's,^PROJ_docsdir.*,PROJ_docsdir := $(PROJ_prefix)/share/doc/'${PF}, \
- -e 's,^PROJ_etcdir.*,PROJ_etcdir := '"${EPREFIX}"'/etc/llvm,' \
- -e 's,^PROJ_libdir.*,PROJ_libdir := $(PROJ_prefix)/'$(get_libdir), \
- -i Makefile.config.in || die "Makefile.config sed failed"
-
- einfo "Fixing rpath"
- sed -e 's/\$(RPATH) -Wl,\$(\(ToolDir\|LibDir\))//g' -i Makefile.rules \
- || die "rpath sed failed"
-}
-
-src_configure() {
- local CONF_FLAGS=""
-
- if use debug; then
- CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
- einfo "Note: Compiling LLVM in debug mode will create huge and slow binaries"
- # ...and you probably shouldn't use tmpfs, unless it can hold 900MB
- else
- CONF_FLAGS="${CONF_FLAGS} \
- --enable-optimized \
- --disable-assertions \
- --disable-expensive-checks"
- fi
-
- # Setup the search path to include the Prefix includes
- if use prefix ; then
- CONF_FLAGS="${CONF_FLAGS} \
- --with-c-include-dirs=${EPREFIX}/usr/include:/usr/include"
- fi
-
- if use amd64; then
- CONF_FLAGS="${CONF_FLAGS} --enable-pic"
- fi
-
- # Skip llvm-gcc parts even if installed
- CONF_FLAGS="${CONF_FLAGS} --with-llvmgccdir=/dev/null"
-
- if use system-cxx-headers; then
- # Try to get current C++ headers path
- CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=$(gcc-config -X| cut -d: -f1 | sed '/-v4$/! s,$,/include/g++-v4,')"
- CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
- if has_multilib_profile; then
- CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-32bit-dir=32"
- fi
- fi
-
- econf ${CONF_FLAGS} || die "econf failed"
-}
-
-src_compile() {
- emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1 clang-only || die "emake failed"
-}
-
-src_test() {
- cd "${S}"/test || die "cd failed"
- emake site.exp || die "updating llvm site.exp failed"
-
- cd "${S}"/tools/clang || die "cd clang failed"
-
- echo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- if ! emake -j1 VERBOSE=1 test; then
- hasq test $FEATURES && die "Make test failed. See above for details."
- hasq test $FEATURES || eerror "Make test failed. See above for details."
- fi
-}
-
-src_install() {
- cd "${S}"/tools/clang || die "cd clang failed"
- emake KEEP_SYMBOLS=1 DESTDIR="${D}" install || die "install failed"
-
- if use static-analyzer ; then
- dobin tools/scan-build/ccc-analyzer
- dosym ccc-analyzer /usr/bin/c++-analyzer
- dobin tools/scan-build/scan-build
-
- insinto /usr/share/${PN}
- doins tools/scan-build/scanview.css
- doins tools/scan-build/sorttable.js
-
- cd tools/scan-view || die "cd scan-view failed"
- dobin scan-view
- install-scan-view() {
- insinto "$(python_get_sitedir)"/clang
- doins Reporter.py Resources ScanView.py startfile.py
- touch "${ED}"/"$(python_get_sitedir)"/clang/__init__.py
- }
- python_execute_function install-scan-view
- fi
-
- # Fix install_names on Darwin. The build system is too complicated
- # to just fix this, so we correct it post-install
- if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in libCIndex.dylib ; do
- install_name_tool -id "${EPREFIX}"/usr/lib/${lib} \
- "${ED}"/usr/lib/${lib}
- done
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize clang
- if use system-cxx-headers; then
- elog "C++ headers search path is hardcoded to the active gcc profile one"
- elog "If you change the active gcc profile, or update gcc to a new version,"
- elog "you will have to remerge this package to update the search path"
- else
- elog "If clang++ fails to find C++ headers on your system,"
- elog "you can remerge clang with USE=system-cxx-headers to use C++ headers"
- elog "from the active gcc profile"
- fi
-}
-
-pkg_postrm() {
- python_mod_cleanup clang
-}
diff --git a/sys-devel/clang/clang-2.8.ebuild b/sys-devel/clang/clang-2.8-r2.ebuild
index 4d16e501712e..cffcbd8d3e65 100644
--- a/sys-devel/clang/clang-2.8.ebuild
+++ b/sys-devel/clang/clang-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.8.ebuild,v 1.3 2010/10/08 13:56:52 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.8-r2.ebuild,v 1.1 2010/10/21 08:14:07 voyageur Exp $
EAPI=3
@@ -19,11 +19,11 @@ SRC_URI="http://llvm.org/releases/${PV}/llvm-${PV}.tgz -> llvm-${PV}-r1.tgz
LICENSE="UoI-NCSA"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~ppc-macos"
-IUSE="debug +static-analyzer system-cxx-headers test"
+IUSE="alltargets debug +static-analyzer system-cxx-headers test"
# Note: for LTO support, clang will depend on binutils with gold plugins, and LLVM built after that - http://llvm.org/docs/GoldPlugin.html
DEPEND="static-analyzer? ( dev-lang/perl )"
-RDEPEND="~sys-devel/llvm-${PV}"
+RDEPEND="~sys-devel/llvm-${PV}[alltargets=]"
S="${WORKDIR}/llvm-${PV}"
@@ -60,8 +60,7 @@ src_prepare() {
}
src_configure() {
- # --enable-shared: undefined symbol, bug #338231
- local CONF_FLAGS=""
+ local CONF_FLAGS="--enable-shared"
if use debug; then
CONF_FLAGS="${CONF_FLAGS} --disable-optimized"
@@ -80,6 +79,12 @@ src_configure() {
--with-c-include-dirs=${EPREFIX}/usr/include:/usr/include"
fi
+ if use alltargets; then
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=all"
+ else
+ CONF_FLAGS="${CONF_FLAGS} --enable-targets=host-only"
+ fi
+
if use amd64; then
CONF_FLAGS="${CONF_FLAGS} --enable-pic"
fi
@@ -88,8 +93,10 @@ src_configure() {
CONF_FLAGS="${CONF_FLAGS} --with-llvmgccdir=/dev/null"
if use system-cxx-headers; then
- # Try to get current C++ headers path
- CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=$(gcc-config -X| cut -d: -f1 | sed '/-v4$/! s,$,/include/g++-v4,')"
+ # Try to get current gcc headers path
+ local CXX_PATH=$(gcc-config -X| cut -d: -f1 | sed 's,/include/g++-v4$,,')
+ CONF_FLAGS="${CONF_FLAGS} --with-c-include-dirs=/usr/include:${CXX_PATH}/include"
+ CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-root=${CXX_PATH}/include/g++-v4"
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-arch=$CHOST"
if has_multilib_profile; then
CONF_FLAGS="${CONF_FLAGS} --with-cxx-include-32bit-dir=32"