summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-28 04:27:58 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-28 04:27:58 +0000
commit13cfab3ba9b8be2e7ac5b9e5b6c5cf9edd2621cb (patch)
treea7f15c510882339b788533deafc0db560d6ae12e /sys-devel
parentgetting rid of apache-ssl package in favor of USE friendly apache/ package (diff)
downloadgentoo-2-13cfab3ba9b8be2e7ac5b9e5b6c5cf9edd2621cb.tar.gz
gentoo-2-13cfab3ba9b8be2e7ac5b9e5b6c5cf9edd2621cb.tar.bz2
gentoo-2-13cfab3ba9b8be2e7ac5b9e5b6c5cf9edd2621cb.zip
new version of binutils, and ebuild fixes/updates
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.27.ebuild54
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.11.90.0.271
2 files changed, 55 insertions, 0 deletions
diff --git a/sys-devel/binutils/binutils-2.11.90.0.27.ebuild b/sys-devel/binutils/binutils-2.11.90.0.27.ebuild
new file mode 100644
index 000000000000..9a2416edc2f3
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.11.90.0.27.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.27.ebuild,v 1.1 2001/08/28 04:27:58 drobbins Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf} || die
+ if [ "`use static`" ]
+ then
+ emake -e LDFLAGS=-all-static || die
+ else
+ emake || die
+ fi
+}
+
+src_install() {
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+ if [ -z "`use build`" ]
+ then
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING \
+ gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/NOTES gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+
+}
+
+
+
diff --git a/sys-devel/binutils/files/digest-binutils-2.11.90.0.27 b/sys-devel/binutils/files/digest-binutils-2.11.90.0.27
new file mode 100644
index 000000000000..5ba297fd8848
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.11.90.0.27
@@ -0,0 +1 @@
+MD5 8466c723994f435f9ad18238a328b4ae binutils-2.11.90.0.27.tar.bz2