summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-23 00:10:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-23 00:10:21 +0000
commit12ba95beaf6cba84dfaed0c337bca68b4738ef4e (patch)
treed00d59116e29cc25ea81c3d1b219801be6cd3e32 /sys-devel
parentadd initial category metadata file (GLEP 34) (diff)
downloadgentoo-2-12ba95beaf6cba84dfaed0c337bca68b4738ef4e.tar.gz
gentoo-2-12ba95beaf6cba84dfaed0c337bca68b4738ef4e.tar.bz2
gentoo-2-12ba95beaf6cba84dfaed0c337bca68b4738ef4e.zip
make sure we build on amd64 (touchup CFLAGS)
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
index 853d154d7149..0ea0edc40ece 100644
--- a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.2 2005/03/22 02:56:38 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.3 2005/03/23 00:10:21 vapier Exp $
MAN_VER="3.3.5"
PATCH_VER="1.4"
@@ -37,7 +37,7 @@ inherit toolchain eutils
DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
-KEYWORDS="~alpha -amd64 ~arm ~hppa -ia64 ~mips ~sh sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa -ia64 ~mips ~sh sparc ~x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
@@ -90,4 +90,8 @@ src_unpack() {
epatch ${FILESDIR}/3.3.4/libffi-without-libgcj.patch
#epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
fi
+
+ if [[ $(tc-arch) == "amd64" ]] ; then
+ replace-cpu-flags k8 i686
+ fi
}