summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-03-16 21:31:09 +0000
committerLars Wendler <polynomial-c@gentoo.org>2015-03-16 21:31:09 +0000
commit07ecd5c4e48ee836636c01007282766a8180639d (patch)
treeb0f366e2f37707ec0353b9e62fa0cae935ac3480 /sys-devel
parentUse new toolchain helpers for selecting the bfd linker #438058 by Alexandre R... (diff)
downloadgentoo-2-07ecd5c4e48ee836636c01007282766a8180639d.tar.gz
gentoo-2-07ecd5c4e48ee836636c01007282766a8180639d.tar.bz2
gentoo-2-07ecd5c4e48ee836636c01007282766a8180639d.zip
Removed vulnerable version
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/patch/ChangeLog6
-rw-r--r--sys-devel/patch/files/gnulib_strnlen.c31
-rw-r--r--sys-devel/patch/patch-2.6.1.ebuild40
3 files changed, 5 insertions, 72 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index 12407af5af28..44586c6230c0 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/patch
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.81 2015/03/08 16:28:48 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.82 2015/03/16 21:31:09 polynomial-c Exp $
+
+ 16 Mar 2015; Lars Wendler <polynomial-c@gentoo.org> -patch-2.6.1.ebuild,
+ -files/gnulib_strnlen.c:
+ Removed vulnerable version.
*patch-2.7.5 (08 Mar 2015)
diff --git a/sys-devel/patch/files/gnulib_strnlen.c b/sys-devel/patch/files/gnulib_strnlen.c
deleted file mode 100644
index 112df49ab48d..000000000000
--- a/sys-devel/patch/files/gnulib_strnlen.c
+++ /dev/null
@@ -1,31 +0,0 @@
-/* Find the length of STRING, but scan at most MAXLEN characters.
- Copyright (C) 2005, 2006, 2007, 2009, 2010 Free Software Foundation, Inc.
- Written by Simon Josefsson.
-
- This program is free software; you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
- the Free Software Foundation; either version 2, or (at your option)
- any later version.
-
- This program is distributed in the hope that it will be useful,
- but WITHOUT ANY WARRANTY; without even the implied warranty of
- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- GNU General Public License for more details.
-
- You should have received a copy of the GNU General Public License
- along with this program; if not, write to the Free Software Foundation,
- Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
-
-#include <config.h>
-
-#include <string.h>
-
-/* Find the length of STRING, but scan at most MAXLEN characters.
- If no '\0' terminator is found in that many characters, return MAXLEN. */
-
-size_t
-strnlen (const char *string, size_t maxlen)
-{
- const char *end = memchr (string, '\0', maxlen);
- return end ? (size_t) (end - string) : maxlen;
-}
diff --git a/sys-devel/patch/patch-2.6.1.ebuild b/sys-devel/patch/patch-2.6.1.ebuild
deleted file mode 100644
index fa833c162491..000000000000
--- a/sys-devel/patch/patch-2.6.1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.6.1.ebuild,v 1.13 2014/01/18 03:17:14 vapier Exp $
-
-inherit flag-o-matic
-
-DESCRIPTION="Utility to apply diffs to files"
-HOMEPAGE="http://www.gnu.org/software/patch/patch.html"
-SRC_URI="mirror://gnu/patch/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-IUSE="static test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? ( sys-apps/ed )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # this file is missing from the tarball bug #300845
- cp "${FILESDIR}"/gnulib_strnlen.c gl/lib/strnlen.c || die
-}
-
-src_compile() {
- use static && append-ldflags -static
-
- local myconf=""
- [[ ${USERLAND} != "GNU" ]] && myconf="--program-prefix=g"
- econf ${myconf}
-
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog NEWS README
-}