summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-28 09:21:10 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-28 09:21:10 +0000
commit05e2e8ae7ec2eef66e1b4b25a1ff5b5d8a08c7b0 (patch)
tree4e32f66ec655422339bccfa611359c513dad46a8 /sys-devel
parentadd cygwin targets (diff)
downloadgentoo-2-05e2e8ae7ec2eef66e1b4b25a1ff5b5d8a08c7b0.tar.gz
gentoo-2-05e2e8ae7ec2eef66e1b4b25a1ff5b5d8a08c7b0.tar.bz2
gentoo-2-05e2e8ae7ec2eef66e1b4b25a1ff5b5d8a08c7b0.zip
Initial cygwin support.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9.19.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev19
3 files changed, 44 insertions, 4 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 80da865bd816..1a02e274db8b 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.60 2008/10/27 05:57:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.61 2008/11/28 09:21:10 vapier Exp $
+
+*crossdev-0.9.19 (28 Nov 2008)
+
+ 28 Nov 2008; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.19.ebuild:
+ Initial cygwin support.
*crossdev-0.9.18-r10 (27 Oct 2008)
diff --git a/sys-devel/crossdev/crossdev-0.9.19.ebuild b/sys-devel/crossdev/crossdev-0.9.19.ebuild
new file mode 100644
index 000000000000..8a4caca28187
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.19.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.19.ebuild,v 1.1 2008/11/28 09:21:10 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ || ( dev-util/unifdef sys-freebsd/freebsd-ubin )"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index fd38eb494e8b..c94a9588dd5c 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.108 2008/10/27 05:57:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.109 2008/11/28 09:21:10 vapier Exp $
cd /
umask 0022 #159111
@@ -148,6 +148,10 @@ parse_target() {
LCAT="dev-embedded"; LPKG="avr-libc";
GUSE=${GUSE_DISABLE};;
+ # due to upstream lameness, build C/C++ at first glance
+ *-cygwin)
+ GUSE_DISABLE=${GUSE_DISABLE/nocxx};;
+
mingw*|*-mingw*)
WITH_DEF_HEADERS="yes";
KCAT="dev-util"; KPKG="w32api";
@@ -197,6 +201,12 @@ parse_target() {
*-uclibc*) LPKG="uclibc";;
*-uclinux) LPKG="uclibc";;
+ # Windows targets
+ *-cygwin)
+ LCAT="dev-libs"; LPKG="cygwin";
+ KPKG="[none]";
+ ;;
+
# Bare metal targets
*-newlib|*-elf)
LPKG="newlib"
@@ -210,6 +220,8 @@ parse_target() {
KPKG="[none]"
;;
esac
+
+ : ${LPKG=[none]}
}
setup_portage_vars() {
@@ -329,8 +341,9 @@ GCAT="sys-devel" ; GPKG="gcc" ; GVER="" ; GUSE=""
KCAT="sys-kernel" ; KPKG="linux-headers" ; KVER="" ; KUSE=""
LCAT="sys-libs" ; LPKG="" ; LVER="" ; LUSE=""
DEFAULT_VER="[latest]"
-GUSE_DISABLE="-boundschecking -d -fortran -gtk -gcj -libffi -mudflap -objc -objc++ -objc-gc -openmp"
+GUSE_DISABLE="-boundschecking -d -fortran -gtk -gcj -libffi -mudflap nocxx -objc -objc++ -objc-gc -openmp"
GUSE_DISABLE_STAGE_2=${GUSE_DISABLE/-fortran}
+GUSE_DISABLE_STAGE_2=${GUSE_DISABLE_STAGE_2/nocxx}
WITH_HEADERS="COW" WITH_DEF_HEADERS="yes" #227065 gcc-4.3+ is a pita w/out headers
EX_FAST="no"
EX_GCC="no"
@@ -616,7 +629,7 @@ USE="${KUSE} ${USE}" CROSSCOMPILE_OPTS="headers-only" \
USE="${LUSE} ${USE}" CROSSCOMPILE_OPTS="headers-only" \
doemerge ${LPKG} ${LPKG}-headers
fi
-USE="${GUSE} ${USE} ${GUSE_DISABLE} nocxx" CROSSCOMPILE_OPTS="bootstrap" \
+USE="${GUSE} ${USE} ${GUSE_DISABLE}" CROSSCOMPILE_OPTS="bootstrap" \
doemerge ${GPKG} ${GPKG}-stage1
is_s2 || exit 0