summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-15 04:09:14 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-15 04:09:14 +0000
commit22a6d264ab7d77ce7461a8a672f40b231c3c2dc4 (patch)
tree2907a9371fdef267942d5019abc75b713b7f9f99 /sys-devel/spython
parentunmasked (diff)
downloadgentoo-2-22a6d264ab7d77ce7461a8a672f40b231c3c2dc4.tar.gz
gentoo-2-22a6d264ab7d77ce7461a8a672f40b231c3c2dc4.tar.bz2
gentoo-2-22a6d264ab7d77ce7461a8a672f40b231c3c2dc4.zip
zlib update
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/ChangeLog16
-rw-r--r--sys-devel/spython/files/digest-spython-2.0-r92
-rw-r--r--sys-devel/spython/spython-2.0-r9.ebuild111
3 files changed, 120 insertions, 9 deletions
diff --git a/sys-devel/spython/ChangeLog b/sys-devel/spython/ChangeLog
index 3c9079bde104..6f253c23b9d4 100644
--- a/sys-devel/spython/ChangeLog
+++ b/sys-devel/spython/ChangeLog
@@ -1,13 +1,11 @@
# ChangeLog for sys-devel/spython
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/ChangeLog,v 1.1 2002/02/01 21:53:38 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/ChangeLog,v 1.2 2002/03/15 04:09:13 blocke Exp $
+
+*spython-2.0-r9 (14 Mar 2002)
+
+ 14 Mar 2002; Bruce A. Locke <blocke@shivan.org> spython-2.0-r9.ebuild :
+
+ Bumped zlib dependency up to 1.1.4
-*spython-2.0-r8 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/sys-devel/spython/files/digest-spython-2.0-r9 b/sys-devel/spython/files/digest-spython-2.0-r9
new file mode 100644
index 000000000000..6d4341874266
--- /dev/null
+++ b/sys-devel/spython/files/digest-spython-2.0-r9
@@ -0,0 +1,2 @@
+MD5 4751f4619eda0b5ade9d9dd017e7c1ef BeOpen-Python-2.0.tar.bz2 3421233
+MD5 7c99113a11b03599d8494638f6d90b56 python-fchksum-1.1.tar.gz 28676
diff --git a/sys-devel/spython/spython-2.0-r9.ebuild b/sys-devel/spython/spython-2.0-r9.ebuild
new file mode 100644
index 000000000000..e2865e9414a3
--- /dev/null
+++ b/sys-devel/spython/spython-2.0-r9.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r9.ebuild,v 1.1 2002/03/15 04:09:13 blocke Exp $
+
+S=${WORKDIR}/Python-2.0
+S2=${WORKDIR}/python-fchksum-1.1
+DESCRIPTION="A really great language -- minimalist python environment"
+SRC_URI="http://www.python.org/ftp/python/2.0/BeOpen-Python-2.0.tar.bz2
+ http://www.azstarnet.com/~donut/programs/fchksum/python-fchksum-1.1.tar.gz"
+
+HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
+
+DEPEND=">=sys-devel/autoconf-2.13 >=sys-libs/zlib-1.1.4 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
+
+RDEPEND="virtual/glibc"
+
+# spython can't provide python anymore, since it is missing important services like crypt.
+# upgrades from spython to python can cause things like mailman's authentication system to break.
+#PROVIDE="virtual/python"
+# This means we also need to remove the /usr/bin/python symlink.
+
+src_unpack() {
+
+ unpack BeOpen-Python-2.0.tar.bz2
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+ autoconf
+
+ cd ${S}/Modules
+
+ cp -a ${FILESDIR}/pfconfig.h .
+ unpack python-fchksum-1.1.tar.gz
+
+ echo '*static*' >> Setup.local
+
+ echo "zlib zlibmodule.c -lz" >> Setup.local
+ if [ "`use readline`" ]
+ then
+ echo "readline readline.c -lreadline -lncurses" >> Setup.local
+ fi
+
+ echo "fchksum fchksum.c md5_2.c" >> Setup.local
+
+ cd python-fchksum-1.1
+ cp -a md5.h ../md5_2.h
+ sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
+ sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+
+}
+
+src_compile() {
+
+ export LDFLAGS=-static
+
+ ./configure --prefix=/usr --without-libdb || die
+
+ #libdb3 support is available from http://pybsddb.sourceforge.net/; the one
+ #included with python is for db 1.85 only.
+
+ cp Makefile Makefile.orig
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
+ cd ${S}/Modules
+ cp Makefile.pre Makefile.orig
+ sed -e "s:MODOBJS=:MODOBJS=fchksum.o md5_2.o:" \
+ Makefile.orig > Makefile.pre
+
+ # Parallel make does not work
+ cd ${S}
+ try make
+
+}
+
+src_install() {
+ dodir /usr/share/man
+ make install prefix=${D}/usr MANDIR=${D}/usr/share/man || die
+
+ rm -rf ${D}/usr/include
+ rm -rf ${D}/usr/lib/${PN}${PV}/config
+
+ dodir /usr/lib/python${PV}/site-packages
+ rm -rf ${D}/usr/lib/spython${PV}/site-packages
+ dosym ../python${PV}/site-packages /usr/lib/spython${PV}/site-packages
+
+ if [ "`use build`" ] || [ "`use bootcd`" ]
+ then
+ rm -rf ${D}/usr/share/man
+ rm -rf ${D}/usr/include
+ cd ${D}/usr/lib/spython2.0
+ #remove test and lib-tk directory; we can do much more cleaning too.
+ rm -rf test lib-tk
+ #clean out byte-compiled stuff. They aren't required, and doing so saves space
+ #cd to root so "find" works properly.
+ cd ${D}
+ local x
+ for x in `find -iname '*.py[co]'`
+ do
+ rm x
+ done
+ fi
+}
+
+pkg_preinst() {
+ # keep portage from breaking from this move
+ for file in ${ROOT}/usr/lib/python2.0/{xpak,portage}.py
+ do
+ [ -f ${file} ] || continue
+ cp -a ${file} ${ROOT}/usr/lib/python2.0/site-packages
+ rm -f ${file}* #remove .pyc stuff too
+ done
+}