summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-27 18:26:17 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-27 18:26:17 +0000
commit053bd87280276d62417c79e39e11f6268bad4cf4 (patch)
tree9ca10d6b6c03ca04260c01d83acdfa51f9238767 /sys-devel/spython
parentNow use Setup.local for configuration (diff)
downloadgentoo-2-053bd87280276d62417c79e39e11f6268bad4cf4.tar.gz
gentoo-2-053bd87280276d62417c79e39e11f6268bad4cf4.tar.bz2
gentoo-2-053bd87280276d62417c79e39e11f6268bad4cf4.zip
/usr/bin/python symlink is now generated by pkg_postinst if /usr/bin/python does not exist
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/spython-2.0-r4.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-devel/spython/spython-2.0-r4.ebuild b/sys-devel/spython/spython-2.0-r4.ebuild
index ba558d6b494a..1790d0e5f750 100644
--- a/sys-devel/spython/spython-2.0-r4.ebuild
+++ b/sys-devel/spython/spython-2.0-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.1 2001/02/27 18:23:13 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.2 2001/02/27 18:26:17 achim Exp $
S=${WORKDIR}/Python-2.0
S2=${WORKDIR}/python-fchksum-1.1
@@ -74,10 +74,17 @@ src_install() {
try make install prefix=${D}/usr MANDIR=${D}/usr/share/man
rm ${D}/usr/bin/python
mv ${D}/usr/bin/python2.0 ${D}/usr/bin/spython
- dosym spython /usr/bin/python
if [ "`use build`" ]
then
rm -rf ${D}/usr/share/man
fi
}
+
+pkg_postinst() {
+
+ if [ ! -e "${ROOT}/usr/bin/python" ]
+ then
+ ln -s spython ${ROOT}/usr/bin/python
+ fi
+}