summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGreg Kroah-Hartman <gregkh@gentoo.org>2014-02-27 20:31:26 +0000
committerGreg Kroah-Hartman <gregkh@gentoo.org>2014-02-27 20:31:26 +0000
commite51a61847c983ef27617557216d53e2d21f3e83f (patch)
treeffac144872424bd6a41060e38eecc7d12ed7d19b /sys-devel/sparse
parentUse the unpacker_src_uri_depends() function to pull in either pdlzip or lzip ... (diff)
downloadgentoo-2-e51a61847c983ef27617557216d53e2d21f3e83f.tar.gz
gentoo-2-e51a61847c983ef27617557216d53e2d21f3e83f.tar.bz2
gentoo-2-e51a61847c983ef27617557216d53e2d21f3e83f.zip
0.5.0 version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/ChangeLog9
-rw-r--r--sys-devel/sparse/sparse-0.5.0.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index b73843b483b1..22300b792f82 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/sparse
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.55 2013/09/05 09:17:49 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.56 2014/02/27 20:31:26 gregkh Exp $
+
+*sparse-0.5.0 (27 Feb 2014)
+
+ 27 Feb 2014; Greg Kroah-Hartman <gregkh@gentoo.org> +sparse-0.5.0.ebuild:
+ 0.5.0 version bump
05 Sep 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml,
sparse-9999.ebuild:
diff --git a/sys-devel/sparse/sparse-0.5.0.ebuild b/sys-devel/sparse/sparse-0.5.0.ebuild
new file mode 100644
index 000000000000..c5916ea7d025
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.5.0.ebuild,v 1.1 2014/02/27 20:31:26 gregkh Exp $
+
+EAPI="4"
+
+inherit eutils multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ inherit git-2
+fi
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} == "9999" ]] ; then
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://kernel/software/devel/sparse/dist/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE="gtk test xml"
+
+RDEPEND="gtk? ( x11-libs/gtk+:2 )
+ xml? ( dev-libs/libxml2 )"
+DEPEND="${RDEPEND}
+ gtk? ( virtual/pkgconfig )
+ xml? ( virtual/pkgconfig )"
+
+src_prepare() {
+ tc-export AR CC PKG_CONFIG
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ -e '/^CFLAGS =/{s:=:+= $(CPPFLAGS):;s:-O2 -finline-functions::}' \
+ -e "s:pkg-config:${PKG_CONFIG}:" \
+ Makefile || die
+ export MAKEOPTS+=" V=1 AR=${AR} CC=${CC} HAVE_GTK2=$(usex gtk) HAVE_LIBXML=$(usex xml)"
+}
+
+src_compile() {
+ emake $(usex test all all-installable)
+}