summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-05-03 16:30:04 +0000
committerMike Frysinger <vapier@gentoo.org>2014-05-03 16:30:04 +0000
commit707300afcfc51f1be4af3a71c6890977aacba1ef (patch)
tree250d4de64fa15a2186a920b5506cdba3ab6eb532 /sys-devel/smatch
parentEnable unconfined as default USE flag for selinux systems as targeted policy ... (diff)
downloadgentoo-2-707300afcfc51f1be4af3a71c6890977aacba1ef.tar.gz
gentoo-2-707300afcfc51f1be4af3a71c6890977aacba1ef.tar.bz2
gentoo-2-707300afcfc51f1be4af3a71c6890977aacba1ef.zip
Version bump #509290 by MJJoker.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/smatch')
-rw-r--r--sys-devel/smatch/ChangeLog10
-rw-r--r--sys-devel/smatch/smatch-1.59.ebuild64
-rw-r--r--sys-devel/smatch/smatch-9999.ebuild42
3 files changed, 98 insertions, 18 deletions
diff --git a/sys-devel/smatch/ChangeLog b/sys-devel/smatch/ChangeLog
index 208bc9292473..e3e344965846 100644
--- a/sys-devel/smatch/ChangeLog
+++ b/sys-devel/smatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/smatch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/ChangeLog,v 1.4 2013/01/03 20:50:43 vapier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/ChangeLog,v 1.5 2014/05/03 16:30:04 vapier Exp $
+
+*smatch-1.59 (03 May 2014)
+
+ 03 May 2014; Mike Frysinger <vapier@gentoo.org> +smatch-1.59.ebuild,
+ smatch-9999.ebuild:
+ Version bump #509290 by MJJoker.
*smatch-1.57-r1 (03 Jan 2013)
diff --git a/sys-devel/smatch/smatch-1.59.ebuild b/sys-devel/smatch/smatch-1.59.ebuild
new file mode 100644
index 000000000000..95101afcded7
--- /dev/null
+++ b/sys-devel/smatch/smatch-1.59.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-1.59.ebuild,v 1.1 2014/05/03 16:30:04 vapier Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://repo.or.cz/${PN}.git
+ http://repo.or.cz/r/${PN}.git"
+ inherit git-2
+else
+ SRC_URI="http://repo.or.cz/w/smatch.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="static analysis tool for C"
+HOMEPAGE="http://smatch.sourceforge.net/"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/sqlite"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+ Makefile || die
+}
+
+_emake() {
+ # gtk/llvm/xml is used by sparse which we don't install
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ V=1 \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LD='$(CC)' \
+ HAVE_GTK2=no \
+ HAVE_LLVM=no \
+ HAVE_LIBXML=no \
+ "$@"
+}
+
+src_compile() {
+ _emake smatch
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ # default install target installs a lot of sparse cruft
+ dobin smatch
+ insinto /usr/share/smatch/smatch_data
+ doins smatch_data/*
+ dodoc FAQ README
+}
diff --git a/sys-devel/smatch/smatch-9999.ebuild b/sys-devel/smatch/smatch-9999.ebuild
index aec2144d3154..9d9808d3baff 100644
--- a/sys-devel/smatch/smatch-9999.ebuild
+++ b/sys-devel/smatch/smatch-9999.ebuild
@@ -1,30 +1,23 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-9999.ebuild,v 1.3 2012/12/20 02:46:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/smatch/smatch-9999.ebuild,v 1.4 2014/05/03 16:30:04 vapier Exp $
EAPI="4"
-inherit multilib toolchain-funcs
+inherit toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://repo.or.cz/${PN}.git
http://repo.or.cz/r/${PN}.git"
inherit git-2
+else
+ SRC_URI="http://repo.or.cz/w/smatch.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz
+ mirror://gentoo/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
fi
DESCRIPTION="static analysis tool for C"
HOMEPAGE="http://smatch.sourceforge.net/"
-if [[ ${PV} == "9999" ]] ; then
- SRC_URI=""
- #KEYWORDS=""
-else
- # The repo.or.cz site does not produce stable tarballs,
- # so we have to cache our own copy of the snapshot.
- #SRC_URI="http://repo.or.cz/w/smatch.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz"
- SRC_URI="mirror://gentoo/${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-fi
-
LICENSE="OSL-1.1"
SLOT="0"
IUSE=""
@@ -36,13 +29,30 @@ S=${WORKDIR}/${PN}
src_prepare() {
sed -i \
- -e '/^PREFIX=/s:=.*:=/usr:' \
-e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
Makefile || die
}
+_emake() {
+ # gtk/llvm/xml is used by sparse which we don't install
+ emake \
+ PREFIX="${EPREFIX}/usr" \
+ V=1 \
+ AR="$(tc-getAR)" \
+ CC="$(tc-getCC)" \
+ LD='$(CC)' \
+ HAVE_GTK2=no \
+ HAVE_LLVM=no \
+ HAVE_LIBXML=no \
+ "$@"
+}
+
src_compile() {
- emake PREFIX=/usr V=1 CC="$(tc-getCC)" smatch
+ _emake smatch
+}
+
+src_test() {
+ _emake check
}
src_install() {