summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-09-21 10:13:56 +0000
committerMike Frysinger <vapier@gentoo.org>2008-09-21 10:13:56 +0000
commit3c294d1ebfd5178ffa2a5ec2ac044ffe111239ce (patch)
tree8edfba953090a78ebe5a64caf7f0e4b1e2ec4741 /sys-devel/prelink
parentVersion bump #237141 by Conrad Kostecki. (diff)
downloadgentoo-2-3c294d1ebfd5178ffa2a5ec2ac044ffe111239ce.tar.gz
gentoo-2-3c294d1ebfd5178ffa2a5ec2ac044ffe111239ce.tar.bz2
gentoo-2-3c294d1ebfd5178ffa2a5ec2ac044ffe111239ce.zip
old
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-devel/prelink')
-rw-r--r--sys-devel/prelink/prelink-20050314.ebuild71
-rw-r--r--sys-devel/prelink/prelink-20050610.ebuild70
-rw-r--r--sys-devel/prelink/prelink-20050901.ebuild70
-rw-r--r--sys-devel/prelink/prelink-20060213.ebuild84
-rw-r--r--sys-devel/prelink/prelink-20061201.ebuild64
5 files changed, 0 insertions, 359 deletions
diff --git a/sys-devel/prelink/prelink-20050314.ebuild b/sys-devel/prelink/prelink-20050314.ebuild
deleted file mode 100644
index fbe4dbe0b72d..000000000000
--- a/sys-devel/prelink/prelink-20050314.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20050314.ebuild,v 1.2 2005/05/27 18:01:02 cretin Exp $
-
-inherit eutils
-
-DESCRIPTION="Modifies executables so runtime libraries load faster"
-HOMEPAGE="ftp://people.redhat.com/jakub/prelink"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~azarah/prelink/${P}.tar.bz2
- ftp://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 amd64 ppc alpha"
-IUSE=""
-
-DEPEND=">=dev-libs/elfutils-0.100
- !dev-libs/libelf
- >=sys-libs/glibc-2.3.2-r9
- >=sys-devel/binutils-2.13.90.0.10"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-20040707-init.patch
- epatch ${FILESDIR}/${P}-amd64-gcc4.patch
-
- # Build our /etc/env.d/60prelink
- cat > "${S}/60prelink" <<-EOF
- $(
- # Need to initialize PRELINK_PATH_MASK so that we can
- # just add ':${x}' below.
- PRELINK_PATH_MASK="/lib/modules"
- # Ok, now add the rest
- for x in /usr/$(get_libdir)/locale \
- /usr/$(get_libdir)/wine \
- /usr/$(get_libdir)/valgrind \
- "*.la" "*.png" "*.py" "*.pl" "*.pm" \
- "*.sh" "*.xml" "*.xslt" "*.a" "*.js" ; do
- PRELINK_PATH_MASK="${PRELINK_PATH_MASK}:${x}"
- done
- # Now add it quoted
- echo PRELINK_PATH_MASK="\"${PRELINK_PATH_MASK}\""
- )
- PRELINK_PATH=""
- EOF
-}
-
-src_compile() {
- econf || die "Configure failed"
- emake || die "Make Failed"
-}
-
-src_install() {
- einstall || die "Install Failed"
-
- doenvd ${S}/60prelink
-
- dodoc INSTALL TODO ChangeLog THANKS COPYING README AUTHORS NEWS
-}
-
-pkg_postinst() {
- echo
- einfo "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- einfo "found online at:"
- einfo " http://www.gentoo.org/doc/en/prelink-howto.xml"
- echo
-}
diff --git a/sys-devel/prelink/prelink-20050610.ebuild b/sys-devel/prelink/prelink-20050610.ebuild
deleted file mode 100644
index 4aa8852fc644..000000000000
--- a/sys-devel/prelink/prelink-20050610.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20050610.ebuild,v 1.1 2005/07/20 17:50:00 azarah Exp $
-
-inherit eutils
-
-DESCRIPTION="Modifies executables so runtime libraries load faster"
-HOMEPAGE="ftp://people.redhat.com/jakub/prelink"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~azarah/prelink/${P}.tar.bz2
- ftp://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-libs/elfutils-0.100
- !dev-libs/libelf
- >=sys-libs/glibc-2.3.2-r9
- >=sys-devel/binutils-2.13.90.0.10"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-20040707-init.patch
-
- # Build our /etc/env.d/60prelink
- cat > "${S}/60prelink" <<-EOF
- $(
- # Need to initialize PRELINK_PATH_MASK so that we can
- # just add ':${x}' below.
- PRELINK_PATH_MASK="/lib/modules"
- # Ok, now add the rest
- for x in /usr/$(get_libdir)/locale \
- /usr/$(get_libdir)/wine \
- /usr/$(get_libdir)/valgrind \
- "*.la" "*.png" "*.py" "*.pl" "*.pm" \
- "*.sh" "*.xml" "*.xslt" "*.a" "*.js" ; do
- PRELINK_PATH_MASK="${PRELINK_PATH_MASK}:${x}"
- done
- # Now add it quoted
- echo PRELINK_PATH_MASK="\"${PRELINK_PATH_MASK}\""
- )
- PRELINK_PATH=""
- EOF
-}
-
-src_compile() {
- econf || die "Configure failed"
- emake || die "Make Failed"
-}
-
-src_install() {
- einstall || die "Install Failed"
-
- doenvd ${S}/60prelink
-
- dodoc INSTALL TODO ChangeLog THANKS COPYING README AUTHORS NEWS
-}
-
-pkg_postinst() {
- echo
- einfo "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- einfo "found online at:"
- einfo " http://www.gentoo.org/doc/en/prelink-howto.xml"
- echo
-}
diff --git a/sys-devel/prelink/prelink-20050901.ebuild b/sys-devel/prelink/prelink-20050901.ebuild
deleted file mode 100644
index 909319890e26..000000000000
--- a/sys-devel/prelink/prelink-20050901.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20050901.ebuild,v 1.1 2005/12/02 16:28:26 azarah Exp $
-
-inherit eutils
-
-DESCRIPTION="Modifies executables so runtime libraries load faster"
-HOMEPAGE="ftp://people.redhat.com/jakub/prelink"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~azarah/prelink/${P}.tar.bz2
- ftp://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-libs/elfutils-0.100
- !dev-libs/libelf
- >=sys-libs/glibc-2.3.4
- >=sys-devel/binutils-2.15.90.0.1"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-20040707-init.patch
-
- # Build our /etc/env.d/60prelink
- cat > "${S}/60prelink" <<-EOF
- $(
- # Need to initialize PRELINK_PATH_MASK so that we can
- # just add ':${x}' below.
- PRELINK_PATH_MASK="/lib/modules"
- # Ok, now add the rest
- for x in /usr/$(get_libdir)/locale \
- /usr/$(get_libdir)/wine \
- /usr/$(get_libdir)/valgrind \
- "*.la" "*.png" "*.py" "*.pl" "*.pm" \
- "*.sh" "*.xml" "*.xslt" "*.a" "*.js" ; do
- PRELINK_PATH_MASK="${PRELINK_PATH_MASK}:${x}"
- done
- # Now add it quoted
- echo PRELINK_PATH_MASK="\"${PRELINK_PATH_MASK}\""
- )
- PRELINK_PATH=""
- EOF
-}
-
-src_compile() {
- econf || die "Configure failed"
- emake || die "Make Failed"
-}
-
-src_install() {
- einstall || die "Install Failed"
-
- doenvd ${S}/60prelink
-
- dodoc INSTALL TODO ChangeLog THANKS COPYING README AUTHORS NEWS
-}
-
-pkg_postinst() {
- echo
- einfo "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- einfo "found online at:"
- einfo " http://www.gentoo.org/doc/en/prelink-howto.xml"
- echo
-}
diff --git a/sys-devel/prelink/prelink-20060213.ebuild b/sys-devel/prelink/prelink-20060213.ebuild
deleted file mode 100644
index f26e9ce49a63..000000000000
--- a/sys-devel/prelink/prelink-20060213.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20060213.ebuild,v 1.2 2007/07/15 04:37:55 mr_bones_ Exp $
-
-inherit eutils
-
-DESCRIPTION="Modifies executables so runtime libraries load faster"
-HOMEPAGE="ftp://people.redhat.com/jakub/prelink"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- http://dev.gentoo.org/~azarah/prelink/${P}.tar.bz2
- ftp://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-libs/elfutils-0.100
- !dev-libs/libelf
- >=sys-libs/glibc-2.3.4
- >=sys-devel/binutils-2.15.90.0.1"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-20040707-init.patch
- epatch ${FILESDIR}/${PN}-20060213-symloop.patch
-
- # Build our /etc/env.d/60prelink
- cat > "${S}/60prelink" <<-EOF
- $(
- # Need to initialize PRELINK_PATH_MASK so that we can
- # just add ':${x}' below.
- PRELINK_PATH_MASK="/lib/modules"
- # Ok, now add the rest
- for x in /usr/$(get_libdir)/locale \
- /usr/$(get_libdir)/wine \
- /usr/$(get_libdir)/valgrind \
- "*.la" "*.png" "*.py" "*.pl" "*.pm" \
- "*.sh" "*.xml" "*.xslt" "*.a" "*.js" ; do
- PRELINK_PATH_MASK="${PRELINK_PATH_MASK}:${x}"
- done
- # Now add it quoted
- echo PRELINK_PATH_MASK="\"${PRELINK_PATH_MASK}\""
- )
- PRELINK_PATH=""
- EOF
-}
-
-src_compile() {
- econf || die "Configure failed"
- emake || die "Make Failed"
-}
-
-src_install() {
- einstall || die "Install Failed"
-
- doenvd ${S}/60prelink
-
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/prelink.cron prelink
- newconfd "${FILESDIR}"/prelink.confd prelink
-
- dodir /var/{lib/misc,log}
- touch "${D}/var/lib/misc/prelink.full"
- touch "${D}/var/lib/misc/prelink.quick"
- touch "${D}/var/lib/misc/prelink.force"
- touch "${D}/var/log/prelink.log"
-
- dodoc INSTALL TODO ChangeLog THANKS COPYING README AUTHORS NEWS
-}
-
-pkg_postinst() {
- echo
- einfo "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- einfo "found online at:"
- einfo " http://www.gentoo.org/doc/en/prelink-howto.xml"
- einfo "Added cron job at /etc/cron.daily/prelink"
- einfo "Edit /etc/conf.d/prelink to enable / configure"
- echo
- touch "${ROOT}/var/lib/misc/prelink.force"
-}
diff --git a/sys-devel/prelink/prelink-20061201.ebuild b/sys-devel/prelink/prelink-20061201.ebuild
deleted file mode 100644
index 6bd58d89a8d3..000000000000
--- a/sys-devel/prelink/prelink-20061201.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/prelink/prelink-20061201.ebuild,v 1.3 2007/04/07 09:02:31 vapier Exp $
-
-# the tar.bz2 was ripped from prelink-0.3.10-1.src.rpm on Fedora mirrors
-
-inherit eutils
-
-DESCRIPTION="modifies ELFs so they load faster at runtime"
-HOMEPAGE="http://people.redhat.com/jakub/prelink"
-SRC_URI="mirror://gentoo/${P}.tar.bz2
- ftp://people.redhat.com/jakub/prelink/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE=""
-
-DEPEND=">=dev-libs/elfutils-0.100
- !dev-libs/libelf
- >=sys-libs/glibc-2.3.4"
-RDEPEND="${DEPEND}
- >=sys-devel/binutils-2.15.90.0.1"
-
-S=${WORKDIR}/${PN}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-prelink-conf.patch
- sed -i \
- -e '/^CC=/s: : -Wl,--disable-new-dtags :' \
- testsuite/functions.sh #100147
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "Install Failed"
-
- insinto /etc
- doins doc/prelink.conf || die
-
- exeinto /etc/cron.daily
- newexe "${FILESDIR}"/prelink.cron prelink
- newconfd "${FILESDIR}"/prelink.confd prelink
-
- dodir /var/{lib/misc,log}
- touch "${D}/var/lib/misc/prelink.full"
- touch "${D}/var/lib/misc/prelink.quick"
- touch "${D}/var/lib/misc/prelink.force"
- touch "${D}/var/log/prelink.log"
-
- dodoc INSTALL TODO ChangeLog THANKS COPYING README AUTHORS NEWS
-}
-
-pkg_postinst() {
- echo
- elog "You may wish to read the Gentoo Linux Prelink Guide, which can be"
- elog "found online at:"
- elog " http://www.gentoo.org/doc/en/prelink-howto.xml"
- elog "Added cron job at /etc/cron.daily/prelink"
- elog "Edit /etc/conf.d/prelink to enable / configure"
- echo
- touch "${ROOT}/var/lib/misc/prelink.force"
-}