summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-11 19:02:12 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-11 19:02:12 +0000
commit88b228b886743e495fdc5e1b49e0be3ce240a738 (patch)
treeb1b1d1866b468108339b5d48b313d64fc906ea34 /sys-devel/pmake
parentAdjust all ebuilds to each other (diff)
downloadgentoo-2-88b228b886743e495fdc5e1b49e0be3ce240a738.tar.gz
gentoo-2-88b228b886743e495fdc5e1b49e0be3ce240a738.tar.bz2
gentoo-2-88b228b886743e495fdc5e1b49e0be3ce240a738.zip
remove old
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/ChangeLog6
-rw-r--r--sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch13
-rw-r--r--sys-devel/pmake/pmake-1.111.1-r1.ebuild83
-rw-r--r--sys-devel/pmake/pmake-1.98.ebuild67
4 files changed, 5 insertions, 164 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
index e9204d977383..62b23f3b0c14 100644
--- a/sys-devel/pmake/ChangeLog
+++ b/sys-devel/pmake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/pmake
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.43 2011/07/10 14:29:24 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.44 2011/07/11 19:02:09 aballier Exp $
+
+ 11 Jul 2011; Alexis Ballier <aballier@gentoo.org> -pmake-1.98.ebuild,
+ -pmake-1.111.1-r1.ebuild, -files/pmake-1.111.1-obsd-inttypes.patch:
+ remove old
10 Jul 2011; Raúl Porcel <armin76@gentoo.org> pmake-1.111.3.1.ebuild:
alpha/ia64/sparc stable wrt #367891
diff --git a/sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch b/sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch
deleted file mode 100644
index f9ee9a62b759..000000000000
--- a/sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- pmake.orig/buf.c 2006-04-24 10:11:09 -0300
-+++ pmake/buf.c 2006-04-24 10:16:46 -0300
-@@ -82,6 +82,10 @@
- #endif /* not lint */
- #endif
-
-+#if defined(__OpenBSD__)
-+# include <inttypes.h>
-+#endif
-+
- /*-
- * buf.c --
- * Functions for automatically-expanded buffers.
diff --git a/sys-devel/pmake/pmake-1.111.1-r1.ebuild b/sys-devel/pmake/pmake-1.111.1-r1.ebuild
deleted file mode 100644
index 152afc6da4e5..000000000000
--- a/sys-devel/pmake/pmake-1.111.1-r1.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.1-r1.ebuild,v 1.1 2008/09/25 08:45:14 aballier Exp $
-
-inherit eutils toolchain-funcs versionator
-
-MY_P="${PN}-$(get_version_component_range 1-2)"
-DEBIAN_SOURCE="${PN}_$(get_version_component_range 1-2).orig.tar.gz"
-DEBIAN_PATCH="${PN}_$(replace_version_separator 2 '-').diff.gz"
-
-DESCRIPTION="BSD build tool to create programs in parallel. Debian's version of NetBSD's make"
-HOMEPAGE="http://www.netbsd.org/"
-SRC_URI="mirror://debian/pool/main/p/pmake/${DEBIAN_SOURCE}
- mirror://debian/pool/main/p/pmake/${DEBIAN_PATCH}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND=""
-
-S="${WORKDIR}/${PN}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${WORKDIR}/${DEBIAN_PATCH/.gz/}"
-
- # pmake makes the assumption that . and .. are the first two
- # entries in a directory, which doesn't always appear to be the
- # case on ext3... (05 Apr 2004 agriffis)
- epatch "${FILESDIR}/${PN}-1.98-skipdots.patch"
-
- # Add inttypes.h header on OpenBSD
- epatch "${FILESDIR}/${P}-obsd-inttypes.patch"
-
- # Clean up headers to reduce warnings
- sed -i -e 's|^#endif.*|#endif|' *.h */*.h
-
- # Don't ignore ldflags
- epatch "${FILESDIR}/${P}-ldflags.patch"
-}
-
-src_compile() {
- # The following CFLAGS are almost directly from Red Hat 8.0 and
- # debian/rules, so assume it's okay to void out the __COPYRIGHT
- # and __RCSID. I've checked the source and don't see the point,
- # but whatever... (07 Feb 2004 agriffis)
- CFLAGS="${CFLAGS} -Wall -Wno-unused -D_GNU_SOURCE \
- -DHAVE_STRERROR -DHAVE_STRDUP -DHAVE_SETENV \
- -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
- -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"$(tc-arch-kernel)\\\""
- if [[ "${USERLAND}" == "GNU" ]]; then
- CFLAGS="${CFLAGS} -D_PATH_DEFSYSPATH=\\\"/usr/share/mk/${PN}\\\""
- fi
-
- make -f Makefile.boot \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- || die "make failed"
-}
-
-src_install() {
- # Don't install these on BSD, else they conflict
- if [[ "${USERLAND}" == "GNU" ]]; then
- insinto /usr/share/mk/${PN}
- doins mk/*
- fi
-
- newbin bmake pmake || die "newbin failed"
- dobin mkdep || die "dobin failed"
- mv make.1 pmake.1
- doman mkdep.1 pmake.1
- dodoc PSD.doc/tutorial.ms
-
- if [[ "${USERLAND}" == "BSD" ]]; then
- dosym pmake /usr/bin/make
- dosym pmake.1.gz /usr/share/man/man1/make.1.gz
- fi
-}
diff --git a/sys-devel/pmake/pmake-1.98.ebuild b/sys-devel/pmake/pmake-1.98.ebuild
deleted file mode 100644
index de47b87db1a1..000000000000
--- a/sys-devel/pmake/pmake-1.98.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.98.ebuild,v 1.11 2009/09/23 20:42:21 patrick Exp $
-
-inherit eutils toolchain-funcs
-
-MY_P="${P/-/_}"
-DEB_PL="3"
-DESCRIPTION="BSD build tool to create programs in parallel. Debian's version of NetBSD's make"
-HOMEPAGE="http://www.netbsd.org/"
-SRC_URI="mirror://debian/pool/main/p/pmake/${MY_P}.orig.tar.gz
- mirror://debian/pool/main/p/pmake/${MY_P}-${DEB_PL}.diff.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
-
-S="${WORKDIR}/make_HEAD"
-
-src_unpack() {
- unpack ${A} && cd ${S} || die
-
- # debian patch (which includes the mk defs)
- epatch ${WORKDIR}/${MY_P}-${DEB_PL}.diff
-
- # pmake makes the assumption that . and .. are the first two
- # entries in a directory, which doesn't always appear to be the
- # case on ext3... (05 Apr 2004 agriffis)
- epatch ${FILESDIR}/${P}-skipdots.patch
-
- # Clean up headers to reduce warnings
- sed -i -e 's|^#endif.*|#endif|' *.h */*.h
-}
-
-src_compile() {
- local a=$ARCH
- [[ $a = x86 ]] && a=i386
-
- # The following CFLAGS are almost directly from Red Hat 8.0 and
- # debian/rules, so assume it's okay to void out the __COPYRIGHT
- # and __RCSID. I've checked the source and don't see the point,
- # but whatever... (07 Feb 2004 agriffis)
- CFLAGS="${CFLAGS} -Wall -Wno-unused -D_GNU_SOURCE \
- -DHAVE_STRERROR -DHAVE_STRDUP -DHAVE_SETENV \
- -D__COPYRIGHT\(x\)= -D__RCSID\(x\)= -I. \
- -DMACHINE=\\\"gentoo\\\" -DMACHINE_ARCH=\\\"${a}\\\""
- make -f Makefile.boot \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- || die "make failed"
-}
-
-src_install() {
- insinto /usr/share/mk
- doins mk/*
-
- newbin bmake pmake || die
- dobin mkdep || die
- mv make.1 pmake.1
- doman mkdep.1 pmake.1
- dodoc PSD.doc/tutorial.ms
-}