summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-05-08 14:24:04 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-05-08 14:24:04 +0000
commit39e50539ac34e3170b4d4712419855dbc30077a4 (patch)
tree7be5a96b4fe8d736e4dd7be6869ee5998d94bfda /sys-devel/patch
parent~amd64 (Manifest recommit) (diff)
downloadgentoo-2-39e50539ac34e3170b4d4712419855dbc30077a4.tar.gz
gentoo-2-39e50539ac34e3170b4d4712419855dbc30077a4.tar.bz2
gentoo-2-39e50539ac34e3170b4d4712419855dbc30077a4.zip
Fixes BUG #46892.
Diffstat (limited to 'sys-devel/patch')
-rw-r--r--sys-devel/patch/ChangeLog7
-rw-r--r--sys-devel/patch/patch-2.5.9.ebuild14
2 files changed, 18 insertions, 3 deletions
diff --git a/sys-devel/patch/ChangeLog b/sys-devel/patch/ChangeLog
index c129ad9e2de9..b00a834fd783 100644
--- a/sys-devel/patch/ChangeLog
+++ b/sys-devel/patch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/patch
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.20 2004/03/29 21:53:56 avenj Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/ChangeLog,v 1.21 2004/05/08 14:24:04 kugelfang Exp $
+
+ 08 May 2004; Danny van Dyk <kugelfang@gentoo.org> patch-2.5.9.ebuild:
+ Filtering "-pie" from LDFLAGS and appending manually to the Makefile for amd64.
29 Mar 2004; Jon Portnoy <avenj@gentoo.org> patch-2.5.9.ebuild :
Added strip-flags, bug #42698.
diff --git a/sys-devel/patch/patch-2.5.9.ebuild b/sys-devel/patch/patch-2.5.9.ebuild
index b56b7b5f6b2c..6c0d70f427d5 100644
--- a/sys-devel/patch/patch-2.5.9.ebuild
+++ b/sys-devel/patch/patch-2.5.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.15 2004/04/24 08:06:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/patch/patch-2.5.9.ebuild,v 1.16 2004/05/08 14:24:04 kugelfang Exp $
inherit flag-o-matic
@@ -20,8 +20,20 @@ DEPEND="virtual/glibc"
src_compile() {
strip-flags
CFLAGS="$CFLAGS -DLINUX -D_XOPEN_SOURCE=500"
+ # workaround for hardened on amd64, 1st part
+ if [ "`use amd64`" ] && [ "is-ldflags -pie" ]; then
+ einfo Stripping "-pie" from LDFLAGS, adding it to Makefile manually
+ filter-ldflags -pie
+ append-flags -fPIC
+ LDFLAGS_PIE="1"
+ fi
ac_cv_sys_long_file_names=yes \
./configure --host=${CHOST} --prefix=/usr --mandir=/usr/share/man
+ # workaround for hardened on amd64, 2nd part
+ if [ ${LDFLAGS_PIE} = "1" ]; then
+ einfo "Patching Makefile..."
+ sed -i -e 's/^LDFLAGS =/& -pie/' Makefile || die "Patching Makefile failed!"
+ fi
if ! use static ; then
emake || die "emake failed"
else