summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-04-27 22:49:21 +0000
committerRobert Coie <rac@gentoo.org>2003-04-27 22:49:21 +0000
commitbbaca134832dae11b164c0a091d1babf6e618962 (patch)
tree011e9db325a258f9acf5452f3d23d253334e3e8f /sys-devel/makepp/makepp-1.18.ebuild
parentThanks vapier, fixed ebuild up so it is correct. (diff)
downloadgentoo-2-bbaca134832dae11b164c0a091d1babf6e618962.tar.gz
gentoo-2-bbaca134832dae11b164c0a091d1babf6e618962.tar.bz2
gentoo-2-bbaca134832dae11b164c0a091d1babf6e618962.zip
initial import from bug 4191
Diffstat (limited to 'sys-devel/makepp/makepp-1.18.ebuild')
-rw-r--r--sys-devel/makepp/makepp-1.18.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-devel/makepp/makepp-1.18.ebuild b/sys-devel/makepp/makepp-1.18.ebuild
new file mode 100644
index 000000000000..41dd9a68a2a3
--- /dev/null
+++ b/sys-devel/makepp/makepp-1.18.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/makepp/makepp-1.18.ebuild,v 1.1 2003/04/27 22:49:19 rac Exp $
+
+DESCRIPTION="GNU make replacement"
+HOMEPAGE="http://makepp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+DEPEND=">=dev-lang/perl-5.6.0"
+
+inherit eutils
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-install.patch
+ # There is a sandbox violation in this test.
+ # In future versions, this ebuild should try to find
+ # a better way of avoiding this, but the current version
+ # appears to have garbage NUL characters all over the test files,
+ # making them complicated to edit.
+ # Robert Coie <rac@gentoo.org> 2002.02.18
+ rm ${S}/makepp_tests/include.test
+}
+
+src_compile() {
+ make test || die
+}
+
+src_install() {
+ perl install.pl /usr ${D} /usr/bin /usr/share/makepp /usr/share/doc/makepp
+}