summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2012-03-06 09:11:26 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2012-03-06 09:11:26 +0000
commit9412fbfddf72b5fbda0f8a5ff8d2b17c0960cbda (patch)
tree0d0da79de78407854daa457fa9c6ffb4117d9263 /sys-devel/llvm
parentRevbump supporting php 5.4 (diff)
downloadgentoo-2-9412fbfddf72b5fbda0f8a5ff8d2b17c0960cbda.tar.gz
gentoo-2-9412fbfddf72b5fbda0f8a5ff8d2b17c0960cbda.tar.bz2
gentoo-2-9412fbfddf72b5fbda0f8a5ff8d2b17c0960cbda.zip
Set python-2 to build, thanks Matthias Dahl in bug #406155 for report and patch. Also add PPC support patch and switch to EAPI4
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild18
2 files changed, 17 insertions, 7 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 28d35dd3efec..fbdf0d0863e3 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.62 2012/02/03 13:11:42 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.63 2012/03/06 09:11:26 voyageur Exp $
+
+ 06 Mar 2012; Bernard Cafarelli <voyageur@gentoo.org> llvm-9999.ebuild:
+ Set python-2 to build, thanks Matthias Dahl in bug #406155 for report and
+ patch. Also add PPC support patch and switch to EAPI4
*llvm-3.0-r1 (03 Feb 2012)
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 7769888d2d56..6d61a886b268 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.20 2012/01/27 13:42:08 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.21 2012/03/06 09:11:26 voyageur Exp $
-EAPI="3"
-inherit subversion eutils flag-o-matic multilib toolchain-funcs
+EAPI="4"
+PYTHON_DEPEND="2"
+inherit subversion eutils flag-o-matic multilib toolchain-funcs python
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -32,6 +33,10 @@ RDEPEND="dev-lang/perl
vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )"
pkg_setup() {
+ # llvm strictly requires python-2 for building
+ python_set_active_version 2
+ python_pkg_setup
+
# need to check if the active compiler is ok
broken_gcc=" 3.2.2 3.2.3 3.3.2 4.1.1 "
@@ -87,6 +92,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-2.6-commandguide-nops.patch
epatch "${FILESDIR}"/${PN}-2.9-nodoctargz.patch
+ epatch "${FILESDIR}"/${PN}-3.0-PPC_macro.patch
}
src_configure() {
@@ -123,15 +129,15 @@ src_configure() {
append-cppflags "$(pkg-config --cflags libffi)"
fi
CONF_FLAGS="${CONF_FLAGS} $(use_enable libffi)"
- econf ${CONF_FLAGS} || die "econf failed"
+ econf ${CONF_FLAGS}
}
src_compile() {
- emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1 || die "emake failed"
+ emake VERBOSE=1 KEEP_SYMBOLS=1 REQUIRES_RTTI=1
}
src_install() {
- emake KEEP_SYMBOLS=1 DESTDIR="${D}" install || die "install failed"
+ emake KEEP_SYMBOLS=1 DESTDIR="${D}" install
if use vim-syntax; then
insinto /usr/share/vim/vimfiles/syntax