summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-08-26 07:10:05 +0000
committerFabian Groffen <grobian@gentoo.org>2010-08-26 07:10:05 +0000
commit43a6e7f457b1da982b3a734148208b3faaccc413 (patch)
treeebfb173a37bd55c3ac8d94be701eb4dc647f207e /sys-devel/llvm
parentBump to EAPI=3, make Prefix aware, add support for Darwin platforms, bug #332605 (diff)
downloadgentoo-2-43a6e7f457b1da982b3a734148208b3faaccc413.tar.gz
gentoo-2-43a6e7f457b1da982b3a734148208b3faaccc413.tar.bz2
gentoo-2-43a6e7f457b1da982b3a734148208b3faaccc413.zip
use an existing compiler
(Portage version: 2.2.01.15553-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/llvm-2.7.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/llvm/llvm-2.7.ebuild b/sys-devel/llvm/llvm-2.7.ebuild
index 4566c5b435b2..e4a693decf3e 100644
--- a/sys-devel/llvm/llvm-2.7.ebuild
+++ b/sys-devel/llvm/llvm-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.3 2010/08/26 07:00:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.7.ebuild,v 1.4 2010/08/26 07:10:05 grobian Exp $
EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -20,7 +20,7 @@ DEPEND="dev-lang/perl
>=sys-devel/bison-1.28
!~sys-devel/bison-1.85
!~sys-devel/bison-1.875
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.1.2 )
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( virtual/libffi )
ocaml? ( dev-lang/ocaml )
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index e33f04435807..a12249b9c157 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.2 2010/08/26 07:00:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.3 2010/08/26 07:10:05 grobian Exp $
EAPI="3"
inherit subversion eutils multilib toolchain-funcs
@@ -21,7 +21,7 @@ DEPEND="dev-lang/perl
>=sys-devel/bison-1.28
!~sys-devel/bison-1.85
!~sys-devel/bison-1.875
- || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.1.2 )
+ || ( >=sys-devel/gcc-3.0 >=sys-devel/gcc-apple-4.2.1 )
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-3.2.3 )
libffi? ( virtual/libffi )
ocaml? ( dev-lang/ocaml )