summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-07 16:50:18 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-07 16:50:18 +0000
commit871148d98822664c3aef1367393b86e3c2c2d7aa (patch)
treef8867908b36496945b9171e031c51bc0bc4af1e8 /sys-devel/libperl
parentdont detect commented notrust lines (Manifest recommit) (diff)
downloadgentoo-2-871148d98822664c3aef1367393b86e3c2c2d7aa.tar.gz
gentoo-2-871148d98822664c3aef1367393b86e3c2c2d7aa.tar.bz2
gentoo-2-871148d98822664c3aef1367393b86e3c2c2d7aa.zip
move to ~ppc
Diffstat (limited to 'sys-devel/libperl')
-rw-r--r--sys-devel/libperl/libperl-5.8.4.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/sys-devel/libperl/libperl-5.8.4.ebuild b/sys-devel/libperl/libperl-5.8.4.ebuild
index 237c286c7ea9..c583aa77af53 100644
--- a/sys-devel/libperl/libperl-5.8.4.ebuild
+++ b/sys-devel/libperl/libperl-5.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.5 2004/06/02 05:02:51 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.4.ebuild,v 1.6 2004/06/07 16:50:18 vapier Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -82,7 +82,7 @@ fi
LIBPERL="libperl.so.${PERLSLOT}.${SHORT_PV}"
LICENSE="Artistic GPL-2"
-KEYWORDS="~x86 -ppc ~sparc ~mips ~alpha ~arm ~hppa amd64 ~ia64 ~ppc64 s390"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa amd64 ~ia64 ~ppc64 s390"
DEPEND="sys-apps/groff
berkdb? ( sys-libs/db )
@@ -98,7 +98,7 @@ PDEPEND=">=dev-lang/perl-${PV}"
pkg_setup() {
# I think this should rather be displayed if you *have* 'threads'
# in USE if it could break things ...
- if [ -n "`use threads`" ]
+ if use threads
then
ewarn ""
ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
@@ -142,7 +142,7 @@ src_compile() {
export LC_ALL="C"
local myconf=""
- if [ "`use threads`" ]
+ if use threads
then
einfo "using threads"
mythreading="-multi"
@@ -152,28 +152,28 @@ src_compile() {
myarch="${CHOST%%-*}-linux"
fi
- if [ "`use gdbm`" ]
+ if use gdbm
then
myconf="${myconf} -Di_gdbm"
fi
- if [ "`use berkdb`" ]
+ if use berkdb
then
myconf="${myconf} -Di_db -Di_ndbm"
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
- if [ "`use mips`" ]
+ if use mips
then
# this is needed because gcc 3.3-compiled kernels will hang
# the machine trying to run this test - check with `Kumba
# <rac@gentoo.org> 2003.06.26
myconf="${myconf} -Dd_u32align"
fi
- if [ "`use sparc`" ]
+ if use sparc
then
myconf="${myconf} -Ud_longdbl"
fi
- if [ "`use sparc64`" ]
+ if use sparc64
then
myconf="${myconf} -Ud_longdbl"
fi
@@ -374,5 +374,3 @@ pkg_postinst() {
fi
fi
}
-
-