summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-05-30 02:44:56 +0000
committerNed Ludd <solar@gentoo.org>2005-05-30 02:44:56 +0000
commit73e7afd5b7b78f33f129124625ca284d724c6dc8 (patch)
tree24a1a3ff6d2e1fda806c6b92717a2be4e577231c /sys-devel/libperl/libperl-5.8.6.ebuild
parent- update sys-apps/shadow to use libc expanded variable elibc_uclibc vs uclibc... (diff)
downloadgentoo-2-73e7afd5b7b78f33f129124625ca284d724c6dc8.tar.gz
gentoo-2-73e7afd5b7b78f33f129124625ca284d724c6dc8.tar.bz2
gentoo-2-73e7afd5b7b78f33f129124625ca284d724c6dc8.zip
- update sys-devel/libperl to use libc expanded variable elibc_uclibc vs uclibc so USE=-* works
Diffstat (limited to 'sys-devel/libperl/libperl-5.8.6.ebuild')
-rw-r--r--sys-devel/libperl/libperl-5.8.6.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/sys-devel/libperl/libperl-5.8.6.ebuild b/sys-devel/libperl/libperl-5.8.6.ebuild
index 809cbe35349a..d16131f08f89 100644
--- a/sys-devel/libperl/libperl-5.8.6.ebuild
+++ b/sys-devel/libperl/libperl-5.8.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.9 2005/05/23 13:28:50 herbs Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.6.ebuild,v 1.10 2005/05/30 02:44:56 solar Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -52,7 +52,7 @@
#
# Martin Schlemmer <azarah@gentoo.org> (28 Dec 2002).
-IUSE="berkdb debug gdbm ithreads nocxx uclibc"
+IUSE="berkdb debug gdbm ithreads nocxx"
inherit eutils flag-o-matic toolchain-funcs
@@ -143,7 +143,7 @@ src_unpack() {
src_compile() {
# Perl has problems compiling with -Os in your flags
- use uclibc || replace-flags "-Os" "-O2"
+ use elibc_uclibc || replace-flags "-Os" "-O2"
# This flag makes compiling crash in interesting ways
filter-flags "-malign-double"