summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2009-02-18 03:24:40 +0000
committerJoshua Kinard <kumba@gentoo.org>2009-02-18 03:24:40 +0000
commit3f90b9c820037bd279ce1194d922fffc54030478 (patch)
tree2b0dd540b328518bb445c0a32bcfc713d86d779f /sys-devel/kgcc64
parentupdated DEPs to use jdk instead of jre (fixes bug #256610) (diff)
downloadgentoo-2-3f90b9c820037bd279ce1194d922fffc54030478.tar.gz
gentoo-2-3f90b9c820037bd279ce1194d922fffc54030478.tar.bz2
gentoo-2-3f90b9c820037bd279ce1194d922fffc54030478.zip
Add kgcc64-4.3.3 and add ~mips keyword to it. We're not affected by header issues with gcc (per #228115).
(Portage version: 2.1.6.7/cvs/Linux mips64)
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/ChangeLog10
-rw-r--r--sys-devel/kgcc64/kgcc64-4.3.3.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index f06593620ff5..6b4b5323964d 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/kgcc64
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.22 2008/12/09 02:14:45 halcy0n Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.23 2009/02/18 03:24:40 kumba Exp $
+
+*kgcc64-4.3.3 (18 Feb 2009)
+
+ 18 Feb 2009; Joshua Kinard <kumba@gentoo.org> +kgcc64-4.3.3.ebuild:
+ Add kgcc64-4.3.3 and add ~mips keyword to it. We're not affected by header
+ issues with gcc (per #228115).
09 Dec 2008; Mark Loeser <halcy0n@gentoo.org> kgcc64-4.1.2.ebuild,
kgcc64-4.2.4.ebuild, kgcc64-4.3.1.ebuild, kgcc64-4.3.2.ebuild:
diff --git a/sys-devel/kgcc64/kgcc64-4.3.3.ebuild b/sys-devel/kgcc64/kgcc64-4.3.3.ebuild
new file mode 100644
index 000000000000..35b5707c1f55
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.3.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.3.ebuild,v 1.1 2009/02/18 03:24:40 kumba Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+ETYPE="gcc-compiler"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips; all other archs, refer to bug #228115
+KEYWORDS="~mips"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}