summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-07-21 00:07:08 +0000
committerJeroen Roovers <jer@gentoo.org>2010-07-21 00:07:08 +0000
commit222f4e00bb788a00d97c6c21300ad4864e13b921 (patch)
treed863b8c2b489cfdac5b8c89fa67e3445658584b2 /sys-devel/kgcc64
parentadded amd64 keyword + ebuild cleanup. (diff)
downloadgentoo-2-222f4e00bb788a00d97c6c21300ad4864e13b921.tar.gz
gentoo-2-222f4e00bb788a00d97c6c21300ad4864e13b921.tar.bz2
gentoo-2-222f4e00bb788a00d97c6c21300ad4864e13b921.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/ChangeLog7
-rw-r--r--sys-devel/kgcc64/kgcc64-4.4.4.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index 680126a564b1..4f47ab5c85f6 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.27 2010/07/17 16:23:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.28 2010/07/21 00:07:08 jer Exp $
+
+*kgcc64-4.4.4 (21 Jul 2010)
+
+ 21 Jul 2010; Jeroen Roovers <jer@gentoo.org> +kgcc64-4.4.4.ebuild:
+ Version bump.
17 Jul 2010; Jeroen Roovers <jer@gentoo.org> kgcc64-4.3.1.ebuild,
kgcc64-4.3.2.ebuild, kgcc64-4.3.3.ebuild:
diff --git a/sys-devel/kgcc64/kgcc64-4.4.4.ebuild b/sys-devel/kgcc64/kgcc64-4.4.4.ebuild
new file mode 100644
index 000000000000..fa72aaa9ea44
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.4.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.4.4.ebuild,v 1.1 2010/07/21 00:07:08 jer Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.0"
+ETYPE="gcc-compiler"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+# Works on mips and sparc; all other archs, refer to bug #228115
+KEYWORDS="~hppa"
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64"
+
+pkg_postinst() {
+ toolchain_pkg_postinst
+
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}