summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-09-11 12:30:59 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-09-11 12:30:59 +0000
commit44e3d8c98e3a30136abaa4b06113e0badbb3f83e (patch)
tree593bd64a487d9a68cc7ee7d0834be1eb9c841299 /sys-devel/icecream
parentWith USE=-emacs, don't byte-compile emacs lisp files. Fixes bug 336708. (diff)
downloadgentoo-2-44e3d8c98e3a30136abaa4b06113e0badbb3f83e.tar.gz
gentoo-2-44e3d8c98e3a30136abaa4b06113e0badbb3f83e.tar.bz2
gentoo-2-44e3d8c98e3a30136abaa4b06113e0badbb3f83e.zip
Drop all old releases. Cleanup ebuild. Remove only stable version. Open stablereq if you use it in stable environment and trust it is working reliably.
(Portage version: 2.2_rc79/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/icecream')
-rw-r--r--sys-devel/icecream/ChangeLog13
-rw-r--r--sys-devel/icecream/files/0.9.6-symlinks.patch19
-rw-r--r--sys-devel/icecream/files/icecream7
-rw-r--r--sys-devel/icecream/files/icecream-config4
-rw-r--r--sys-devel/icecream/files/icecream-create-env4
-rw-r--r--sys-devel/icecream/files/icecream-dont-create-symlinks.patch14
-rw-r--r--sys-devel/icecream/icecream-0.9.3.ebuild106
-rw-r--r--sys-devel/icecream/icecream-0.9.4.ebuild128
-rw-r--r--sys-devel/icecream/icecream-0.9.6.ebuild (renamed from sys-devel/icecream/icecream-0.9.2.ebuild)68
9 files changed, 62 insertions, 301 deletions
diff --git a/sys-devel/icecream/ChangeLog b/sys-devel/icecream/ChangeLog
index 8296113ad246..09a95a007e92 100644
--- a/sys-devel/icecream/ChangeLog
+++ b/sys-devel/icecream/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for sys-devel/icecream
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.37 2010/06/02 06:47:39 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.38 2010/09/11 12:30:59 scarabeus Exp $
+
+*icecream-0.9.6 (11 Sep 2010)
+
+ 11 Sep 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.9.6-symlinks.patch, -icecream-0.9.2.ebuild,
+ -icecream-0.9.3.ebuild, -icecream-0.9.4.ebuild, +icecream-0.9.6.ebuild,
+ files/icecream, files/icecream-config, files/icecream-create-env,
+ -files/icecream-dont-create-symlinks.patch:
+ Drop all old releases. Cleanup ebuild. Remove only stable version. Open
+ stablereq if you use it in stable environment and trust it is working
+ reliably.
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove bluebird from metadata.xml (#223101)
diff --git a/sys-devel/icecream/files/0.9.6-symlinks.patch b/sys-devel/icecream/files/0.9.6-symlinks.patch
new file mode 100644
index 000000000000..279ee0cc0f99
--- /dev/null
+++ b/sys-devel/icecream/files/0.9.6-symlinks.patch
@@ -0,0 +1,19 @@
+diff -urN icecc-0.9.6//client/Makefile.am icecc-0.9.6.new//client/Makefile.am
+--- icecc-0.9.6//client/Makefile.am 2010-09-11 13:43:53.922000148 +0200
++++ icecc-0.9.6.new//client/Makefile.am 2010-09-11 13:44:39.950000148 +0200
+@@ -7,15 +7,3 @@
+ noinst_HEADERS = client.h md5.h util.h
+
+ EXTRA_DIST = icecc-create-env
+-
+-install-exec-local:
+- $(mkinstalldirs) $(DESTDIR)$(bindir)
+- for link in g++ gcc c++ cc icerun; do \
+- rm -f $(DESTDIR)$(bindir)/$$link ;\
+- $(LN_S) icecc $(DESTDIR)$(bindir)/$$link ;\
+- done
+-
+-uninstall-local:
+- for link in g++ gcc c++ cc; do \
+- rm $(DESTDIR)$(bindir)/$$link ;\
+- done
diff --git a/sys-devel/icecream/files/icecream b/sys-devel/icecream/files/icecream
index cae25eb28a4f..b3f5d791a686 100644
--- a/sys-devel/icecream/files/icecream
+++ b/sys-devel/icecream/files/icecream
@@ -1,13 +1,13 @@
#!/sbin/runscript
-
-#NB: Config is in /etc/conf.d/icecream
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/files/icecream,v 1.3 2010/09/11 12:30:59 scarabeus Exp $
depend() {
need net
}
start() {
-
local basedir=${ICECREAM_BASEDIR:-"/var/cache/icecream"}
local netname=${ICECREAM_NETNAME:+"-n ${ICECREAM_NETNAME}"}
local logfile=${ICECREAM_LOG_FILE:+"-l ${ICECREAM_LOG_FILE}"}
@@ -35,6 +35,7 @@ stop() {
ebegin "Stopping Distributed Compiler Daemon"
start-stop-daemon --stop --quiet --name iceccd
eend ${?}
+
if [[ "${ICECREAM_RUN_SCHEDULER}" == "yes" ]]; then
ebegin "Stopping Distributed Compiler Scheduler"
start-stop-daemon --stop --quiet --name scheduler
diff --git a/sys-devel/icecream/files/icecream-config b/sys-devel/icecream/files/icecream-config
index d520072090f0..6ed24c743772 100644
--- a/sys-devel/icecream/files/icecream-config
+++ b/sys-devel/icecream/files/icecream-config
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
#
# icecream-config - helper script for icecream and its ebuild
#
-# Copyright 2003 Superlucidity Services, LLC
+# Copyright 2003-2010 Superlucidity Services, LLC
# This program licensed under the GNU GPL version 2.
#
# This script developed by Zachary T Welch at Superlucidity Services, LLC
diff --git a/sys-devel/icecream/files/icecream-create-env b/sys-devel/icecream/files/icecream-create-env
index 92b08364d908..632bdc5bd2dd 100644
--- a/sys-devel/icecream/files/icecream-create-env
+++ b/sys-devel/icecream/files/icecream-create-env
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
#
# icecream-create-env - helper script to create icecc environments(mostly for cross-compiling)
#
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
#
# Please note, this script has been designed to work with Gentoo's crossdev, it may or may
diff --git a/sys-devel/icecream/files/icecream-dont-create-symlinks.patch b/sys-devel/icecream/files/icecream-dont-create-symlinks.patch
deleted file mode 100644
index 5f9daa5f7e18..000000000000
--- a/sys-devel/icecream/files/icecream-dont-create-symlinks.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff -urN icecream.orig/client/Makefile.am icecream/client/Makefile.am
---- icecream.orig/client/Makefile.am
-+++ icecream/client/Makefile.am
-@@ -17,10 +17,6 @@
-
- install-exec-local:
- $(mkinstalldirs) $(DESTDIR)$(bindir)
-- for link in g++ gcc c++ cc; do \
-- rm -f $(DESTDIR)$(bindir)/$$link ;\
-- $(LN_S) icecc $(DESTDIR)$(bindir)/$$link ;\
-- done
-
- uninstall-local:
- for link in g++ gcc c++ cc; do \
diff --git a/sys-devel/icecream/icecream-0.9.3.ebuild b/sys-devel/icecream/icecream-0.9.3.ebuild
deleted file mode 100644
index ef61b2430ab1..000000000000
--- a/sys-devel/icecream/icecream-0.9.3.ebuild
+++ /dev/null
@@ -1,106 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.3.ebuild,v 1.4 2010/02/12 19:38:47 armin76 Exp $
-
-inherit autotools eutils flag-o-matic
-
-MY_P="icecc-${PV}"
-
-DESCRIPTION="icecc is a program for distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="http://en.opensuse.org/Icecream"
-SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
-IUSE=""
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-dont-create-symlinks.patch"
- epatch "${FILESDIR}/${PN}-conf.d-verbosity.patch"
-
- # honour ${CFLAGS_${ABI}} environment variable, bug #232931
- epatch "${FILESDIR}/${PN}-gentoo-multilib.patch"
-
- use amd64 && append-flags -fPIC -DPIC
-
- eautoreconf
-}
-
-src_compile() {
- econf
- emake || die "compiling icecc failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- dosbin "${FILESDIR}"/icecream-config || die "install failed"
-
- dosbin "${FILESDIR}"/icecream-create-env || die "install failed"
-
- newconfd suse/sysconfig.icecream icecream || die "install failed"
- doinitd "${FILESDIR}"/icecream || die "install failed"
-
- diropts -m0755
- keepdir /usr/lib/icecc/bin
-}
-
-pkg_postinst() {
- enewgroup icecream
-
- #are we doing bootstrap with has no useradd?
- if [ -x /usr/sbin/useradd ]; then
- enewuser icecream -1 -1 /var/cache/icecream icecream
- else
- ewarn "You do not have useradd (bootstrap) from shadow so I didn't"
- ewarn "install the icecream user. Note that attempting to start the daemon"
- ewarn "will fail. Please install shadow and re-emerge icecream."
- ebeep 2
- fi
-
- if [[ "${ROOT}" = "/" ]] ; then
- einfo "Scanning for compiler front-ends..."
- /usr/sbin/icecream-config --install-links
- /usr/sbin/icecream-config --install-links "${CHOST}"
- else
- ewarn "Install is incomplete; you must run the following command:"
- ewarn " # icecream-config --install-links \"${CHOST}\""
- ewarn "after booting or chrooting to \"${ROOT}\" to complete installation."
- fi
-
- elog
- elog "If you have compiled binutils/gcc/glibc with processor-specific flags"
- elog "(as normal using Gentoo), there is a greater chance that your compiler"
- elog "won't work on other machines. The best would be to build gcc, glibc and"
- elog "binutils without those flags and then copy the needed files into your"
- elog "tarball for distribution to other machines. This tarball can be created"
- elog "by running /usr/bin/icecc --build-native, and used by setting"
- elog "ICECC_VERSION in /etc/conf.d/icecream"
- elog ' ICECC_VERSION=<filename_of_archive_containing_your_environment>'
- elog
- elog "To use icecream with portage add the following line to /etc/make.conf"
- elog ' PREROOTPATH=/usr/lib/icecc/bin'
- elog
- elog "To use icecream with normal make use (e.g. in /etc/profile)"
- elog ' PATH=/usr/lib/icecc/bin:$PATH'
- elog
- elog "N.B. To use icecream with ccache, the ccache PATH should come first:"
- elog ' PATH=/usr/lib/ccache/bin:/usr/lib/icecc/bin:$PATH'
- elog
- elog "Don't forget to open the following ports in your firewall(s):"
- elog " TCP/10245 on the daemon computers (required)"
- elog " TCP/8765 for the the scheduler computer (required)"
- elog " TCP/8766 for the telnet interface to the scheduler (optional)"
- elog " UDP/8765 for broadcast to find the scheduler (optional)"
- elog
- elog "Further usage instructions: http://www.opensuse.org/icecream"
- elog
- elog "The icecream monitor is no longer included in this package."
- elog "See http://bugs.gentoo.org/show_bug.cgi?id=139432 for more info."
-}
diff --git a/sys-devel/icecream/icecream-0.9.4.ebuild b/sys-devel/icecream/icecream-0.9.4.ebuild
deleted file mode 100644
index 28e185e34e45..000000000000
--- a/sys-devel/icecream/icecream-0.9.4.ebuild
+++ /dev/null
@@ -1,128 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.4.ebuild,v 1.6 2010/02/12 19:38:47 armin76 Exp $
-
-inherit autotools eutils flag-o-matic
-
-MY_P="icecc-${PV}"
-
-DESCRIPTION="icecc is a program for distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="http://en.opensuse.org/Icecream"
-SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-
-DEPEND="!x11-misc/icecc"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-dont-create-symlinks.patch"
- epatch "${FILESDIR}/${PN}-conf.d-verbosity.patch"
-
- # honour ${CFLAGS_${ABI}} environment variable, bug #232931
- epatch "${FILESDIR}/${PN}-gentoo-multilib.patch"
-
- use amd64 && append-flags -fPIC -DPIC
-
- eautoreconf
-}
-
-src_compile() {
- econf
- emake || die "compiling icecc failed"
-
- # compile manpages...yeah, we need meinproc, ergo kdelibs for this :(
- #if use doc; then
- # cd doc
- # for docfile in *.docbook; do
- # outputfile="${docfile/man-/}"
- # outputfile="${outputfile/.docbook/}"
-
- # meinproc \
- # --stylesheet /usr/kde/3.5/share/apps/ksgmltools2/customization/kde-man.xsl \
- # "${docfile}" && \
- # mv manpage.troff "${outputfile}" || \
- # die "compiling manpages failed"
- # done
- #fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
-
- dosbin "${FILESDIR}"/icecream-config || die "install failed"
-
- dosbin "${FILESDIR}"/icecream-create-env || die "install failed"
-
- newconfd suse/sysconfig.icecream icecream || die "install failed"
- doinitd "${FILESDIR}"/icecream || die "install failed"
-
- diropts -m0755
- keepdir /usr/lib/icecc/bin
-
- #if use doc; then
- # cd doc
- # doman icecc.1 iceccd.1 icecream.7 scheduler.1 || die "doman failed"
- #fi
-}
-
-pkg_postinst() {
- enewgroup icecream
-
- #are we doing bootstrap with has no useradd?
- if [ -x /usr/sbin/useradd ]; then
- enewuser icecream -1 -1 /var/cache/icecream icecream
- else
- ewarn "You do not have useradd (bootstrap) from shadow so I didn't"
- ewarn "install the icecream user. Note that attempting to start the daemon"
- ewarn "will fail. Please install shadow and re-emerge icecream."
- ebeep 2
- fi
-
- if [[ "${ROOT}" = "/" ]] ; then
- einfo "Scanning for compiler front-ends..."
- /usr/sbin/icecream-config --install-links
- /usr/sbin/icecream-config --install-links "${CHOST}"
- else
- ewarn "Install is incomplete; you must run the following command:"
- ewarn " # icecream-config --install-links \"${CHOST}\""
- ewarn "after booting or chrooting to \"${ROOT}\" to complete installation."
- fi
-
- elog
- elog "If you have compiled binutils/gcc/glibc with processor-specific flags"
- elog "(as normal using Gentoo), there is a greater chance that your compiler"
- elog "won't work on other machines. The best would be to build gcc, glibc and"
- elog "binutils without those flags and then copy the needed files into your"
- elog "tarball for distribution to other machines. This tarball can be created"
- elog "by running /usr/bin/icecc --build-native, and used by setting"
- elog "ICECC_VERSION in /etc/conf.d/icecream"
- elog ' ICECC_VERSION=<filename_of_archive_containing_your_environment>'
- elog
- elog "To use icecream with portage add the following line to /etc/make.conf"
- elog ' PREROOTPATH=/usr/lib/icecc/bin'
- elog
- elog "To use icecream with normal make use (e.g. in /etc/profile)"
- elog ' PATH=/usr/lib/icecc/bin:$PATH'
- elog
- elog "N.B. To use icecream with ccache, the ccache PATH should come first:"
- elog ' PATH=/usr/lib/ccache/bin:/usr/lib/icecc/bin:$PATH'
- elog
- elog "Don't forget to open the following ports in your firewall(s):"
- elog " TCP/10245 on the daemon computers (required)"
- elog " TCP/8765 for the the scheduler computer (required)"
- elog " TCP/8766 for the telnet interface to the scheduler (optional)"
- elog " UDP/8765 for broadcast to find the scheduler (optional)"
- elog
- elog "Further usage instructions: http://www.opensuse.org/icecream"
- elog
- elog "The icecream monitor is no longer included in this package."
- elog "See http://bugs.gentoo.org/show_bug.cgi?id=139432 for more info."
-}
diff --git a/sys-devel/icecream/icecream-0.9.2.ebuild b/sys-devel/icecream/icecream-0.9.6.ebuild
index 05232541d331..3b1846ae21cc 100644
--- a/sys-devel/icecream/icecream-0.9.2.ebuild
+++ b/sys-devel/icecream/icecream-0.9.6.ebuild
@@ -1,47 +1,45 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.2.ebuild,v 1.7 2010/02/12 19:38:47 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.6.ebuild,v 1.1 2010/09/11 12:30:59 scarabeus Exp $
-inherit autotools eutils flag-o-matic
+EAPI=3
+
+inherit base autotools
MY_P="icecc-${PV}"
DESCRIPTION="icecc is a program for distributed compiling of C(++) code across several machines; based on distcc"
-HOMEPAGE="http://en.opensuse.org/Icecream"
+HOMEPAGE="http://old-en.opensuse.org/Icecream"
SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 ~arm ppc sparc x86"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
IUSE=""
S="${WORKDIR}/${MY_P}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${PN}-dont-create-symlinks.patch"
- epatch "${FILESDIR}/${PN}-conf.d-verbosity.patch"
+PATCHES=(
+ "${FILESDIR}/${PV}-symlinks.patch"
+ "${FILESDIR}/${PN}-conf.d-verbosity.patch"
+ "${FILESDIR}/${PN}-gentoo-multilib.patch"
+)
- # honour ${CFLAGS_${ABI}} environment variable, bug #232931
- epatch "${FILESDIR}/${PN}-gentoo-multilib.patch"
+pkg_setup() {
+ enewgroup icecream
+ enewuser icecream -1 -1 /var/cache/icecream icecream
+}
- use amd64 && append-flags -fPIC -DPIC
+src_prepare() {
+ base_src_prepare
eautoreconf
}
-src_compile() {
- econf
- emake || die "compiling icecc failed"
-}
-
src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+ base_src_install
dosbin "${FILESDIR}"/icecream-config || die "install failed"
-
dosbin "${FILESDIR}"/icecream-create-env || die "install failed"
newconfd suse/sysconfig.icecream icecream || die "install failed"
@@ -52,27 +50,10 @@ src_install() {
}
pkg_postinst() {
- enewgroup icecream
-
- #are we doing bootstrap with has no useradd?
- if [ -x /usr/sbin/useradd ]; then
- enewuser icecream -1 -1 /var/cache/icecream icecream
- else
- ewarn "You do not have useradd (bootstrap) from shadow so I didn't"
- ewarn "install the icecream user. Note that attempting to start the daemon"
- ewarn "will fail. Please install shadow and re-emerge icecream."
- ebeep 2
- fi
-
- if [[ "${ROOT}" = "/" ]] ; then
- einfo "Scanning for compiler front-ends..."
- /usr/sbin/icecream-config --install-links
- /usr/sbin/icecream-config --install-links "${CHOST}"
- else
- ewarn "Install is incomplete; you must run the following command:"
- ewarn " # icecream-config --install-links \"${CHOST}\""
- ewarn "after booting or chrooting to \"${ROOT}\" to complete installation."
- fi
+ ebegin "Scanning for compiler front-ends..."
+ /usr/sbin/icecream-config --install-links
+ /usr/sbin/icecream-config --install-links "${CHOST}"
+ eend ${?}
elog
elog "If you have compiled binutils/gcc/glibc with processor-specific flags"
@@ -99,8 +80,5 @@ pkg_postinst() {
elog " TCP/8766 for the telnet interface to the scheduler (optional)"
elog " UDP/8765 for broadcast to find the scheduler (optional)"
elog
- elog "Further usage instructions: http://www.opensuse.org/icecream"
- elog
- elog "The icecream monitor is no longer included in this package."
- elog "See http://bugs.gentoo.org/show_bug.cgi?id=139432 for more info."
+ elog "Further usage instructions: ${HOMEPAGE}"
}