summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-20 02:52:51 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-20 02:52:51 +0000
commitb02fda255c3ada0c93e896960049201d08748051 (patch)
tree235e1e981175af631ba6582949a1c9f3afadd2f7 /sys-devel/gnuconfig
parentStabilize for everyone. (diff)
downloadgentoo-2-b02fda255c3ada0c93e896960049201d08748051.tar.gz
gentoo-2-b02fda255c3ada0c93e896960049201d08748051.tar.bz2
gentoo-2-b02fda255c3ada0c93e896960049201d08748051.zip
Version bump.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/ChangeLog8
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20100403.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index f94adad32e95..78a7a046c2ef 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.48 2010/04/20 02:52:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.49 2010/04/20 02:52:51 vapier Exp $
+
+*gnuconfig-20100403 (20 Apr 2010)
+
+ 20 Apr 2010; Mike Frysinger <vapier@gentoo.org>
+ +gnuconfig-20100403.ebuild:
+ Version bump.
19 Apr 2010; Mike Frysinger <vapier@gentoo.org> gnuconfig-20100122.ebuild:
Stabilize for everyone.
diff --git a/sys-devel/gnuconfig/gnuconfig-20100403.ebuild b/sys-devel/gnuconfig/gnuconfig-20100403.ebuild
new file mode 100644
index 000000000000..d9068cb30e96
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20100403.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20100403.ebuild,v 1.1 2010/04/20 02:52:51 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git"
+ inherit git
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(head -n 1 ChangeLog | awk '{print $1}' | sed -e 's:-::g')
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+ epatch "${WORKDIR}"/*.patch
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}