summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-04-20 02:51:49 +0000
committerMike Frysinger <vapier@gentoo.org>2010-04-20 02:51:49 +0000
commit2377dd6f524386bca40c66dae88be08325bac781 (patch)
tree63c83c4468a17239281a6f3d0fad14657d7d60fe /sys-devel/gnuconfig
parentVersion bump. (diff)
downloadgentoo-2-2377dd6f524386bca40c66dae88be08325bac781.tar.gz
gentoo-2-2377dd6f524386bca40c66dae88be08325bac781.tar.bz2
gentoo-2-2377dd6f524386bca40c66dae88be08325bac781.zip
old
Diffstat (limited to 'sys-devel/gnuconfig')
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20090203.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/sys-devel/gnuconfig/gnuconfig-20090203.ebuild b/sys-devel/gnuconfig/gnuconfig-20090203.ebuild
deleted file mode 100644
index 00e2356d1c26..000000000000
--- a/sys-devel/gnuconfig/gnuconfig-20090203.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20090203.ebuild,v 1.2 2009/09/05 00:27:55 vapier Exp $
-
-inherit eutils
-if [[ ${PV} == "99999999" ]] ; then
- EGIT_REPO_URI="git://git.savannah.gnu.org/config.git"
- inherit git
-else
- SRC_URI="mirror://gentoo/${P}.tar.bz2"
- KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-fi
-
-DESCRIPTION="Updated config.sub and config.guess file from GNU"
-HOMEPAGE="http://savannah.gnu.org/projects/config"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-S=${WORKDIR}
-
-maint_pkg_create() {
- cd "${S}"
-
- local ver=$(head -n 1 ChangeLog | awk '{print $1}' | sed -e 's:-::g')
- [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
-
- cp "${FILESDIR}"/${PV}/*.patch . || die
-
- local tar="${T}/gnuconfig-${ver}.tar.bz2"
- tar -jcf ${tar} . || die "creating tar failed"
- einfo "Packaged tar now available:"
- einfo "$(du -b ${tar})"
-}
-
-src_unpack() {
- if [[ ${PV} == "99999999" ]] ; then
- git_src_unpack
- maint_pkg_create
- else
- unpack ${A}
- fi
- epatch "${WORKDIR}"/*.patch
- sed -i '/i386-pc-solaris2.6/d' testsuite/config-guess.data
- use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
-}
-
-src_compile() { :;}
-
-src_install() {
- insinto /usr/share/${PN}
- doins config.{sub,guess} || die
- fperms +x /usr/share/${PN}/config.{sub,guess}
- dodoc ChangeLog
-}