summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2002-10-20 00:56:24 +0000
committerBrandon Low <lostlogic@gentoo.org>2002-10-20 00:56:24 +0000
commit1fad4bdfef17cd156317df0326df19134c182f8a (patch)
tree26ec7637175c502e37b4e480a98dc4f63f4c1865 /sys-devel/gecc
parentnew import (diff)
downloadgentoo-2-1fad4bdfef17cd156317df0326df19134c182f8a.tar.gz
gentoo-2-1fad4bdfef17cd156317df0326df19134c182f8a.tar.bz2
gentoo-2-1fad4bdfef17cd156317df0326df19134c182f8a.zip
ebuild.makepretty();
Diffstat (limited to 'sys-devel/gecc')
-rw-r--r--sys-devel/gecc/gecc-20021019.ebuild108
1 files changed, 6 insertions, 102 deletions
diff --git a/sys-devel/gecc/gecc-20021019.ebuild b/sys-devel/gecc/gecc-20021019.ebuild
index 571c8f0e7d95..5c7b2122156d 100644
--- a/sys-devel/gecc/gecc-20021019.ebuild
+++ b/sys-devel/gecc/gecc-20021019.ebuild
@@ -1,124 +1,28 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/gecc-20021019.ebuild,v 1.2 2002/10/20 00:29:40 mjc Exp $
-
-# NOTE: The comments in this file are for instruction and documentation.
-# They're not meant to appear with your final, production ebuild. Please
-# remember to remove them before submitting or committing your ebuild. That
-# doesn't mean you can't add your own comments though.
-
-# The 'Header' on the third line should just be left alone. When your ebuild
-# will be commited to cvs, the details on that line will be automatically
-# generated to contain the correct data.
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gecc/gecc-20021019.ebuild,v 1.3 2002/10/20 00:56:24 lostlogic Exp $
# comprehensive list of any and all USE flags leveraged in the build,
# with the exception of any ARCH specific flags, i.e. ppc sparc sparc64
# x86 alpha - this is a required variable
IUSE=""
-
-# Short one-line description of this package.
DESCRIPTION="gecc is a tool to speed up compilation of C/C++ sources. It distributes the compilation on a cluster of compilation nodes. It also caches the object files to save some unneeded work."
-
-# Homepage, not used by Portage directly but handy for developer reference
HOMEPAGE="http://gecc.sourceforge.net/"
-
-# Point to any required sources; these will be automatically downloaded by
-# Portage.
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-# License of the package. This must match the name of file(s) in
-# /usr/portage/licenses/. For complex license combination see the developer
-# docs on gentoo.org for details.
LICENSE="gpl"
-
-# The SLOT variable is used to tell Portage if it's OK to keep multiple
-# versions of the same package installed at the same time. For example,
-# if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
-# with 1.2.2), it would be optimal to instruct Portage to not remove
-# libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
-# we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
-# emerge clean understands SLOTs, and will keep the most recent version
-# of each SLOT and remove everything else.
-# Note that normal applications should use SLOT="0" if possible, since
-# there should only be exactly one version installed at a time.
-# DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
SLOT="0"
-
-# Using KEYWORDS, we can record masking information *inside* an ebuild
-# instead of relying on an external package.mask file. Right now, you
-# should set the KEYWORDS variable for every ebuild so that it contains
-# the names of all the architectures with which the ebuild works. We have
-# 4 official architecture names right now: "x86", "ppc", "sparc" and
-# "sparc64". So, if you've confirmed that your ebuild works on x86 and ppc,
-# you'd specify: KEYWORDS="x86 ppc"
-# For packages that are platform-independant (like Java, PHP or Perl
-# applications) specify all keywords.
-# DO NOT USE KEYWORDS="*". This is deprecated and only for backward
-# compatibility reasons.
KEYWORDS="~x86"
-
-# Build-time dependencies, such as
-# ssl? ( >=openssl-0.9.6b )
-# >=perl-5.6.1-r1
-# It is advisable to use the >= syntax show above, to reflect what you
-# had installed on your system when you tested the package. Then
-# other users hopefully won't be caught without the right version of
-# a dependency.
DEPEND="sys-devel/gcc"
-
-# Run-time dependencies, same as DEPEND if RDEPEND isn't defined:
-#RDEPEND=""
-
-# Source directory; the dir where the sources can be found (automatically
-# unpacked) inside ${WORKDIR}. S will get a default setting of ${WORKDIR}/${P}
-# if you omit this line.
-
+RDEPEND="$DEPEND"
S="${WORKDIR}/${P}"
src_compile() {
- # Most open-source packages use GNU autoconf for configuration.
- # You should use something similar to the following lines to
- # configure your package before compilation. The "|| die" portion
- # at the end will stop the build process if the command fails.
- # You should use this at the end of critical commands in the build
- # process. (Hint: Most commands are critical, that is, the build
- # process should abort if they aren't successful.)
rm -rf test
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
- patch -p0 < ${FILESDIR}/${P}-gentoo.diff
- # Note the use of --infodir and --mandir, above. This is to make
- # this package FHS 2.2-compliant. For more information, see
- # http://www.pathname.com/fhs/
-
- # emake (previously known as pmake) is a script that calls the
- # standard GNU make with parallel building options for speedier
- # builds (especially on SMP systems). Try emake first. It might
- # not work for some packages, in which case you'll have to resort
- # to normal "make".
-
- emake || die
- #make || die
+ econf || die "configure failed"
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+ emake || die "make failed"
}
src_install() {
- # You must *personally verify* that this trick doesn't install
- # anything outside of DESTDIR; do this by reading and
- # understanding the install part of the Makefiles.
- make DESTDIR=${D} install
- # For Makefiles that don't make proper use of DESTDIR, setting
- # prefix is often an alternative. However if you do this, then
- # you also need to specify mandir and infodir, since they were
- # passed to ./configure as absolute paths (overriding the prefix
- # setting).
- #make \
- # prefix=${D}/usr \
- # mandir=${D}/usr/share/man \
- # infodir=${D}/usr/share/info \
- # install || die
- # Again, verify the Makefiles! We don't want anything falling
- # outside of ${D}.
+ einstall || die "Install failed"
}