summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-02-22 19:44:57 +0000
committerMike Frysinger <vapier@gentoo.org>2009-02-22 19:44:57 +0000
commitdc1ccbbefb6fed83eb27047c33c4730b5deb4bee (patch)
treec7670e58496106a4f6998eb410e8f074f1d9267f /sys-devel/gdb
parentcourier bump (diff)
downloadgentoo-2-dc1ccbbefb6fed83eb27047c33c4730b5deb4bee.tar.gz
gentoo-2-dc1ccbbefb6fed83eb27047c33c4730b5deb4bee.tar.bz2
gentoo-2-dc1ccbbefb6fed83eb27047c33c4730b5deb4bee.zip
old
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/gdb-6.7.1-r1.ebuild82
-rw-r--r--sys-devel/gdb/gdb-6.7.1-r2.ebuild84
-rw-r--r--sys-devel/gdb/gdb-6.7.1.ebuild82
-rw-r--r--sys-devel/gdb/gdb-6.7.ebuild82
-rw-r--r--sys-devel/gdb/gdb-6.8.ebuild86
5 files changed, 0 insertions, 416 deletions
diff --git a/sys-devel/gdb/gdb-6.7.1-r1.ebuild b/sys-devel/gdb/gdb-6.7.1-r1.ebuild
deleted file mode 100644
index b0428bc04c6d..000000000000
--- a/sys-devel/gdb/gdb-6.7.1-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.7.1-r1.ebuild,v 1.2 2007/12/30 20:14:22 vapier Exp $
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-PATCH_VER="1.2"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
-IUSE="nls test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-src_compile() {
- replace-flags -O? -O2
- econf \
- --disable-werror \
- $(use_enable nls) \
- || die
- emake || die
-}
-
-src_test() {
- make check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${ROOT}"/etc/skel/.gdbinit
-}
diff --git a/sys-devel/gdb/gdb-6.7.1-r2.ebuild b/sys-devel/gdb/gdb-6.7.1-r2.ebuild
deleted file mode 100644
index 6bafcac4d51b..000000000000
--- a/sys-devel/gdb/gdb-6.7.1-r2.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.7.1-r2.ebuild,v 1.3 2008/02/25 04:04:25 vapier Exp $
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-PATCH_VER="1.2"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="alpha ~amd64 arm ~hppa ia64 ~mips ~ppc ~ppc64 s390 sparc x86 ~x86-fbsd"
-IUSE="nls test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- sys-libs/readline"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-src_compile() {
- replace-flags -O? -O2
- econf \
- --disable-werror \
- --with-system-readline \
- $(use_enable nls) \
- || die
- emake || die
-}
-
-src_test() {
- make check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${ROOT}"/etc/skel/.gdbinit
-}
diff --git a/sys-devel/gdb/gdb-6.7.1.ebuild b/sys-devel/gdb/gdb-6.7.1.ebuild
deleted file mode 100644
index 3e17c7fe1779..000000000000
--- a/sys-devel/gdb/gdb-6.7.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.7.1.ebuild,v 1.9 2008/02/25 04:04:25 vapier Exp $
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-PATCH_VER="1.0"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sparc x86 ~x86-fbsd"
-IUSE="nls test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-src_compile() {
- replace-flags -O? -O2
- econf \
- --disable-werror \
- $(use_enable nls) \
- || die
- emake || die
-}
-
-src_test() {
- make check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${ROOT}"/etc/skel/.gdbinit
-}
diff --git a/sys-devel/gdb/gdb-6.7.ebuild b/sys-devel/gdb/gdb-6.7.ebuild
deleted file mode 100644
index c5e4d4aadfec..000000000000
--- a/sys-devel/gdb/gdb-6.7.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.7.ebuild,v 1.1 2007/10/10 20:14:54 vapier Exp $
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-PATCH_VER="1.0"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.bz2"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
-IUSE="nls test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2"
-DEPEND="${RDEPEND}
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-src_compile() {
- replace-flags -O? -O2
- econf \
- --disable-werror \
- $(use_enable nls) \
- || die
- emake || die
-}
-
-src_test() {
- make check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${ROOT}"/etc/skel/.gdbinit
-}
diff --git a/sys-devel/gdb/gdb-6.8.ebuild b/sys-devel/gdb/gdb-6.8.ebuild
deleted file mode 100644
index 935f796a4cee..000000000000
--- a/sys-devel/gdb/gdb-6.8.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-6.8.ebuild,v 1.4 2008/04/07 23:05:28 vapier Exp $
-
-inherit flag-o-matic eutils
-
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-PATCH_VER="1.2"
-DESCRIPTION="GNU debugger"
-HOMEPAGE="http://sources.redhat.com/gdb/"
-SRC_URI="http://ftp.gnu.org/gnu/gdb/${P}.tar.bz2
- ftp://sources.redhat.com/pub/gdb/releases/${P}.tar.bz2
- mirror://gentoo/${P}-patches-${PATCH_VER}.tar.lzma"
-
-LICENSE="GPL-2 LGPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
-IUSE="multitarget nls test vanilla"
-
-RDEPEND=">=sys-libs/ncurses-5.2-r2
- sys-libs/readline"
-DEPEND="${RDEPEND}
- app-arch/lzma-utils
- test? ( dev-util/dejagnu )
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- use vanilla || EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch
- strip-linguas -u bfd/po opcodes/po
-}
-
-src_compile() {
- strip-unsupported-flags
- econf \
- --disable-werror \
- --with-system-readline \
- $(use_enable nls) \
- $(use multitarget && echo --enable-targets=all) \
- || die
- emake || die
-}
-
-src_test() {
- make check || ewarn "tests failed"
-}
-
-src_install() {
- emake \
- DESTDIR="${D}" \
- libdir=/nukeme/pretty/pretty/please includedir=/nukeme/pretty/pretty/please \
- install || die
- rm -r "${D}"/nukeme || die
-
- # Don't install docs when building a cross-gdb
- if [[ ${CTARGET} != ${CHOST} ]] ; then
- rm -r "${D}"/usr/share
- return 0
- fi
-
- dodoc README
- docinto gdb
- dodoc gdb/CONTRIBUTE gdb/README gdb/MAINTAINERS \
- gdb/NEWS gdb/ChangeLog gdb/PROBLEMS
- docinto sim
- dodoc sim/ChangeLog sim/MAINTAINERS sim/README-HACKING
-
- dodoc "${WORKDIR}"/extra/gdbinit.sample
-
- # Remove shared info pages
- rm -f "${D}"/usr/share/info/{annotate,bfd,configure,standards}.info*
-}
-
-pkg_postinst() {
- # portage sucks and doesnt unmerge files in /etc
- rm -vf "${ROOT}"/etc/skel/.gdbinit
-}