summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-13 21:44:15 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-13 21:44:15 +0000
commit2c04624da3c35517ed4752f0c3df6dcca0f0a118 (patch)
treee4d406b9cfe87cc57fcb8830340882d9f42c9531 /sys-devel/gdb
parentVersion bump (diff)
downloadgentoo-2-2c04624da3c35517ed4752f0c3df6dcca0f0a118.tar.gz
gentoo-2-2c04624da3c35517ed4752f0c3df6dcca0f0a118.tar.bz2
gentoo-2-2c04624da3c35517ed4752f0c3df6dcca0f0a118.zip
Reject USE="-client -server" builds.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gdb')
-rw-r--r--sys-devel/gdb/ChangeLog8
-rw-r--r--sys-devel/gdb/gdb-7.8.1.ebuild9
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild9
3 files changed, 18 insertions, 8 deletions
diff --git a/sys-devel/gdb/ChangeLog b/sys-devel/gdb/ChangeLog
index dd318ff976df..de1c85c0a9ce 100644
--- a/sys-devel/gdb/ChangeLog
+++ b/sys-devel/gdb/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gdb
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.283 2014/11/11 10:52:58 ago Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/ChangeLog,v 1.284 2015/02/13 21:44:15 vapier Exp $
+
+ 13 Feb 2015; Mike Frysinger <vapier@gentoo.org> gdb-7.8.1.ebuild,
+ gdb-9999.ebuild:
+ Reject USE="-client -server" builds.
11 Nov 2014; Agostino Sarubbo <ago@gentoo.org> gdb-7.7.1.ebuild:
Stable for ia64, wrt bug #526376
diff --git a/sys-devel/gdb/gdb-7.8.1.ebuild b/sys-devel/gdb/gdb-7.8.1.ebuild
index e4e1d2af5052..ec148ab8cd32 100644
--- a/sys-devel/gdb/gdb-7.8.1.ebuild
+++ b/sys-devel/gdb/gdb-7.8.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.8.1.ebuild,v 1.1 2014/10/30 02:25:33 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-7.8.1.ebuild,v 1.2 2015/02/13 21:44:15 vapier Exp $
EAPI="4"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -54,7 +54,10 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ || ( client server )
+"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index 475ec20a833f..7cad98c25477 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.29 2014/08/04 01:30:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.30 2015/02/13 21:44:15 vapier Exp $
EAPI="4"
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -54,7 +54,10 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ || ( client server )
+"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2