summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-18 01:04:59 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-18 01:04:59 +0000
commite58ca174f5b37e99545cd5d7b6ac79477be78dbf (patch)
tree3e060f17e44250ff7bc9f1e5b3ed93d76be3c8fb /sys-devel/gdb/gdb-9999.ebuild
parenttypo fix (diff)
downloadgentoo-2-e58ca174f5b37e99545cd5d7b6ac79477be78dbf.tar.gz
gentoo-2-e58ca174f5b37e99545cd5d7b6ac79477be78dbf.tar.bz2
gentoo-2-e58ca174f5b37e99545cd5d7b6ac79477be78dbf.zip
Fix by Jonathan Callen for USE=-python handling #504830.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-devel/gdb/gdb-9999.ebuild')
-rw-r--r--sys-devel/gdb/gdb-9999.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/gdb/gdb-9999.ebuild b/sys-devel/gdb/gdb-9999.ebuild
index aec14c4ad5c8..907b6852abda 100644
--- a/sys-devel/gdb/gdb-9999.ebuild
+++ b/sys-devel/gdb/gdb-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.25 2014/03/14 05:52:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-9999.ebuild,v 1.26 2014/03/18 01:04:59 vapier Exp $
EAPI="4"
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -54,6 +54,7 @@ if [[ ${PV} != 9999* ]] ; then
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
IUSE="+client expat lzma multitarget nls +python +server test vanilla zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="!dev-util/gdbserver
>=sys-libs/ncurses-5.2-r2
@@ -70,6 +71,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${PN}-${MY_PV}
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
src_prepare() {
[[ -n ${RPM} ]] && rpm_spec_epatch "${WORKDIR}"/gdb.spec
use vanilla || [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/patch