summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-03-05 16:25:26 +0000
committerFabian Groffen <grobian@gentoo.org>2010-03-05 16:25:26 +0000
commit1d445c763ed6501b34ce430709269666f41cc352 (patch)
tree6a0ae7437f5ae8c04ab0b39cbfcce7e29ef00cae /sys-devel/gdb-apple/gdb-apple-966.ebuild
parentMove package from dev-util to dev-vcs, bug 56967. (diff)
downloadgentoo-2-1d445c763ed6501b34ce430709269666f41cc352.tar.gz
gentoo-2-1d445c763ed6501b34ce430709269666f41cc352.tar.bz2
gentoo-2-1d445c763ed6501b34ce430709269666f41cc352.zip
Convert to EAPI=3
(Portage version: 2.2.00.15738-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel/gdb-apple/gdb-apple-966.ebuild')
-rw-r--r--sys-devel/gdb-apple/gdb-apple-966.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-devel/gdb-apple/gdb-apple-966.ebuild b/sys-devel/gdb-apple/gdb-apple-966.ebuild
index 043a83f7a3bd..766fa0e086bd 100644
--- a/sys-devel/gdb-apple/gdb-apple-966.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-966.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.3 2009/11/27 08:40:03 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.4 2010/03/05 16:25:26 grobian Exp $
+
+EAPI="3"
inherit eutils flag-o-matic
@@ -22,10 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/gdb-${PV}/src
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
epatch "${FILESDIR}"/${PN}-962-darwin8.patch
@@ -36,18 +35,15 @@ src_unpack() {
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
-src_compile() {
+src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
- emake || die
}
src_install() {
- local ED=${ED-${D}}
-
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -R "${D}"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die