summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-10-13 01:25:57 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-10-13 01:25:57 +0000
commitee65e22faead74929aff8366064c9b3f1982c59a (patch)
treeba276c34cb0ba1d9becd4d729e1b92277a138bc6 /sys-devel/gcc
parentfilter cflags (diff)
downloadgentoo-2-ee65e22faead74929aff8366064c9b3f1982c59a.tar.gz
gentoo-2-ee65e22faead74929aff8366064c9b3f1982c59a.tar.bz2
gentoo-2-ee65e22faead74929aff8366064c9b3f1982c59a.zip
filter cflags
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/gcc-3.2-r1.ebuild31
1 files changed, 25 insertions, 6 deletions
diff --git a/sys-devel/gcc/gcc-3.2-r1.ebuild b/sys-devel/gcc/gcc-3.2-r1.ebuild
index 27471c838bc7..9281e818b6e8 100644
--- a/sys-devel/gcc/gcc-3.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2-r1.ebuild,v 1.5 2002/10/05 05:39:26 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2-r1.ebuild,v 1.6 2002/10/13 01:25:57 azarah Exp $
IUSE="static nls bootstrap java build"
@@ -9,11 +9,30 @@ IUSE="static nls bootstrap java build"
inherit flag-o-matic libtool
-# Compile problems with these ...
-filter-flags "-fno-exceptions"
-
-# cf bug #6641
-filter-flags "-fomit-frame-pointer"
+# Compile problems with these (bug #6641 among others)...
+filter-flags "-fno-exceptions -fomit-frame-pointer"
+
+# Recently there has been a lot of stability problem in Gentoo-land. Many
+# things can be the cause to this, but I believe that it is due to gcc3
+# still having issues with optimizations, or with it not filtering bad
+# combinations (protecting the user maybe from himeself) yet.
+#
+# This can clearly be seen in large builds like glibc, where too aggressive
+# CFLAGS cause the test to fail miserbly.
+#
+# Quote from Nick Jones <carpaski@gentoo.org>, who in my opinion
+# knows what he is talking about:
+#
+# People really shouldn't force code-specific options on... It's a
+# bad idea. The -march options aren't just to look pretty. They enable
+# options that are sensible (and include sse,mmx,3dnow when apropriate).
+#
+# The next command strips CFLAGS and CXXFLAGS from nearly all flags. If
+# you do not like it, comment it, but do not bugreport if you run into
+# problems.
+#
+# <azarah@gentoo.org> (13 Oct 2002)
+strip-flags
LOC="/usr"
MY_PV="`echo ${PV/_pre} | cut -d. -f1,2`"