summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-05-04 22:42:30 +0000
committerNed Ludd <solar@gentoo.org>2004-05-04 22:42:30 +0000
commitc472ba26b8ff72ae460f5270c2fa0a9e6ab6a4ff (patch)
tree8c0f57fe3853da6971e6e7fd290720d70047d573 /sys-devel/gcc
parentStable on alpha. (Manifest recommit) (diff)
downloadgentoo-2-c472ba26b8ff72ae460f5270c2fa0a9e6ab6a4ff.tar.gz
gentoo-2-c472ba26b8ff72ae460f5270c2fa0a9e6ab6a4ff.tar.bz2
gentoo-2-c472ba26b8ff72ae460f5270c2fa0a9e6ab6a4ff.zip
added gcc-uclibc-3.3-loop.patch
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog5
-rw-r--r--sys-devel/gcc/Manifest1
-rw-r--r--sys-devel/gcc/files/3.3.3/gcc-uclibc-3.3-loop.patch10
3 files changed, 15 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 82687cb7bd3b..f490e3c97c75 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.235 2004/05/04 17:26:25 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.236 2004/05/04 22:42:30 solar Exp $
+
+ 04 May 2004; <solar@gentoo.org> files/3.3.3/gcc-uclibc-3.3-loop.patch:
+ added gcc-uclibc-3.3-loop.patch
04 May 2004; <solar@gentoo.org> gcc-3.3.3-r4.ebuild:
fixed typo's and limit USE hardened piessp by default to x86 only for now
diff --git a/sys-devel/gcc/Manifest b/sys-devel/gcc/Manifest
index 9d2184b9ebf3..96bac2911202 100644
--- a/sys-devel/gcc/Manifest
+++ b/sys-devel/gcc/Manifest
@@ -144,6 +144,7 @@ MD5 43c60f04779324d74d3aac52224bed95 files/3.3.3/gcc333_pre20040426-gentoo-brand
MD5 9ba0bd0b103cf9535927ad7c482fe780 files/3.3.3/gcc333-debian-arm-getoff.patch 3501
MD5 25eda9981106a55c413d1df3d3a87db5 files/3.3.3/gcc333-debian-arm-ldm.patch 3383
MD5 ff6d7b5082c5e39fab8a5d8932c1a8b7 files/3.3.3/gcc-3.3.3-uclibc-add-ssp.patch 461
+MD5 308a0e53f03e9cb74b3d12c2633cbee2 files/3.3.3/gcc-uclibc-3.3-loop.patch 433
MD5 d9ae122db2768f8e504dfef256d4991f files/3.3.2/gcc332-gentoo-branding.patch 874
MD5 9e7ed6184a1cdcb69db29f1de26c2d18 files/3.3.2/gcc332-altivec-fix.patch 1607
MD5 c89b605fe512439cf492c1c378226c7c files/3.4.0/gcc-3.4.0-fno-for-scope.patch 1604
diff --git a/sys-devel/gcc/files/3.3.3/gcc-uclibc-3.3-loop.patch b/sys-devel/gcc/files/3.3.3/gcc-uclibc-3.3-loop.patch
new file mode 100644
index 000000000000..8fab7556f1a2
--- /dev/null
+++ b/sys-devel/gcc/files/3.3.3/gcc-uclibc-3.3-loop.patch
@@ -0,0 +1,10 @@
+--- gcc/gcc/gcc/loop.c 14 Feb 2004 14:46:03 -0000 1.488.2.3
++++ gcc/gcc/gcc/loop.c 28 Apr 2004 22:02:53 -0000
+@@ -929,6 +929,7 @@
+ || (! (GET_CODE (SET_SRC (set)) == REG
+ && (REGNO (SET_SRC (set))
+ < FIRST_PSEUDO_REGISTER))))
++ && regno >= FIRST_PSEUDO_REGISTER
+ /* This test is not redundant; SET_SRC (set) might be
+ a call-clobbered register and the life of REGNO
+ might span a call. */