summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-11-15 22:19:01 +0000
committerMike Frysinger <vapier@gentoo.org>2006-11-15 22:19:01 +0000
commitc0df801e69b38b7aefa68f70d4863f1dd9d7a76c (patch)
tree613b487b82b735e3c473b979387dabd61630faf6 /sys-devel/gcc
parentmove gcc2-flags() to the gcc2 ebuild (diff)
downloadgentoo-2-c0df801e69b38b7aefa68f70d4863f1dd9d7a76c.tar.gz
gentoo-2-c0df801e69b38b7aefa68f70d4863f1dd9d7a76c.tar.bz2
gentoo-2-c0df801e69b38b7aefa68f70d4863f1dd9d7a76c.zip
move gcc2-flags() out of flag-o-matic.eclass to here
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/gcc-2.95.3-r9.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/sys-devel/gcc/gcc-2.95.3-r9.ebuild b/sys-devel/gcc/gcc-2.95.3-r9.ebuild
index 1bb580170d6d..675d7a3edfca 100644
--- a/sys-devel/gcc/gcc-2.95.3-r9.ebuild
+++ b/sys-devel/gcc/gcc-2.95.3-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r9.ebuild,v 1.4 2006/04/13 05:54:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-2.95.3-r9.ebuild,v 1.5 2006/11/15 22:19:01 vapier Exp $
inherit eutils flag-o-matic toolchain-funcs versionator fixheadtails gnuconfig
@@ -18,7 +18,20 @@ do_filter_flags() {
# Are we trying to compile with gcc3 ? CFLAGS and CXXFLAGS needs to be
# valid for gcc-2.95.3 ...
- gcc2-flags
+ if [[ $(tc-arch) == "x86" || $(tc-arch) == "amd64" ]] ; then
+ CFLAGS=${CFLAGS//-mtune=/-mcpu=}
+ CXXFLAGS=${CXXFLAGS//-mtune=/-mcpu=}
+ fi
+
+ replace-cpu-flags k6-{2,3} k6
+ replace-cpu-flags athlon{,-{tbird,4,xp,mp}} i686
+
+ replace-cpu-flags pentium-mmx i586
+ replace-cpu-flags pentium{2,3,4} i686
+
+ replace-cpu-flags ev6{7,8} ev6
+
+ export CFLAGS CXXFLAGS
}
export CTARGET=${CTARGET:-${CHOST}}