summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2009-07-23 01:57:28 +0000
committerMark Loeser <halcy0n@gentoo.org>2009-07-23 01:57:28 +0000
commit861a80e3586fe07ae5aded959cbd26fc67bfcb33 (patch)
tree9f95dbfcac1c0991ccda29b06788369b0b4d2519 /sys-devel/gcc
parentamd64 stable, bug 277270 (diff)
downloadgentoo-2-861a80e3586fe07ae5aded959cbd26fc67bfcb33.tar.gz
gentoo-2-861a80e3586fe07ae5aded959cbd26fc67bfcb33.tar.bz2
gentoo-2-861a80e3586fe07ae5aded959cbd26fc67bfcb33.zip
Version bump, and dropped archs I'm unsure if they work or not
(Portage version: 2.2_rc33-r1/cvs/Linux i686)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-4.4.1.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 3c55357e7cd6..5c25a7b1ad63 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.713 2009/07/20 18:45:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.714 2009/07/23 01:57:28 halcy0n Exp $
+
+*gcc-4.4.1 (23 Jul 2009)
+
+ 23 Jul 2009; Mark Loeser <halcy0n@gentoo.org> +gcc-4.4.1.ebuild:
+ Version bump, and dropped archs I'm unsure if they work or not
20 Jul 2009; Jeroen Roovers <jer@gentoo.org> gcc-4.4.0-r1.ebuild:
Mark gcc-4.4* -hppa (bug #272645 and some currently undocumented
diff --git a/sys-devel/gcc/gcc-4.4.1.ebuild b/sys-devel/gcc/gcc-4.4.1.ebuild
new file mode 100644
index 000000000000..32e814f6cf42
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.4.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.1.ebuild,v 1.1 2009/07/23 01:57:28 halcy0n Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# Hardened gcc 4 stuff
+#PIE_VER="10.1.5"
+#SPECS_VER="0.9.4"
+
+# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
+#PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
+#PIE_UCLIBC_STABLE="x86 arm"
+#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
+#SSP_UCLIBC_STABLE=""
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-3 LGPL-2.1 libgcc libstdc++ gcc-runtime-library-exception-3.1"
+KEYWORDS="~amd64 -hppa ~ppc64 ~x86 -x86-fbsd"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.3
+ graphite? (
+ >=dev-libs/ppl-0.10
+ >=dev-libs/cloog-ppl-0.15
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ app-arch/zip
+ app-arch/unzip
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( sys-devel/autogen dev-util/dejagnu )
+ >=sys-apps/texinfo-4.2-r4
+ >=sys-devel/bison-1.875
+ amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
+}