summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-11-09 19:22:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-11-09 19:22:57 +0000
commit6e3dac1ce88e503afc306778e1ac760af6aa8938 (patch)
treed5539c5b6a1426c8e41ed791588e713366a769cf /sys-devel/gcc/gcc-4.6.2.ebuild
parentInitial import. Thanks to James Le Cuirot <chewi@aura-online.co.uk> for the i... (diff)
downloadgentoo-2-6e3dac1ce88e503afc306778e1ac760af6aa8938.tar.gz
gentoo-2-6e3dac1ce88e503afc306778e1ac760af6aa8938.tar.bz2
gentoo-2-6e3dac1ce88e503afc306778e1ac760af6aa8938.zip
Drop most dependencies now that toolchain.eclass takes care of them. Also drop the ncurses dep as that seems to be purely a workaround for an ancient issue #4411 which we have addressed in different ways.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gcc/gcc-4.6.2.ebuild')
-rw-r--r--sys-devel/gcc/gcc-4.6.2.ebuild41
1 files changed, 4 insertions, 37 deletions
diff --git a/sys-devel/gcc/gcc-4.6.2.ebuild b/sys-devel/gcc/gcc-4.6.2.ebuild
index 7d1fc6f0d6e5..980ed5cbdcc3 100644
--- a/sys-devel/gcc/gcc-4.6.2.ebuild
+++ b/sys-devel/gcc/gcc-4.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.1 2011/10/30 19:40:28 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.6.2.ebuild,v 1.2 2011/11/09 19:22:57 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -23,46 +23,13 @@ DESCRIPTION="The GNU Compiler Collection"
LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
KEYWORDS=""
-IUSE=""
-RDEPEND=">=sys-libs/zlib-1.1.4
- virtual/libiconv
- >=dev-libs/gmp-4.3.2
- >=dev-libs/mpfr-2.4.2
- >=dev-libs/mpc-0.8.1
- graphite? (
- >=dev-libs/cloog-ppl-0.15.10
- >=dev-libs/ppl-0.11
- )
- !build? (
- gcj? (
- gtk? (
- x11-libs/libXt
- x11-libs/libX11
- x11-libs/libXtst
- x11-proto/xproto
- x11-proto/xextproto
- =x11-libs/gtk+-2*
- x11-libs/pango
- )
- >=media-libs/libart_lgpl-2.1
- app-arch/zip
- app-arch/unzip
- )
- nls? ( sys-devel/gettext )
- )"
+RDEPEND=""
DEPEND="${RDEPEND}
- test? (
- >=dev-util/dejagnu-1.4.4
- >=sys-devel/autogen-5.5.4
- )
- >=sys-apps/texinfo-4.8
- >=sys-devel/bison-1.875
- >=sys-devel/flex-2.5.4
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
>=${CATEGORY}/binutils-2.18"
-PDEPEND=">=sys-devel/gcc-config-1.4
- go? ( >=sys-devel/gcc-config-1.5 )"
+PDEPEND="go? ( >=sys-devel/gcc-config-1.5 )"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"