summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-10 18:36:58 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-10 18:36:58 +0000
commit5c460d12233ff5fb51fd9ce88d9c817db0f3df21 (patch)
treeccda8d08dfa3bd6b0e101d808b6f5b69f16fca0d /sys-devel/gcc-config
parentRemoved ncurses masks (diff)
downloadgentoo-2-5c460d12233ff5fb51fd9ce88d9c817db0f3df21.tar.gz
gentoo-2-5c460d12233ff5fb51fd9ce88d9c817db0f3df21.tar.bz2
gentoo-2-5c460d12233ff5fb51fd9ce88d9c817db0f3df21.zip
cleanup
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.00
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.10
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.098
-rw-r--r--sys-devel/gcc-config/files/gcc-config-1.1213
-rw-r--r--sys-devel/gcc-config/gcc-config-1.0.ebuild20
-rw-r--r--sys-devel/gcc-config/gcc-config-1.1.ebuild20
6 files changed, 0 insertions, 351 deletions
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.0 b/sys-devel/gcc-config/files/digest-gcc-config-1.0
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.0
+++ /dev/null
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.1 b/sys-devel/gcc-config/files/digest-gcc-config-1.1
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.1
+++ /dev/null
diff --git a/sys-devel/gcc-config/files/gcc-config-1.0 b/sys-devel/gcc-config/files/gcc-config-1.0
deleted file mode 100644
index a11b0907a795..000000000000
--- a/sys-devel/gcc-config/files/gcc-config-1.0
+++ /dev/null
@@ -1,98 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.0,v 1.1 2002/10/27 22:38:11 azarah Exp $
-
-
-source /etc/init.d/functions.sh || {
- echo "$0: Could not source /etc/init.d/functions.sh!"
- exit 1
-}
-
-if [ "$(id -u)" -ne 0 ]
-then
- eerror "$0: Must be root."
- exit 1
-fi
-
-usage() {
-cat << "FOO"
-usage: gcc-config <CHOST>-<gcc version>
-
-FOO
- exit 1
-}
-
-if [ "$#" -ne 1 ] && [ "$#" -eq 2 -a "$1" != "--use-old" ]
-then
- usage
-fi
-
-GCC_COMP=""
-
-# Only use specified compiler if one is not already selected.
-if [ "$1" = "--use-old" ]
-then
- shift
-
- if [ -f /etc/env.d/gcc/config ]
- then
- source /etc/env.d/gcc/config
- if [ -n "${CURRENT}" ]
- then
- GCC_COMP="${CURRENT}"
- fi
- fi
-
- if [ -z "${GCC_COMP}" ]
- then
- GCC_COMP="$1"
- fi
-else
- GCC_COMP="$1"
-fi
-if [ ! -d /usr/lib/gcc-lib/${GCC_COMP%-*}/${GCC_COMP##*-} -o \
- ! -f /etc/env.d/gcc/${GCC_COMP} ]
-then
- usage
-else
- ebegin "Switching to ${GCC_COMP} compiler"
-
- # Sourcing /etc/env.d/gcc/${GCC_COMP} is going to mess up
- # PATH among things...
- CP="$(which cp)"
- RM="$(which rm)"
- MV="$(which mv)"
- LN="$(which ln)"
- ENV_UPDATE="$(which env-update)"
-
- source /etc/env.d/gcc/${GCC_COMP}
-
- ${CP} -f /etc/env.d/gcc/${GCC_COMP} /etc/env.d/05gcc
-
- if [ -d /usr/include/${STDCXX_INCDIR} -a ! -L /usr/include/${STDCXX_INCDIR} ]
- then
- ${MV} /usr/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}.orig
- elif [ -L /usr/include/${STDCXX_INCDIR} ]
- then
- ${RM} -f /usr/include/${STDCXX_INCDIR}
- fi
- ${LN} -snf ..${LDPATH/\/usr}/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}
-
- [ -L /lib/cpp -o -f /lib/cpp ] && ${RM} -f /lib/cpp
- ${LN} -snf ..${PATH}/cpp /lib/cpp
- [ -L /usr/bin/cc -o -f /usr/bin/cc ] && ${RM} -f /usr/bin/cc
- ${LN} -snf ../..${PATH}/gcc /usr/bin/cc
-
- echo "CURRENT=${GCC_COMP}" > /etc/env.d/gcc/config
-
- source /etc/profile
-
- ${ENV_UPDATE} &> /dev/null
-
- eend 0
-fi
-
-
-# vim:ts=4
diff --git a/sys-devel/gcc-config/files/gcc-config-1.1 b/sys-devel/gcc-config/files/gcc-config-1.1
deleted file mode 100644
index 4eb74c6dc8d3..000000000000
--- a/sys-devel/gcc-config/files/gcc-config-1.1
+++ /dev/null
@@ -1,213 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author: Martin Schlemmer <azarah@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.1,v 1.1 2002/11/10 11:58:19 azarah Exp $
-
-
-source /etc/init.d/functions.sh || {
- echo "$0: Could not source /etc/init.d/functions.sh!"
- exit 1
-}
-
-if [ "$(id -u)" -ne 0 ]
-then
- eerror "$0: Must be root."
- exit 1
-fi
-
-usage() {
-cat << "USAGE_END"
-Usage: gcc-config [Option] <CHOST>-<gcc version>
-Options:
- [--use-old]
- [--get-current-profile]
- [--get-bin-path]
- [--get-lib-path]
- [--get-stdcxx-incdir]
-
-USAGE_END
-
- exit 1
-}
-
-if [ "$#" -lt 1 ]
-then
- usage
-fi
-
-find_path() {
- [ -z "$1" ] && return 0
-
- for x in /bin /sbin /usr/bin /usr/sbin
- do
- if [ -x ${x}/$1 -a -r ${x}/$1 ]
- then
- echo "${x}/$1"
- break
- fi
- done
-}
-
-GCC_COMP=""
-
-switch_profile() {
- ebegin "Switching to ${GCC_COMP} compiler"
-
- # Sourcing /etc/env.d/gcc/${GCC_COMP} is going to mess up
- # PATH among things...
- CP="$(find_path cp)"
- RM="$(find_path rm)"
- MV="$(find_path mv)"
- LN="$(find_path ln)"
- GREP="$(find_path grep)"
- ENV_UPDATE="$(find_path env-update)"
-
- source /etc/env.d/gcc/${GCC_COMP}
-
- ${GREP} -v 'STDCXX_INCDIR' /etc/env.d/gcc/${GCC_COMP} > /etc/env.d/05gcc
-
- if [ -d /usr/include/${STDCXX_INCDIR} -a ! -L /usr/include/${STDCXX_INCDIR} ]
- then
- ${MV} /usr/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}.orig
- elif [ -L /usr/include/${STDCXX_INCDIR} ]
- then
- ${RM} -f /usr/include/${STDCXX_INCDIR}
- fi
- ${LN} -snf ..${LDPATH/\/usr}/include/${STDCXX_INCDIR} /usr/include/${STDCXX_INCDIR}
-
- [ -L /lib/cpp -o -f /lib/cpp ] && ${RM} -f /lib/cpp
- ${LN} -snf ..${PATH}/cpp /lib/cpp
- [ -L /usr/bin/cc -o -f /usr/bin/cc ] && ${RM} -f /usr/bin/cc
- ${LN} -snf ../..${PATH}/gcc /usr/bin/cc
-
- echo "CURRENT=${GCC_COMP}" > /etc/env.d/gcc/config
-
- source /etc/profile
-
- ${ENV_UPDATE} &> /dev/null
-
- eend 0
-
- return 0
-}
-
-get_current_profile() {
- if [ ! -f /etc/env.d/gcc/config ]
- then
- eerror "$0: No gcc profile is active!"
- return 1
- fi
-
- source /etc/env.d/gcc/config
-
- if [ -z "${CURRENT}" ]
- then
- eerror "$0: No gcc profile is active!"
- return 1
- fi
-
- echo "${CURRENT}"
-
- return 0
-}
-
-get_bin_path() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${PATH}"
-
- return 0
-}
-
-get_lib_path() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${LDPATH}"
-
- return 0
-}
-
-get_stdcxx_incdir() {
- source /etc/env.d/gcc/${GCC_COMP}
-
- echo "${LDPATH}/include/${STDCXX_INCDIR}"
-
- return 0
-}
-
-NEED_ACTION="yes"
-DOIT="switch_profile"
-
-for x in $*
-do
- case ${x} in
- # Only use specified compiler if one is not already selected.
- --use-old)
- if get_current_profile &> /dev/null
- then
- GCC_COMP="$(get_current_profile)"
- fi
- ;;
- --get-current-profile)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_current_profile"
- fi
- ;;
- --get-bin-path)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_bin_path"
- fi
- ;;
- --get-lib-path)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_lib_path"
- fi
- ;;
- --get-stdcxx-incdir)
- if [ "${NEED_ACTION}" = "yes" ]
- then
- NEED_ACTION="no"
- DOIT="get_stdcxx_incdir"
- fi
- ;;
- *)
- if [ -z "${GCC_COMP}" ]
- then
- GCC_COMP="${x}"
- fi
- ;;
- esac
-done
-
-if [ "${DOIT}" = "switch_profile" -a -z "${GCC_COMP}" ]
-then
- usage
-fi
-
-if [ -z "${GCC_COMP}" ]
-then
- if get_current_profile &> /dev/null
- then
- GCC_COMP="$(get_current_profile)"
- else
- usage
- fi
-fi
-
-if [ ! -d /usr/lib/gcc-lib/${GCC_COMP%-*}/${GCC_COMP##*-} -o \
- ! -f /etc/env.d/gcc/${GCC_COMP} ]
-then
- usage
-fi
-
-eval ${DOIT}
-
-
-# vim:ts=4
diff --git a/sys-devel/gcc-config/gcc-config-1.0.ebuild b/sys-devel/gcc-config/gcc-config-1.0.ebuild
deleted file mode 100644
index 06f9852120e0..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.0.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.0.ebuild,v 1.1 2002/10/27 22:38:11 azarah Exp $
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Utility to change the gcc compiler being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-KEYWORDS="x86 ppc sparc sparc64 alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-
-
-src_install() {
- newsbin ${FILESDIR}/${PN}-${PV} ${PN}
-}
-
diff --git a/sys-devel/gcc-config/gcc-config-1.1.ebuild b/sys-devel/gcc-config/gcc-config-1.1.ebuild
deleted file mode 100644
index 6a65c1c1fba4..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.1.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.1.ebuild,v 1.1 2002/11/10 11:58:19 azarah Exp $
-
-S="${WORKDIR}/${P}"
-DESCRIPTION="Utility to change the gcc compiler being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-KEYWORDS="x86 ppc sparc sparc64 alpha"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-
-
-src_install() {
- newsbin ${FILESDIR}/${PN}-${PV} ${PN}
-}
-