summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-03 18:57:20 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-03 18:57:20 +0000
commit3dfe7921cc53c74f33f14b34c4a6dbe73679f6c0 (patch)
tree13a547881c6d8200f62f63518fe2d244e07a5703 /sys-devel/gcc-config
parentAdd HDA support for the 2.6.17.x kernels (#138785). (diff)
downloadgentoo-2-3dfe7921cc53c74f33f14b34c4a6dbe73679f6c0.tar.gz
gentoo-2-3dfe7921cc53c74f33f14b34c4a6dbe73679f6c0.tar.bz2
gentoo-2-3dfe7921cc53c74f33f14b34c4a6dbe73679f6c0.zip
old
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r21
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.13-r2.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r2 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r2
deleted file mode 100644
index 8b137891791f..000000000000
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.13-r2
+++ /dev/null
@@ -1 +0,0 @@
-
diff --git a/sys-devel/gcc-config/gcc-config-1.3.13-r2.ebuild b/sys-devel/gcc-config/gcc-config-1.3.13-r2.ebuild
deleted file mode 100644
index e7169eb503c2..000000000000
--- a/sys-devel/gcc-config/gcc-config-1.3.13-r2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.13-r2.ebuild,v 1.1 2006/04/25 00:20:17 vapier Exp $
-
-inherit toolchain-funcs multilib
-
-# Version of .c wrapper to use
-W_VER="1.4.7"
-
-DESCRIPTION="Utility to change the gcc compiler being used"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-
-S=${WORKDIR}
-
-src_compile() {
- $(tc-getCC) -O2 -Wall -o wrapper \
- "${FILESDIR}"/wrapper-${W_VER}.c || die "compile wrapper"
-}
-
-src_install() {
- newbin "${FILESDIR}"/${PN}-${PV} ${PN} || die "install gcc-config"
- sed -i \
- -e "s:PORTAGE-VERSION:${PVR}:g" \
- -e "s:GENTOO_LIBDIR:$(get_libdir):g" \
- "${D}"/usr/bin/${PN}
-
- exeinto /usr/$(get_libdir)/misc
- newexe wrapper gcc-config || die "install wrapper"
-}
-
-pkg_postinst() {
- # Do we have a valid multi ver setup ?
- if gcc-config --get-current-profile &>/dev/null ; then
- # We not longer use the /usr/include/g++-v3 hacks, as
- # it is not needed ...
- [[ -L ${ROOT}/usr/include/g++ ]] && rm -f "${ROOT}"/usr/include/g++
- [[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
- [[ ${ROOT} = "/" ]] && gcc-config $(/usr/bin/gcc-config --get-current-profile)
- fi
-
- # Make sure old versions dont exist #79062
- rm -f "${ROOT}"/usr/sbin/gcc-config
-}