summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-10 04:03:13 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-10 04:03:13 +0000
commit1f16389e2d7d3c613973bc270defdebd2fbd8e82 (patch)
treed11343875aad94d79312c5588f0a04402098e1e0 /sys-devel/gcc-config
parentUse tarball instead of zipball, reducing DEPENDencies and (hopefully) making ... (diff)
downloadgentoo-2-1f16389e2d7d3c613973bc270defdebd2fbd8e82.tar.gz
gentoo-2-1f16389e2d7d3c613973bc270defdebd2fbd8e82.tar.bz2
gentoo-2-1f16389e2d7d3c613973bc270defdebd2fbd8e82.zip
Version bump.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/ChangeLog7
-rw-r--r--sys-devel/gcc-config/gcc-config-1.7.3.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 6ee456edf9c1..f82b57e34e28 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.217 2012/06/09 08:41:18 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.218 2012/06/10 04:03:13 vapier Exp $
+
+*gcc-config-1.7.3 (10 Jun 2012)
+
+ 10 Jun 2012; Mike Frysinger <vapier@gentoo.org> +gcc-config-1.7.3.ebuild:
+ Version bump.
09 Jun 2012; Markus Meier <maekke@gentoo.org> gcc-config-1.6.ebuild:
arm stable, bug #419399
diff --git a/sys-devel/gcc-config/gcc-config-1.7.3.ebuild b/sys-devel/gcc-config/gcc-config-1.7.3.ebuild
new file mode 100644
index 000000000000..964f0b53cd17
--- /dev/null
+++ b/sys-devel/gcc-config/gcc-config-1.7.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.7.3.ebuild,v 1.1 2012/06/10 04:03:13 vapier Exp $
+
+inherit unpacker toolchain-funcs multilib
+
+DESCRIPTION="utility to manage compilers"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gcc-config.git"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE=""
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PV="${PV}" \
+ SUBLIBDIR="$(get_libdir)" \
+ install || die
+}
+
+pkg_postinst() {
+ # Scrub eselect-compiler remains
+ rm -f "${ROOT}"/etc/env.d/05compiler &
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config &
+
+ # We not longer use the /usr/include/g++-v3 hacks, as
+ # it is not needed ...
+ rm -f "${ROOT}"/usr/include/g++{,-v3} &
+
+ # Do we have a valid multi ver setup ?
+ local x
+ for x in $(gcc-config -C -l 2>/dev/null | awk '$NF == "*" { print $2 }') ; do
+ gcc-config ${x}
+ done
+
+ wait
+}