summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-03-16 01:19:33 +0000
committerMike Frysinger <vapier@gentoo.org>2008-03-16 01:19:33 +0000
commit0acbe56c4eb892f180cb37c63524d8a0461d2984 (patch)
tree3f4c4d863a32e7ab7bf4e02a09fe773e4244ae5e /sys-devel/gcc-config
parentold (diff)
downloadgentoo-2-0acbe56c4eb892f180cb37c63524d8a0461d2984.tar.gz
gentoo-2-0acbe56c4eb892f180cb37c63524d8a0461d2984.tar.bz2
gentoo-2-0acbe56c4eb892f180cb37c63524d8a0461d2984.zip
do the checking/cleanup before executing gcc-config
Diffstat (limited to 'sys-devel/gcc-config')
-rw-r--r--sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild b/sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild
index 8b94f368de4c..5cdc99503004 100644
--- a/sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild,v 1.9 2008/01/10 08:50:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.4.0-r4.ebuild,v 1.10 2008/03/16 01:19:33 vapier Exp $
inherit flag-o-matic toolchain-funcs multilib
@@ -41,6 +41,14 @@ src_install() {
}
pkg_postinst() {
+ # Scrub eselect-compiler remains
+ if [[ -e ${ROOT}/etc/env.d/05compiler ]] ; then
+ rm -f "${ROOT}"/etc/env.d/05compiler
+ fi
+
+ # Make sure old versions dont exist #79062
+ rm -f "${ROOT}"/usr/sbin/gcc-config
+
# Do we have a valid multi ver setup ?
if gcc-config --get-current-profile &>/dev/null ; then
# We not longer use the /usr/include/g++-v3 hacks, as
@@ -49,12 +57,4 @@ pkg_postinst() {
[[ -L ${ROOT}/usr/include/g++-v3 ]] && rm -f "${ROOT}"/usr/include/g++-v3
gcc-config $(/usr/bin/gcc-config --get-current-profile)
fi
-
- # Scrub eselect-compiler remains
- if [[ -e ${ROOT}/etc/env.d/05compiler ]] ; then
- rm -f "${ROOT}"/etc/env.d/05compiler
- fi
-
- # Make sure old versions dont exist #79062
- rm -f "${ROOT}"/usr/sbin/gcc-config
}