summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2004-03-02 17:23:01 +0000
committerLisa M. Seelye <lisa@gentoo.org>2004-03-02 17:23:01 +0000
commitc62cdea5376745ffa80cccd8a855876f2ecd0891 (patch)
tree0e4526baae5f001d1a192ed9104479a439f9912d /sys-devel/distcc
parentAdded ~amd64 keyword. (Manifest recommit) (diff)
downloadgentoo-2-c62cdea5376745ffa80cccd8a855876f2ecd0891.tar.gz
gentoo-2-c62cdea5376745ffa80cccd8a855876f2ecd0891.tar.bz2
gentoo-2-c62cdea5376745ffa80cccd8a855876f2ecd0891.zip
Version bump and to remove DISTCC_DIR remnants from the daemon config files (see bug #42947). the config files are non critical, since an unuse envvar never hurt anyone i will not bump 2.12.1.
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog10
-rw-r--r--sys-devel/distcc/Manifest2
-rw-r--r--sys-devel/distcc/distcc-2.13.ebuild142
-rw-r--r--sys-devel/distcc/files/2.11.1p/conf6
-rw-r--r--sys-devel/distcc/files/2.11.1p/init3
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.131
6 files changed, 156 insertions, 8 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 6078037909ec..6427ae405646 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.96 2004/02/23 01:53:12 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.97 2004/03/02 17:23:01 lisa Exp $
+
+*distcc-2.13 (02 Mar 2004)
+
+ 02 Mar 2004; Lisa Seelye <lisa@gentoo.org> distcc-2.13.ebuild,
+ files/2.11.1p/conf, files/2.11.1p/init:
+ Version bump and to remove DISTCC_DIR remnants from the daemon config files
+ (see bug #42947). the config files are non critical, since an unuse envvar
+ never hurt anyone i will not bump 2.12.1.
22 Feb 2004; Lisa Seelye <lisa@gentoo.org> distcc-2.11.1.ebuild,
distcc-2.11.2-r1.ebuild, distcc-2.11.2.ebuild, distcc-2.8-r2.ebuild,
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 5dd6adf363a7..d0575d59a050 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,7 +1,9 @@
+MD5 4595c6b3d0dbb7bcb54916eef1020e1e distcc-2.13.ebuild 4452
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
MD5 840291cb64e469a7695bfd60cfa62623 ChangeLog 17523
MD5 5d5758311cdd7fd437eca2ce9fc078ca distcc-2.12.1.ebuild 4556
MD5 9ca407ce154707a1f27485523adf943c files/digest-distcc-2.12.1 66
+MD5 6ab90bfeafe27c0d276eb8b6f1257560 files/digest-distcc-2.13 64
MD5 0d27e364d11fcecd8fdd7eb1c4be732a files/2.11.1p/distcc-config 4839
MD5 606dd55609a04a0f21b9875259148332 files/2.11.1p/init 633
MD5 66c4af6f8dd87d270e5da50341ca6e14 files/2.11.1p/conf 658
diff --git a/sys-devel/distcc/distcc-2.13.ebuild b/sys-devel/distcc/distcc-2.13.ebuild
new file mode 100644
index 000000000000..216f531f216f
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.13.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.13.ebuild,v 1.1 2004/03/02 17:23:01 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+PATCHLEVEL="2.11.1p"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~ia64 ~amd64"
+
+IUSE="gnome gtk selinux ipv6"
+
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="!mips? ( gnome? ( >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ )
+ !mips? (
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && ! use mips && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && ! use mips && myconf="${myconf} --with-gnome"
+ use mips && use gtk || use gnome && ewarn "X support for Mips has been disabled."
+
+ #Above, mips is excluded due to version issues. 2004-02-20
+
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ myconf=" ${myconf} --enable-rfc2553 "
+ sleep 4s
+ fi
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version includes a new distcc-config. If you encounter problems with it,"
+ ewarn "please report them to our Bugzilla at bugs.gentoo.org"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+ sleep 3s
+}
diff --git a/sys-devel/distcc/files/2.11.1p/conf b/sys-devel/distcc/files/2.11.1p/conf
index d76a02999705..389100743704 100644
--- a/sys-devel/distcc/files/2.11.1p/conf
+++ b/sys-devel/distcc/files/2.11.1p/conf
@@ -1,5 +1,5 @@
# Copyright 2003 Gentoo Technologies, Inc
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.11.1p/conf,v 1.1 2003/10/18 20:18:15 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.11.1p/conf,v 1.2 2004/03/02 17:23:01 lisa Exp $
# distccd configuration file
# this is the distccd executable
@@ -15,7 +15,3 @@ DISTCCD_PIDFILE=/var/run/distccd/distccd.pid
# set this for niceness
# Default is 15
DISTCCD_NICE="15"
-
-# This is the path that distccd and the monitors will look
-# for the state files.
-DISTCC_DIR="/var/tmp/distccd"
diff --git a/sys-devel/distcc/files/2.11.1p/init b/sys-devel/distcc/files/2.11.1p/init
index 754fe9a3587d..9d57b2cae862 100644
--- a/sys-devel/distcc/files/2.11.1p/init
+++ b/sys-devel/distcc/files/2.11.1p/init
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.11.1p/init,v 1.1 2003/10/18 20:18:15 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/files/2.11.1p/init,v 1.2 2004/03/02 17:23:01 lisa Exp $
depend() {
need net
@@ -8,7 +8,6 @@ depend() {
start() {
rm -f ${DISTCCD_PIDFILE}
ebegin "Starting distccd"
- DISTCC_DIR="${DISTCC_DIR}" \
PATH="$(gcc-config --get-bin-path):${PATH}" \
/sbin/start-stop-daemon --start --quiet --startas ${DISTCCD_EXEC} \
--pidfile ${DISTCCD_PIDFILE} -- \
diff --git a/sys-devel/distcc/files/digest-distcc-2.13 b/sys-devel/distcc/files/digest-distcc-2.13
new file mode 100644
index 000000000000..9d066b5a3a22
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.13
@@ -0,0 +1 @@
+MD5 98cfd19a0329c9c3fdaee14098b2a9a5 distcc-2.13.tar.bz2 330805