summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2004-01-09 07:42:38 +0000
committerLisa M. Seelye <lisa@gentoo.org>2004-01-09 07:42:38 +0000
commit4b3dc231d6084fa2b62df81063f536a2d008a3b0 (patch)
tree2a6bdf79f2d177118b3c024500739403a3129ed2 /sys-devel/distcc
parentThis is a version bump with some pretty big fixes (setuid/gid ordering, gento... (diff)
downloadgentoo-2-4b3dc231d6084fa2b62df81063f536a2d008a3b0.tar.gz
gentoo-2-4b3dc231d6084fa2b62df81063f536a2d008a3b0.tar.bz2
gentoo-2-4b3dc231d6084fa2b62df81063f536a2d008a3b0.zip
This is a version bump with some pretty big fixes (setuid/gid ordering, gentoo bug #37592) and more.
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog8
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.12.1.ebuild136
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.12.11
4 files changed, 146 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 24db8a22724c..7e969b275c23 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.88 2004/01/05 23:23:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.89 2004/01/09 07:42:30 lisa Exp $
+
+*distcc-2.12.1 (09 Jan 2004)
+
+ 09 Jan 2004; Lisa Seelye <lisa@gentoo.org> distcc-2.12.1.ebuild:
+ This is a version bump with some pretty big fixes (setuid/gid ordering, gentoo
+ bug #37592) and more.
05 Jan 2004; Robin H. Johnson <robbat2@gentoo.org> files/2.10/distcc-config,
files/2.11/distcc-config, files/2.8/distcc-config, files/2.9/distcc-config:
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 998a96e62fe3..13703c45bc58 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -2,12 +2,12 @@ MD5 68dbe381db08b1286622ad4435b0adfc distcc-2.11.2.ebuild 4051
MD5 6e7845f012b8418afdae5ae3c80ee90f distcc-2.11.2-r1.ebuild 4054
MD5 7cd5bdea10955d968339056f67f524b0 distcc-2.8-r2.ebuild 3365
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
-MD5 1bcb19e4c022279ff54b45360963b38f ChangeLog 15945
+MD5 1b1fd855997f6f714e70d0118a9680a4 ChangeLog 16145
MD5 36d326efa9afa631d8d724d196162888 distcc-2.5-r1.ebuild 3214
MD5 2fb1d3745b45a323d791c7c6bd198528 distcc-2.9.ebuild 3454
MD5 04fc10eeeca52f5260403f36d3783130 distcc-2.11.1.ebuild 3930
MD5 4ab49c5f612a303db08b994ef0c37706 distcc-2.12.ebuild 4336
-MD5 4ab49c5f612a303db08b994ef0c37706 distcc-2.12.1.ebuild 4336
+MD5 64fa725331fe2a01ca5aead2de0e9e66 distcc-2.12.1.ebuild 4245
MD5 c09d755beeab4ae675a8352f4ee04c63 files/digest-distcc-2.11.2-r1 66
MD5 86e7b8c5c35c5e34e2adfe2c55369f7a files/digest-distcc-2.11.1 66
MD5 56fd1ac60c1b8402e1632da62f32a890 files/digest-distcc-2.8-r2 63
diff --git a/sys-devel/distcc/distcc-2.12.1.ebuild b/sys-devel/distcc/distcc-2.12.1.ebuild
new file mode 100644
index 000000000000..e47366686682
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.12.1.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.12.1.ebuild,v 1.1 2004/01/09 07:42:30 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+PATCHLEVEL="2.11.1p"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+
+IUSE="gnome gtk selinux ipv6"
+
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gnome? ( >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && myconf="${myconf} --with-gnome"
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ myconf=" ${myconf} --enable-rfc2553 "
+ sleep 2s
+ fi
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version is using a new distcc-config. If you encounter problems with it"
+ ewarn "Please report errors to bug 27432 on the bugs.gentoo.org site"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+ sleep 3s
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.12.1 b/sys-devel/distcc/files/digest-distcc-2.12.1
new file mode 100644
index 000000000000..e10ef67c7d44
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.12.1
@@ -0,0 +1 @@
+MD5 34c465416f261b980db46a9df6d66c75 distcc-2.12.1.tar.bz2 325428