summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-04-04 06:18:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-04-04 06:18:43 +0000
commite377fa7e6073d89d9c4d47ced3c0c4b9a0807c6a (patch)
tree6e4a58fdcf1ede984206b32a4c5e5474b90b259b /sys-devel/dev86
parentold (diff)
downloadgentoo-2-e377fa7e6073d89d9c4d47ced3c0c4b9a0807c6a.tar.gz
gentoo-2-e377fa7e6073d89d9c4d47ced3c0c4b9a0807c6a.tar.bz2
gentoo-2-e377fa7e6073d89d9c4d47ced3c0c4b9a0807c6a.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-devel/dev86')
-rw-r--r--sys-devel/dev86/ChangeLog7
-rw-r--r--sys-devel/dev86/dev86-0.16.20.ebuild77
2 files changed, 5 insertions, 79 deletions
diff --git a/sys-devel/dev86/ChangeLog b/sys-devel/dev86/ChangeLog
index eb2791f2b656..da5682443927 100644
--- a/sys-devel/dev86/ChangeLog
+++ b/sys-devel/dev86/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/dev86
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.30 2014/06/12 12:36:34 polynomial-c Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.31 2015/04/04 06:18:43 mr_bones_ Exp $
+
+ 04 Apr 2015; Michael Sterrett <mr_bones_@gentoo.org> -dev86-0.16.20.ebuild:
+ old
*dev86-0.16.21 (12 Jun 2014)
diff --git a/sys-devel/dev86/dev86-0.16.20.ebuild b/sys-devel/dev86/dev86-0.16.20.ebuild
deleted file mode 100644
index bb0c299b407b..000000000000
--- a/sys-devel/dev86/dev86-0.16.20.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/dev86-0.16.20.ebuild,v 1.2 2014/05/18 17:26:27 vapier Exp $
-
-EAPI="5"
-
-inherit eutils multilib
-
-DESCRIPTION="Bruce's C compiler - Simple C compiler to generate 8086 code"
-HOMEPAGE="http://v3.sk/~lkundrak/dev86/"
-SRC_URI="http://v3.sk/~lkundrak/dev86/archive/Dev86src-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-IUSE=""
-
-RDEPEND="sys-devel/bin86"
-DEPEND="${RDEPEND}
- dev-util/gperf"
-
-STRIP_MASK="/usr/*/bcc/lib*.a /usr/*/i386/libc.a"
-
-src_prepare() {
- # elksemu doesn't compile under amd64
- if use amd64; then
- einfo "Not compiling elksemu on amd64"
- sed -i \
- -e 's,alt-libs elksemu,alt-libs,' \
- -e 's,install-lib install-emu,install-lib,' \
- makefile.in || die
- fi
-
- epatch "${FILESDIR}"/dev86-pic.patch
- epatch "${FILESDIR}"/${PN}-0.16.19-fortify.patch
- sed -i \
- -e "s:-O2 -g:${CFLAGS}:" \
- -e '/INEXE=/s:-s::' \
- makefile.in || die
- sed -i \
- -e "s:/lib/:/$(get_libdir)/:" \
- bcc/bcc.c || die
- sed -i -e '/INSTALL_OPTS=/s:-s::' bin86/Makefile || die
- sed -i -e '/install -m 755 -s/s:-s::' dis88/Makefile || die
-}
-
-src_compile() {
- # Don't mess with CPPFLAGS as they tend to break compilation
- # (bug #343655).
- CPPFLAGS=""
-
- # First `make` is also a config, so set all the path vars here
- emake -j1 \
- DIST="${D}" \
- CC="$(tc-getCC)" \
- LIBDIR="/usr/$(get_libdir)/bcc" \
- INCLDIR="/usr/$(get_libdir)/bcc"
-
- export PATH=${S}/bin:${PATH}
- cd bin
- ln -s ncc bcc
- cd ..
- cd bootblocks
- ln -s ../bcc/version.h .
- emake DIST="${D}"
-}
-
-src_install() {
- emake -j1 install-all DIST="${D}"
- dobin bootblocks/makeboot
- # remove all the stuff supplied by bin86
- cd "${D}"
- rm usr/bin/{as,ld,nm,objdump,size}86 || die
- rm usr/man/man1/{as,ld}86.1 || die
- dodir /usr/share/man
- mv usr/man usr/share/
-}