summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-15 03:13:09 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-15 03:13:09 +0000
commit5d9560ef38aa1431297f434528a8928937ba28c3 (patch)
tree4afbc2166b5bca099f63e0594aec151d01709496 /sys-devel/crossdev
parentold (diff)
downloadgentoo-2-5d9560ef38aa1431297f434528a8928937ba28c3.tar.gz
gentoo-2-5d9560ef38aa1431297f434528a8928937ba28c3.tar.bz2
gentoo-2-5d9560ef38aa1431297f434528a8928937ba28c3.zip
Add support for C++ with avr targets; fixes by Ludek Stepan #99014 / #99020.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9.7.ebuild21
-rwxr-xr-xsys-devel/crossdev/files/crossdev7
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.70
4 files changed, 32 insertions, 4 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 6e6d6014281c..1fa9dacb87a5 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.19 2005/07/14 01:16:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.20 2005/07/15 03:13:09 vapier Exp $
+
+*crossdev-0.9.7 (15 Jul 2005)
+
+ 15 Jul 2005; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ +crossdev-0.9.7.ebuild:
+ Add support for C++ with avr targets; fixes by Ludek Stepan #99014 / #99020.
*crossdev-0.9.6-r1 (14 Jul 2005)
diff --git a/sys-devel/crossdev/crossdev-0.9.7.ebuild b/sys-devel/crossdev/crossdev-0.9.7.ebuild
new file mode 100644
index 000000000000..a9f7e4892d56
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.7.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.7.ebuild,v 1.1 2005/07/15 03:13:09 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
+IUSE=""
+
+RDEPEND="sys-apps/portage
+ app-shells/bash
+ sys-apps/coreutils"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index a59fa691a06c..5cf1652feeef 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.26 2005/07/14 01:16:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.27 2005/07/15 03:13:09 vapier Exp $
if [[ ${ROOT:-/} != "/" ]] ; then
echo "Sorry, but crossdev does not support ROOT."
@@ -85,9 +85,10 @@ parse_target() {
#####################
### other targets ###
avr*) TARCH=${HARCH}; CPOST="";
- KPKG="[none]"; STAGE="2";
+ KPKG="[none]"; STAGE="3";
LCAT="dev-embedded"; LPKG="avr-libc";
- GUSE="-fortran -gtk nocxx -gcj -objc";;
+ GVER="3.4.4"; BVER="2.16.1";
+ GUSE="-fortran -gtk -gcj -objc";;
ps2*) einfo "The ps2 target is really an alias for the ee/iop/dvp targets"
${CROSSDEV} -t ee || exit 1
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.7 b/sys-devel/crossdev/files/digest-crossdev-0.9.7
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.7