summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-10-18 17:46:20 +0000
committerMike Frysinger <vapier@gentoo.org>2011-10-18 17:46:20 +0000
commit21bf8e37ed543c0505f2f98c2aa08acc5b392690 (patch)
tree18e852cde483c5e446f2c7e5ed0b7ca100450dc5 /sys-devel/crossdev
parentVersion bump. (diff)
downloadgentoo-2-21bf8e37ed543c0505f2f98c2aa08acc5b392690.tar.gz
gentoo-2-21bf8e37ed543c0505f2f98c2aa08acc5b392690.tar.bz2
gentoo-2-21bf8e37ed543c0505f2f98c2aa08acc5b392690.zip
Version bump.
(Portage version: 2.2.0_alpha65/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog7
-rw-r--r--sys-devel/crossdev/crossdev-20111018.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 7f3c34b6ad65..32ee22fb8dda 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.83 2011/10/11 22:23:50 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.84 2011/10/18 17:46:20 vapier Exp $
+
+*crossdev-20111018 (18 Oct 2011)
+
+ 18 Oct 2011; Mike Frysinger <vapier@gentoo.org> +crossdev-20111018.ebuild:
+ Version bump.
*crossdev-20111011 (11 Oct 2011)
diff --git a/sys-devel/crossdev/crossdev-20111018.ebuild b/sys-devel/crossdev/crossdev-20111018.ebuild
new file mode 100644
index 000000000000..928ec9bee73d
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-20111018.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-20111018.ebuild,v 1.1 2011/10/18 17:46:20 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/crossdev.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash
+ !sys-devel/crossdev-wrappers"
+DEPEND="app-arch/xz-utils"
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+}