summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-02-21 13:49:06 +0000
committerFabian Groffen <grobian@gentoo.org>2012-02-21 13:49:06 +0000
commit4cc372d5a1660b6850fa3d1557cb0aa4b22bab8b (patch)
treec032e2223bebff4ecc171a296676a5730a566325 /sys-devel/clang
parentStable for amd64, wrt bug #404723 (diff)
downloadgentoo-2-4cc372d5a1660b6850fa3d1557cb0aa4b22bab8b.tar.gz
gentoo-2-4cc372d5a1660b6850fa3d1557cb0aa4b22bab8b.tar.bz2
gentoo-2-4cc372d5a1660b6850fa3d1557cb0aa4b22bab8b.zip
Add patch to fix version detection of Gentoo's binutils-apple, bug #395013 (forcing for clang-2.8 dep problems that aren't mine)
(Portage version: 2.2.01.20153-prefix/cvs/SunOS i386, RepoMan options: --force)
Diffstat (limited to 'sys-devel/clang')
-rw-r--r--sys-devel/clang/ChangeLog6
-rw-r--r--sys-devel/clang/clang-3.0-r3.ebuild4
-rw-r--r--sys-devel/clang/clang-9999.ebuild4
-rw-r--r--sys-devel/clang/files/clang-3.0-gentoo-binutils-apple.patch28
4 files changed, 39 insertions, 3 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 22a2878dde46..c7e510fa3549 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.54 2012/02/16 14:47:35 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.55 2012/02/21 13:49:06 grobian Exp $
+
+ 21 Feb 2012; Fabian Groffen <grobian@gentoo.org> clang-3.0-r3.ebuild,
+ +files/clang-3.0-gentoo-binutils-apple.patch, clang-9999.ebuild:
+ Add patch to fix version detection of Gentoo's binutils-apple, bug #395013
16 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> clang-9999.ebuild:
clang now autodetects C++ header paths, dropping the system-cxx-headers
diff --git a/sys-devel/clang/clang-3.0-r3.ebuild b/sys-devel/clang/clang-3.0-r3.ebuild
index d207cb0539ae..a7614f7e0225 100644
--- a/sys-devel/clang/clang-3.0-r3.ebuild
+++ b/sys-devel/clang/clang-3.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0-r3.ebuild,v 1.1 2012/02/16 11:35:09 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.0-r3.ebuild,v 1.2 2012/02/21 13:49:06 grobian Exp $
EAPI=3
@@ -48,6 +48,8 @@ src_prepare() {
sed -e "/LLVMgold.so/s#lib/#$(get_libdir)/llvm/#" \
-i tools/clang/lib/Driver/Tools.cpp \
|| die "gold plugin path sed failed"
+ # Properly detect Gentoo's binutils-apple version
+ epatch "${FILESDIR}"/${PN}-3.0-gentoo-binutils-apple.patch
# Specify python version
python_convert_shebangs 2 tools/clang/tools/scan-view/scan-view
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 5fe6b1faedd3..0078a9d3959e 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.24 2012/02/16 14:47:35 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.25 2012/02/21 13:49:06 grobian Exp $
EAPI=4
@@ -49,6 +49,8 @@ src_prepare() {
sed -e "/LLVMgold.so/s#lib/#$(get_libdir)/llvm/#" \
-i tools/clang/lib/Driver/Tools.cpp \
|| die "gold plugin path sed failed"
+ # Properly detect Gentoo's binutils-apple version
+ epatch "${FILESDIR}"/${PN}-3.0-gentoo-binutils-apple.patch
# Specify python version
python_convert_shebangs 2 tools/clang/tools/scan-view/scan-view
diff --git a/sys-devel/clang/files/clang-3.0-gentoo-binutils-apple.patch b/sys-devel/clang/files/clang-3.0-gentoo-binutils-apple.patch
new file mode 100644
index 000000000000..4164138ab79a
--- /dev/null
+++ b/sys-devel/clang/files/clang-3.0-gentoo-binutils-apple.patch
@@ -0,0 +1,28 @@
+http://llvm.org/bugs/show_bug.cgi?id=8339
+https://bugs.gentoo.org/show_bug.cgi?id=395013
+
+Tweak version detection bit to cope with Gentoo's slightly different
+output for ld -v.
+
+--- autoconf/m4/link_options.m4
++++ autoconf/m4/link_options.m4
+@@ -10,7 +10,7 @@
+
+ # Check for ld64.
+ if (echo "$version_string" | grep -q "ld64"); then
+- llvm_cv_link_version=$(echo "$version_string" | sed -e "s#.*ld64-\([^ ]*\)#\1#")
++ llvm_cv_link_version=$(echo "$version_string" | sed -e "s#.*ld64-\([^ ]*\)\( (.*)\)\?#\1#")
+ else
+ llvm_cv_link_version=$(echo "$version_string" | sed -e "s#[^0-9]*\([0-9.]*\).*#\1#")
+ fi
+--- configure
++++ configure
+@@ -7528,7 +7528,7 @@
+
+ # Check for ld64.
+ if (echo "$version_string" | grep -q "ld64"); then
+- llvm_cv_link_version=$(echo "$version_string" | sed -e "s#.*ld64-\([^ ]*\)#\1#")
++ llvm_cv_link_version=$(echo "$version_string" | sed -e "s#.*ld64-\([^ ]*\)\( (.*)\)\?#\1#")
+ else
+ llvm_cv_link_version=$(echo "$version_string" | sed -e "s#[^0-9]*\([0-9.]*\).*#\1#")
+ fi