summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-02-19 06:00:27 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-02-19 06:00:27 +0000
commit35853c7bb5dc3fa8dc90ef193a65cacba084a6b0 (patch)
tree33cdea8fc4507bca6ba09c33b0e4255a65ba5e1d /sys-devel/cctools-extras
parentMake this a meta-ebuild that RDEPENDS on the required PEAR packages, see bug ... (diff)
downloadgentoo-2-35853c7bb5dc3fa8dc90ef193a65cacba084a6b0.tar.gz
gentoo-2-35853c7bb5dc3fa8dc90ef193a65cacba084a6b0.tar.bz2
gentoo-2-35853c7bb5dc3fa8dc90ef193a65cacba084a6b0.zip
add IUSE=build. changed to use included seg_hack
(Portage version: 2.0.51.16)
Diffstat (limited to 'sys-devel/cctools-extras')
-rw-r--r--sys-devel/cctools-extras/cctools-extras-495.8.ebuild34
-rw-r--r--sys-devel/cctools-extras/cctools-extras-525.ebuild32
-rw-r--r--sys-devel/cctools-extras/files/digest-cctools-extras-495.81
3 files changed, 22 insertions, 45 deletions
diff --git a/sys-devel/cctools-extras/cctools-extras-495.8.ebuild b/sys-devel/cctools-extras/cctools-extras-495.8.ebuild
deleted file mode 100644
index 2479fc79a473..000000000000
--- a/sys-devel/cctools-extras/cctools-extras-495.8.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-495.8.ebuild,v 1.2 2004/11/07 23:13:37 kito Exp $
-
-DESCRIPTION="Extra cctools utils"
-HOMEPAGE="http://darwinsource.opendarwin.org/"
-SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/cctools-${PV}.tar.gz"
-
-LICENSE="APSL-2"
-
-SLOT="0"
-KEYWORDS="~ppc-macos"
-IUSE=""
-
-DEPEND=""
-
-src_compile() {
- cd ${WORKDIR}/cctools-${PV}
- rm -rf ar as cbtlibs dyld file gprof ld libdyld libmacho mkshlib otool
- make SUBDIRS="libstuff misc" || die "make failed"
-}
-
-src_install() {
- cd ${WORKDIR}/cctools-${PV}/misc
- newbin check_dylib.NEW check_dylib || die "check_dylib failed"
- newbin checksyms.NEW checksyms || die "checksyms failed"
- newbin dylib_pcsampler.NEW dylib_pcsampler || die "dylib_pcsampler failed"
- newbin indr.NEW indr || die "indr failed"
- newbin seg_addr_table.NEW seg_addr_table || die "seg_addr_table failed"
- newbin seg_hack.NEW seg_hack || die "seg_hack failed"
-
- cd ${WORKDIR}/cctools-${PV}/man
- doman {check_dylib.1,checksyms.1,indr.1,seg_addr_table.1}
-} \ No newline at end of file
diff --git a/sys-devel/cctools-extras/cctools-extras-525.ebuild b/sys-devel/cctools-extras/cctools-extras-525.ebuild
index e7f300111442..4dba8e116aa8 100644
--- a/sys-devel/cctools-extras/cctools-extras-525.ebuild
+++ b/sys-devel/cctools-extras/cctools-extras-525.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-525.ebuild,v 1.3 2004/11/18 18:42:01 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/cctools-extras/cctools-extras-525.ebuild,v 1.4 2005/02/19 06:00:27 kito Exp $
-DESCRIPTION="Extra cctools utils"
+S=${WORKDIR}/cctools-${PV}
+
+DESCRIPTION="Extra cctools"
HOMEPAGE="http://darwinsource.opendarwin.org/"
SRC_URI="http://darwinsource.opendarwin.org/tarballs/apsl/cctools-${PV}.tar.gz"
@@ -10,22 +12,30 @@ LICENSE="APSL-2"
SLOT="0"
KEYWORDS="~ppc-macos"
-IUSE=""
+IUSE="build"
DEPEND="sys-apps/bootstrap_cmds
+ sys-libs/libstreams
virtual/libc"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/ld
+ sed -i -e 's:seg_hack:${S}/misc/seg_hack.NEW:' Makefile
+}
+
src_compile() {
- cd ${WORKDIR}/cctools-${PV}
+ cd ${S}
rm -rf ar as cbtlibs dyld file gprof libdyld mkshlib otool
make SUBDIRS="libmacho libstuff misc" RC_OS=macos || die "make failed"
- cd ${WORKDIR}/cctools-${PV}/ld
+ cd ${S}/ld
make RC_OS=macos kld_build || die "static kld build failed"
}
src_install() {
- cd ${WORKDIR}/cctools-${PV}/misc
+ cd ${S}/misc
newbin check_dylib.NEW check_dylib || die "check_dylib failed"
newbin checksyms.NEW checksyms || die "checksyms failed"
newbin dylib_pcsampler.NEW dylib_pcsampler || die "dylib_pcsampler failed"
@@ -33,9 +43,11 @@ src_install() {
newbin seg_addr_table.NEW seg_addr_table || die "seg_addr_table failed"
newbin seg_hack.NEW seg_hack || die "seg_hack failed"
- cd ${WORKDIR}/cctools-${PV}/ld/static_kld
+ cd ${S}/ld/static_kld
dolib.a *.a
- cd ${WORKDIR}/cctools-${PV}/man
- doman {check_dylib.1,checksyms.1,indr.1,seg_addr_table.1}
+ if ! use build; then
+ cd ${S}/man
+ doman {check_dylib.1,checksyms.1,indr.1,seg_addr_table.1}
+ fi
} \ No newline at end of file
diff --git a/sys-devel/cctools-extras/files/digest-cctools-extras-495.8 b/sys-devel/cctools-extras/files/digest-cctools-extras-495.8
deleted file mode 100644
index a7e4386a249c..000000000000
--- a/sys-devel/cctools-extras/files/digest-cctools-extras-495.8
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e7aef5838734ff9650cc1b60df136e66 cctools-495.8.tar.gz 1859332