summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-10-23 19:28:50 +0000
committerTim Harder <radhermit@gentoo.org>2012-10-23 19:28:50 +0000
commitcaba1519a4223b9e3e7b269c3defe033ad302946 (patch)
tree365bf7289796a8ecc86263f56d5d94f4a12f9187 /sys-devel/bison
parentVersion bump (diff)
downloadgentoo-2-caba1519a4223b9e3e7b269c3defe033ad302946.tar.gz
gentoo-2-caba1519a4223b9e3e7b269c3defe033ad302946.tar.bz2
gentoo-2-caba1519a4223b9e3e7b269c3defe033ad302946.zip
Version bump.
(Portage version: 2.2.0_alpha141/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.6.4.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index e6798e37d753..67987483ec4c 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.117 2012/09/07 20:08:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.118 2012/10/23 19:28:50 radhermit Exp $
+
+*bison-2.6.4 (23 Oct 2012)
+
+ 23 Oct 2012; Tim Harder <radhermit@gentoo.org> +bison-2.6.4.ebuild:
+ Version bump.
07 Sep 2012; Mike Frysinger <vapier@gentoo.org>
+files/bison-2.4.3-no-gets.patch, bison-2.4.3.ebuild:
diff --git a/sys-devel/bison/bison-2.6.4.ebuild b/sys-devel/bison/bison-2.6.4.ebuild
new file mode 100644
index 000000000000..46fae86d06d8
--- /dev/null
+++ b/sys-devel/bison/bison-2.6.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.6.4.ebuild,v 1.1 2012/10/23 19:28:50 radhermit Exp $
+
+EAPI=5
+
+inherit flag-o-matic
+
+DESCRIPTION="A general-purpose (yacc-compatible) parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="nls static"
+
+RDEPEND=">=sys-devel/m4-1.4.16"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="AUTHORS ChangeLog-2012 NEWS README THANKS TODO" # ChangeLog-1998 PACKAGING README-alpha README-release
+
+src_configure() {
+ use static && append-ldflags -static
+
+ econf \
+ $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ # This one is installed by dev-util/yacc
+ mv "${ED}"/usr/bin/yacc{,.bison} || die
+ mv "${ED}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need liby.a
+ rm -r "${ED}"/usr/lib* || die
+
+ # Move to documentation directory and leave compressing for EAPI>=4
+ mv "${ED}"/usr/share/${PN}/README "${ED}"/usr/share/doc/${PF}/README.data
+}
+
+pkg_postinst() {
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ ! -e ${f} ]] ; then
+ ln -s yacc.bison "${f}"
+ fi
+}
+
+pkg_postrm() {
+ # clean up the dead symlink when we get unmerged #377469
+ local f="${EROOT}/usr/bin/yacc"
+ if [[ -L ${f} && ! -e ${f} ]] ; then
+ rm -f "${f}"
+ fi
+}