summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-11-14 07:54:36 +0000
committerMike Frysinger <vapier@gentoo.org>2008-11-14 07:54:36 +0000
commitb80308214d9f8273ef2b94ca23658da209cf2885 (patch)
treed4f701642fef626a1795047a3c16a0b6e36948aa /sys-devel/bison
parentVersion bump (diff)
downloadgentoo-2-b80308214d9f8273ef2b94ca23658da209cf2885.tar.gz
gentoo-2-b80308214d9f8273ef2b94ca23658da209cf2885.tar.bz2
gentoo-2-b80308214d9f8273ef2b94ca23658da209cf2885.zip
Document patch properly and make sure we dont regen doc files #246583 by Alex Guensche.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.4 x86_64)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog8
-rw-r--r--sys-devel/bison/bison-2.4-r1.ebuild8
-rw-r--r--sys-devel/bison/files/bison-2.4-compat.patch (renamed from sys-devel/bison/files/bison-2.4.0-compat.patch)189
3 files changed, 101 insertions, 104 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 36de35e0514b..c0719f5049f7 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.74 2008/11/12 18:47:09 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.75 2008/11/14 07:54:36 vapier Exp $
+
+ 14 Nov 2008; Mike Frysinger <vapier@gentoo.org>
+ -files/bison-2.4.0-compat.patch, +files/bison-2.4-compat.patch,
+ bison-2.4-r1.ebuild:
+ Document patch properly and make sure we dont regen doc files #246583 by
+ Alex Guensche.
*bison-2.4-r1 (12 Nov 2008)
diff --git a/sys-devel/bison/bison-2.4-r1.ebuild b/sys-devel/bison/bison-2.4-r1.ebuild
index 20117f14a971..1baab60c5052 100644
--- a/sys-devel/bison/bison-2.4-r1.ebuild
+++ b/sys-devel/bison/bison-2.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4-r1.ebuild,v 1.1 2008/11/12 18:47:10 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4-r1.ebuild,v 1.2 2008/11/14 07:54:36 vapier Exp $
inherit toolchain-funcs flag-o-matic
@@ -20,9 +20,9 @@ RDEPEND="sys-devel/m4"
src_unpack() {
unpack ${A}
cd "${S}"
-
- # fix compatibility with previous bison releases
- epatch "${FILESDIR}"/${PN}-2.4.0-compat.patch
+ epatch "${FILESDIR}"/${P}-compat.patch
+ # since we patch sources, update mtimes on docs so we dont regen
+ touch doc/bison.1 doc/bison.info doc/cross-options.texi
}
src_compile() {
diff --git a/sys-devel/bison/files/bison-2.4.0-compat.patch b/sys-devel/bison/files/bison-2.4-compat.patch
index 9074f5b79a7b..4a834f5b9a83 100644
--- a/sys-devel/bison/files/bison-2.4.0-compat.patch
+++ b/sys-devel/bison/files/bison-2.4-compat.patch
@@ -1,9 +1,33 @@
-diff -NrU5 bison/src/getargs.c bison-2.4.1_pre20081111/src/getargs.c
---- bison/src/getargs.c 2008-11-02 22:55:49.000000000 +0100
-+++ bison-2.4.1_pre20081111/src/getargs.c 2008-11-07 22:48:57.000000000 +0100
-@@ -68,13 +68,13 @@
- { "c++", "c++-skel.m4", ".cc", ".hh", true },
- { "java", "java-skel.m4", ".java", ".java", false },
+http://bugs.gentoo.org/246266
+
+From 5136519230209e4362e477c38d92f7d25203255f Mon Sep 17 00:00:00 2001
+From: Joel E. Denny <jdenny@ces.clemson.edu>
+Date: Fri, 7 Nov 2008 17:20:44 -0500
+Subject: [PATCH] Clean up %skeleton and %language priority implementation.
+
+* src/getargs.c (skeleton_prio): Use default_prio rather than 2, and
+remove static qualifier because others will soon need to see it.
+(language_prio): Likewise.
+(getargs): Use command_line_prio rather than 0.
+* src/getargs.h (command_line_prio, grammar_prio, default_prio): New
+enum fields.
+(skeleton_prio): Extern it.
+(language_prio): Extern it.
+* src/parse-gram.y: Use grammar_prio rather than 1.
+---
+ ChangeLog | 13 +++
+ src/getargs.c | 10 ++-
+ src/getargs.h | 3 +
+ src/parse-gram.c | 226 +++++++++++++++++++++++++++---------------------------
+ src/parse-gram.h | 8 +-
+ src/parse-gram.y | 4 +-
+ 6 files changed, 141 insertions(+), 123 deletions(-)
+
+diff --git a/src/getargs.c b/src/getargs.c
+index c36cabf..a8d1c54 100644
+--- a/src/getargs.c
++++ b/src/getargs.c
+@@ -72,9 +72,9 @@ static struct bison_language const valid_languages[] = {
{ "", "", "", "", false }
};
@@ -15,11 +39,7 @@ diff -NrU5 bison/src/getargs.c bison-2.4.1_pre20081111/src/getargs.c
struct bison_language const *language = &valid_languages[0];
const char *include = NULL;
- char *program_name;
-
-@@ -518,15 +518,15 @@
- case 'I':
- include = AS_FILE_NAME (optarg);
+@@ -540,11 +540,11 @@ getargs (int argc, char *argv[])
break;
case 'L':
@@ -33,25 +53,11 @@ diff -NrU5 bison/src/getargs.c bison-2.4.1_pre20081111/src/getargs.c
break;
case 'T':
- FLAGS_ARGMATCH (trace, optarg);
- break;
-diff -NrU5 bison/src/getargs.h bison-2.4.1_pre20081111/src/getargs.h
---- bison/src/getargs.h 2008-11-02 22:55:49.000000000 +0100
-+++ bison-2.4.1_pre20081111/src/getargs.h 2008-11-07 22:48:57.000000000 +0100
-@@ -1,9 +1,9 @@
- /* Parse command line arguments for bison.
-
- Copyright (C) 1984, 1986, 1989, 1992, 2000, 2001, 2002, 2003, 2004,
-- 2005, 2006, 2007 Free Software Foundation, Inc.
-+ 2005, 2006, 2007, 2008 Free Software Foundation, Inc.
-
- This file is part of Bison, the GNU Compiler Compiler.
-
- This program is free software: you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
-@@ -22,15 +22,17 @@
- # define GETARGS_H_
-
+diff --git a/src/getargs.h b/src/getargs.h
+index c9e3f48..8d27e71 100644
+--- a/src/getargs.h
++++ b/src/getargs.h
+@@ -24,11 +24,13 @@
#include "location.h"
extern char *program_name;
@@ -65,11 +71,7 @@ diff -NrU5 bison/src/getargs.h bison-2.4.1_pre20081111/src/getargs.h
/* for -I */
extern char const *include;
-
- extern bool debug_flag; /* for -t */
-@@ -66,10 +68,11 @@
- char src_extension[sizeof ".java"];
- char header_extension[sizeof ".java"];
+@@ -68,6 +70,7 @@ struct bison_language
bool add_tab;
};
@@ -77,33 +79,10 @@ diff -NrU5 bison/src/getargs.h bison-2.4.1_pre20081111/src/getargs.h
extern struct bison_language const *language;
/*-----------.
- | --report. |
- `-----------*/
-diff -NrU5 bison/src/parse-gram.c bison-2.4.1_pre20081111/src/parse-gram.c
---- bison/src/parse-gram.c 2008-11-02 22:55:49.000000000 +0100
-+++ bison-2.4.1_pre20081111/src/parse-gram.c 2008-11-07 22:48:57.000000000 +0100
-@@ -1,7 +1,7 @@
-
--/* A Bison parser, made by GNU Bison 2.3b.21-d67c5-dirty. */
-+/* A Bison parser, made by GNU Bison 2.4.4-738cd. */
-
- /* Skeleton implementation for Bison's Yacc-like parsers in C
-
- Copyright (C) 1984, 1989, 1990, 2000, 2001, 2002, 2003, 2004, 2005, 2006
- Free Software Foundation, Inc.
-@@ -44,11 +44,11 @@
-
- /* Identify Bison output. */
- #define YYBISON 1
-
- /* Bison version. */
--#define YYBISON_VERSION "2.3b.21-d67c5-dirty"
-+#define YYBISON_VERSION "2.4.4-738cd"
-
- /* Skeleton name. */
- #define YYSKELETON_NAME "yacc.c"
-
- /* Pure parsers. */
+diff --git a/src/parse-gram.c b/src/parse-gram.c
+index 76d25ef..ecb1cae 100644
+--- a/src/parse-gram.c
++++ b/src/parse-gram.c
@@ -1992,11 +1992,11 @@
case 18:
@@ -130,21 +109,10 @@ diff -NrU5 bison/src/parse-gram.c bison-2.4.1_pre20081111/src/parse-gram.c
case 31:
-diff -NrU5 bison/src/parse-gram.h bison-2.4.1_pre20081111/src/parse-gram.h
---- bison/src/parse-gram.h 2008-11-02 22:55:49.000000000 +0100
-+++ bison-2.4.1_pre20081111/src/parse-gram.h 2008-11-07 22:48:57.000000000 +0100
-@@ -1,7 +1,7 @@
-
--/* A Bison parser, made by GNU Bison 2.3b.21-d67c5-dirty. */
-+/* A Bison parser, made by GNU Bison 2.4.4-738cd. */
-
- /* Skeleton interface for Bison's Yacc-like parsers in C
-
- Copyright (C) 1984, 1989, 1990, 2000, 2001, 2002, 2003, 2004, 2005, 2006
- Free Software Foundation, Inc.
-diff -NrU5 bison/src/parse-gram.y bison-2.4.1_pre20081111/src/parse-gram.y
---- bison/src/parse-gram.y 2008-11-02 22:55:49.000000000 +0100
-+++ bison-2.4.1_pre20081111/src/parse-gram.y 2008-11-07 22:48:57.000000000 +0100
+diff --git a/src/parse-gram.y b/src/parse-gram.y
+index a1740e7..cae4fb7 100644
+--- a/src/parse-gram.y
++++ b/src/parse-gram.y
@@ -252,11 +252,11 @@
code_props_translate_code (&action);
gram_scanner_last_string_free ();
@@ -171,22 +139,30 @@ diff -NrU5 bison/src/parse-gram.y bison-2.4.1_pre20081111/src/parse-gram.y
| "%verbose" { report_flag |= report_states; }
| "%yacc" { yacc_flag = true; }
| /*FIXME: Err? What is this horror doing here? */ ";"
-diff -NrU5 bison/src/scan-code.l bison-2.4.1_pre20081111/src/scan-code.l
---- bison/src/scan-code.l 2008-11-02 22:55:49.000000000 +0100
-+++ bison-2.4.1_pre20081111/src/scan-code.l 2008-11-07 22:48:57.000000000 +0100
-@@ -1,8 +1,8 @@
- /* Bison Action Scanner -*- C -*-
-
-- Copyright (C) 2006, 2007 Free Software Foundation, Inc.
-+ Copyright (C) 2006, 2007, 2008 Free Software Foundation, Inc.
-
- This file is part of Bison, the GNU Compiler Compiler.
-
- This program is free software: you can redistribute it and/or modify
- it under the terms of the GNU General Public License as published by
-@@ -168,27 +168,30 @@
- obstack_sgrow (&obstack_for_string, "@@");
- }
+
+From 58bd33b7fc5d13fbd4b61404e1e878ab3b3c16da Mon Sep 17 00:00:00 2001
+From: Joel E. Denny <jdenny@ces.clemson.edu>
+Date: Tue, 4 Nov 2008 15:03:00 -0500
+Subject: [PATCH] Fix user actions without a trailing semicolon.
+
+Reported by Sergei Steshenko at
+<http://lists.gnu.org/archive/html/bug-bison/2008-11/msg00001.html>.
+* THANKS (Sergei Steshenko): Add.
+* src/scan-code.l (SC_RULE_ACTION): Fix it.
+* tests/regression.at (Fix user actions without a trailing semicolon):
+New test case.
+---
+ ChangeLog | 10 ++++++++++
+ THANKS | 1 +
+ src/scan-code.l | 4 ++--
+ tests/regression.at | 26 +++++++++++++++++++++++++-
+ 4 files changed, 38 insertions(+), 3 deletions(-)
+
+diff --git a/src/scan-code.l b/src/scan-code.l
+index 630d45d..71c9076 100644
+--- a/src/scan-code.l
++++ b/src/scan-code.l
+@@ -170,7 +170,7 @@ splice (\\[ \f\t\v]*\n)*
"{" STRING_GROW; ++braces_level;
"}" {
@@ -195,6 +171,26 @@ diff -NrU5 bison/src/scan-code.l bison-2.4.1_pre20081111/src/scan-code.l
/* As an undocumented Bison extension, append `;' before the last
brace in braced code, so that the user code can omit trailing
+
+From d9a9b96bb51bf5430deaba9c5f274d5f56f0fea9 Mon Sep 17 00:00:00 2001
+From: Joel E. Denny <jdenny@ces.clemson.edu>
+Date: Fri, 7 Nov 2008 17:21:23 -0500
+Subject: [PATCH] Don't add a semicolon to actions for %skeleton or %language.
+
+It breaks Java test cases as reported by Akim Demaille.
+* src/scan-code.l: Implement.
+---
+ ChangeLog | 6 ++++++
+ src/scan-code.l | 7 +++++--
+ 2 files changed, 11 insertions(+), 2 deletions(-)
+
+diff --git a/src/scan-code.l b/src/scan-code.l
+index 71c9076..13a78c2 100644
+--- a/src/scan-code.l
++++ b/src/scan-code.l
+@@ -175,7 +175,9 @@ splice (\\[ \f\t\v]*\n)*
+ /* As an undocumented Bison extension, append `;' before the last
+ brace in braced code, so that the user code can omit trailing
`;'. But do not append `;' if emulating Yacc, since Yacc does
- not append one.
+ not append one. Also, some output languages (like Java) do not
@@ -203,10 +199,7 @@ diff -NrU5 bison/src/scan-code.l bison-2.4.1_pre20081111/src/scan-code.l
FIXME: Bison should warn if a semicolon seems to be necessary
here, and should omit the semicolon if it seems unnecessary
- (e.g., after ';', '{', or '}', each followed by comments or
- white space). Such a warning shouldn't depend on --yacc; it
- should depend on a new --pedantic option, which would cause
- Bison to warn if it detects an extension to POSIX. --pedantic
+@@ -186,7 +188,8 @@ splice (\\[ \f\t\v]*\n)*
should also diagnose other Bison extensions like %yacc.
Perhaps there should also be a GCC-style --pedantic-errors
option, so that such warnings are diagnosed as errors. */
@@ -216,5 +209,3 @@ diff -NrU5 bison/src/scan-code.l bison-2.4.1_pre20081111/src/scan-code.l
obstack_1grow (&obstack_for_string, ';');
STRING_GROW;
- }
- }